summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernard Cafarelli <voyageur@gentoo.org>2008-10-09 14:36:11 +0000
committerBernard Cafarelli <voyageur@gentoo.org>2008-10-09 14:36:11 +0000
commita8f5b1dd07e96255b2f731c6ecfd89e89b2f4d91 (patch)
treec9e30f1410476df77bd0bb5071832fe16c0a59ea /gnustep-apps/gworkspace/gworkspace-0.8.7.ebuild
parenttypo, missed an E in RDEPEND (diff)
downloadgentoo-2-a8f5b1dd07e96255b2f731c6ecfd89e89b2f4d91.tar.gz
gentoo-2-a8f5b1dd07e96255b2f731c6ecfd89e89b2f4d91.tar.bz2
gentoo-2-a8f5b1dd07e96255b2f731c6ecfd89e89b2f4d91.zip
Version bump, update homepage. No poppler patch for now
(Portage version: 2.2_rc11/cvs/Linux 2.6.26-gentoo x86_64)
Diffstat (limited to 'gnustep-apps/gworkspace/gworkspace-0.8.7.ebuild')
-rw-r--r--gnustep-apps/gworkspace/gworkspace-0.8.7.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/gnustep-apps/gworkspace/gworkspace-0.8.7.ebuild b/gnustep-apps/gworkspace/gworkspace-0.8.7.ebuild
new file mode 100644
index 000000000000..703fca363891
--- /dev/null
+++ b/gnustep-apps/gworkspace/gworkspace-0.8.7.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/gnustep-apps/gworkspace/gworkspace-0.8.7.ebuild,v 1.1 2008/10/09 14:36:11 voyageur Exp $
+
+inherit gnustep-2
+
+DESCRIPTION="A workspace manager for GNUstep"
+HOMEPAGE="http://www.gnustep.org/experience/GWorkspace.html"
+SRC_URI="ftp://ftp.gnustep.org/pub/gnustep/usr-apps/${P}.tar.gz"
+
+KEYWORDS="~amd64 ~ppc ~x86"
+LICENSE="GPL-2"
+SLOT="0"
+
+#pdf support disabled, needs updated popplerkit patch
+IUSE=""
+DEPEND=">=gnustep-apps/systempreferences-1.0.1_p24791
+ >=dev-db/sqlite-3.2.8"
+RDEPEND="!gnustep-apps/desktop
+ !gnustep-apps/recycler"
+
+src_compile() {
+ local myconf=""
+
+ use kernel_linux && myconf="${myconf} --with-inotify"
+
+ egnustep_env
+ econf ${myconf}
+ egnustep_make
+}
+
+src_install() {
+ egnustep_env
+ egnustep_install
+
+ if use doc;
+ then
+ dodir /usr/share/doc/${PF}
+ cp "${S}"/Documentation/*.pdf "${D}"/usr/share/doc/${PF}
+ fi
+}