summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2008-10-23 21:57:39 +0000
committerGilles Dartiguelongue <eva@gentoo.org>2008-10-23 21:57:39 +0000
commitf58705e46b094e91aa87ce72a28e052ed3a9c422 (patch)
treeadc8b2dd313697f86e18cb6e48477d2c655c160c /gnome-extra
parentadd empty IUSE to make repoman happy (diff)
downloadgentoo-2-f58705e46b094e91aa87ce72a28e052ed3a9c422.tar.gz
gentoo-2-f58705e46b094e91aa87ce72a28e052ed3a9c422.tar.bz2
gentoo-2-f58705e46b094e91aa87ce72a28e052ed3a9c422.zip
Bump to 2.24.1, properly handle fix day of the week in all locales.
(Portage version: 2.2_rc12/cvs/Linux 2.6.24-gentoo-r8-mactel x86_64)
Diffstat (limited to 'gnome-extra')
-rw-r--r--gnome-extra/hamster-applet/ChangeLog8
-rw-r--r--gnome-extra/hamster-applet/hamster-applet-2.24.1.ebuild77
2 files changed, 84 insertions, 1 deletions
diff --git a/gnome-extra/hamster-applet/ChangeLog b/gnome-extra/hamster-applet/ChangeLog
index 234e7e1d2273..b1afb40c9c55 100644
--- a/gnome-extra/hamster-applet/ChangeLog
+++ b/gnome-extra/hamster-applet/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for gnome-extra/hamster-applet
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-extra/hamster-applet/ChangeLog,v 1.1 2008/10/19 20:07:14 eva Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnome-extra/hamster-applet/ChangeLog,v 1.2 2008/10/23 21:57:39 eva Exp $
+
+*hamster-applet-2.24.1 (23 Oct 2008)
+
+ 23 Oct 2008; Gilles Dartiguelongue <eva@gentoo.org>
+ +hamster-applet-2.24.1.ebuild:
+ Bump to 2.24.1, properly handle fix day of the week in all locales.
*hamster-applet-2.24.0 (19 Oct 2008)
diff --git a/gnome-extra/hamster-applet/hamster-applet-2.24.1.ebuild b/gnome-extra/hamster-applet/hamster-applet-2.24.1.ebuild
new file mode 100644
index 000000000000..b05bee7e5a89
--- /dev/null
+++ b/gnome-extra/hamster-applet/hamster-applet-2.24.1.ebuild
@@ -0,0 +1,77 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/gnome-extra/hamster-applet/hamster-applet-2.24.1.ebuild,v 1.1 2008/10/23 21:57:39 eva Exp $
+EAPI=1
+
+GCONF_DEBUG="no"
+SCROLLKEEPER_UPDATE="no"
+
+inherit autotools eutils gnome2 python
+
+DESCRIPTION="Time tracking for the masses, in a GNOME applet"
+HOMEPAGE="http://projecthamster.wordpress.com/"
+
+# license on homepage is out-of-date, was changed to GPL-2 on 2008-04-16
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="eds"
+
+RDEPEND="
+ || ( >=dev-lang/python-2.5
+ ( dev-lang/python:2.4
+ dev-python/pysqlite:2 ) )
+ dev-python/gnome-applets-python
+ dev-python/gconf-python
+ dev-python/dbus-python
+ eds? ( dev-python/evolution-python )
+ >=dev-python/pygobject-2.14
+ >=dev-python/pygtk-2.12
+ >=x11-libs/gtk+-2.12
+ x11-libs/libXScrnSaver"
+
+DEPEND="${RDEPEND}
+ x11-proto/scrnsaverproto
+ >=dev-util/intltool-0.37.1
+ dev-util/pkgconfig
+ sys-devel/gettext"
+
+DOCS="AUTHORS ChangeLog NEWS README"
+
+pkg_setup() {
+ local msg="Rebuild dev-lang/python-2.5 with the sqlite USE flag"
+ if has_version dev-lang/python 2.5; then
+ if ! built_with_use dev-lang/python sqlite; then
+ eerror "${msg}"
+ die "${msg}"
+ fi
+ fi
+}
+
+src_unpack() {
+ gnome2_src_unpack
+
+ # Allow use of python 2.5, upstream bug #554249
+ epatch "${FILESDIR}/${PN}-2.24.0-python25.patch"
+
+ # Remove dependency on gnome-vfs, upstream bug #554250
+ epatch "${FILESDIR}/${PN}-2.24.0-gnomevfs.patch"
+
+ AT_M4DIR="m4" eautoreconf
+
+ # disable pyc compiling
+ mv py-compile py-compile.orig
+ ln -s $(type -P true) py-compile
+}
+
+pkg_postinst() {
+ gnome2_pkg_postinst
+
+ python_version
+ python_mod_optimize /usr/$(get_libdir)/python${PYVER}/site-packages/hamster
+}
+
+pkg_postrm() {
+ gnome2_pkg_postrm
+ python_mod_cleanup /usr/$(get_libdir)/python*/site-packages/hamster
+}