summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2009-02-01 10:27:50 +0000
committerGilles Dartiguelongue <eva@gentoo.org>2009-02-01 10:27:50 +0000
commitc6da9b3cd3d98ccf4676b0483b11179c70968c13 (patch)
treeb32282cd60bffce4b5d161b6a6f622d5cd93ce78 /gnome-extra
parentBump to 2.24.4. Tons of bug fixes. (diff)
downloadgentoo-2-c6da9b3cd3d98ccf4676b0483b11179c70968c13.tar.gz
gentoo-2-c6da9b3cd3d98ccf4676b0483b11179c70968c13.tar.bz2
gentoo-2-c6da9b3cd3d98ccf4676b0483b11179c70968c13.zip
Bump to 2.24.4. Bug fixes.
(Portage version: 2.2_rc23/cvs/Linux x86_64)
Diffstat (limited to 'gnome-extra')
-rw-r--r--gnome-extra/evolution-exchange/ChangeLog10
-rw-r--r--gnome-extra/evolution-exchange/evolution-exchange-2.24.4.ebuild55
2 files changed, 63 insertions, 2 deletions
diff --git a/gnome-extra/evolution-exchange/ChangeLog b/gnome-extra/evolution-exchange/ChangeLog
index d81bbdbb4480..b98eb2511158 100644
--- a/gnome-extra/evolution-exchange/ChangeLog
+++ b/gnome-extra/evolution-exchange/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for gnome-extra/evolution-exchange
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-extra/evolution-exchange/ChangeLog,v 1.80 2008/12/20 17:34:05 nixnut Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/gnome-extra/evolution-exchange/ChangeLog,v 1.81 2009/02/01 10:27:50 eva Exp $
+
+*evolution-exchange-2.24.4 (01 Feb 2009)
+
+ 01 Feb 2009; Gilles Dartiguelongue <eva@gentoo.org>
+ +evolution-exchange-2.24.4.ebuild:
+ Bump to 2.24.4. Bug fixes.
20 Dec 2008; nixnut <nixnut@gentoo.org>
evolution-exchange-2.22.3-r2.ebuild:
diff --git a/gnome-extra/evolution-exchange/evolution-exchange-2.24.4.ebuild b/gnome-extra/evolution-exchange/evolution-exchange-2.24.4.ebuild
new file mode 100644
index 000000000000..e68f22b0d675
--- /dev/null
+++ b/gnome-extra/evolution-exchange/evolution-exchange-2.24.4.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/gnome-extra/evolution-exchange/evolution-exchange-2.24.4.ebuild,v 1.1 2009/02/01 10:27:50 eva Exp $
+
+EAPI="1"
+
+inherit eutils gnome2
+
+DESCRIPTION="Evolution module for connecting to Microsoft Exchange"
+HOMEPAGE="http://www.novell.com/products/desktop/features/evolution.html"
+LICENSE="GPL-2"
+
+SLOT="2.0"
+KEYWORDS="~amd64 ~hppa ~ppc ~sparc ~x86"
+IUSE="debug doc static"
+
+RDEPEND="
+ >=mail-client/evolution-2.24.3
+ >=dev-libs/glib-2.16.0
+ >=x11-libs/gtk+-2.10
+ >=gnome-base/gconf-2.0
+ >=gnome-base/libbonobo-2.20.3
+ >=gnome-base/libglade-2.0
+ >=gnome-base/libgnomeui-2.0
+ dev-libs/libxml2
+ net-libs/libsoup:2.4
+ >=gnome-extra/evolution-data-server-2.24.3
+ >=net-nds/openldap-2.1.30-r2"
+
+DEPEND="${RDEPEND}
+ >=dev-util/intltool-0.40
+ dev-util/pkgconfig
+ doc? ( >=dev-util/gtk-doc-1 )"
+
+DOCS="AUTHORS ChangeLog NEWS README"
+
+pkg_setup() {
+ G2CONF="${G2CONF} $(use_with debug e2k-debug)"
+
+ if ! built_with_use gnome-extra/evolution-data-server ldap || ! built_with_use gnome-extra/evolution-data-server kerberos; then
+ eerror "Please re-emerge gnome-extra/evolution-data-server with"
+ eerror "the use flags ldap and kerberos."
+ die
+ fi
+
+ G2CONF="${G2CONF} $(use_with static static-ldap) --with-openldap"
+}
+
+src_unpack() {
+ gnome2_src_unpack
+
+ # intltoolize because e-e won't install locales otherwise
+ # thanks to recent intltool, no need to eautoreconf/eautomake
+ intltoolize --force --copy --automake || die "intltoolize failed"
+}