summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexandre Rostovtsev <tetromino@gentoo.org>2012-03-14 03:46:32 +0000
committerAlexandre Rostovtsev <tetromino@gentoo.org>2012-03-14 03:46:32 +0000
commitaef60d777cf60765399f958dc209782cd884788c (patch)
tree9705807bb5e30fe606371ca070499dddfffe5d2d /gnome-extra
parentAdd missing dependency: kde-base/kdelibs and x11-libs/qt-assistant. Bug #405577 (diff)
downloadgentoo-2-aef60d777cf60765399f958dc209782cd884788c.tar.gz
gentoo-2-aef60d777cf60765399f958dc209782cd884788c.tar.bz2
gentoo-2-aef60d777cf60765399f958dc209782cd884788c.zip
Fix the argyll-dispcal patch so it works properly (bug #407319).
(Portage version: 2.2.0_alpha90/cvs/Linux x86_64)
Diffstat (limited to 'gnome-extra')
-rw-r--r--gnome-extra/gnome-color-manager/ChangeLog9
-rw-r--r--gnome-extra/gnome-color-manager/files/gnome-color-manager-3.2.2-argyll-prefix.patch90
-rw-r--r--gnome-extra/gnome-color-manager/gnome-color-manager-3.2.2-r2.ebuild (renamed from gnome-extra/gnome-color-manager/gnome-color-manager-3.2.2-r1.ebuild)5
3 files changed, 93 insertions, 11 deletions
diff --git a/gnome-extra/gnome-color-manager/ChangeLog b/gnome-extra/gnome-color-manager/ChangeLog
index 27689851367e..44794d9015a8 100644
--- a/gnome-extra/gnome-color-manager/ChangeLog
+++ b/gnome-extra/gnome-color-manager/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for gnome-extra/gnome-color-manager
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-extra/gnome-color-manager/ChangeLog,v 1.14 2012/03/07 23:04:30 tetromino Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnome-extra/gnome-color-manager/ChangeLog,v 1.15 2012/03/14 03:46:32 tetromino Exp $
+
+*gnome-color-manager-3.2.2-r2 (14 Mar 2012)
+
+ 14 Mar 2012; Alexandre Rostovtsev <tetromino@gentoo.org>
+ -gnome-color-manager-3.2.2-r1.ebuild, +gnome-color-manager-3.2.2-r2.ebuild,
+ files/gnome-color-manager-3.2.2-argyll-prefix.patch:
+ Fix the argyll-dispcal patch so it works properly (bug #407319).
*gnome-color-manager-3.2.2-r1 (07 Mar 2012)
diff --git a/gnome-extra/gnome-color-manager/files/gnome-color-manager-3.2.2-argyll-prefix.patch b/gnome-extra/gnome-color-manager/files/gnome-color-manager-3.2.2-argyll-prefix.patch
index eefc666ac181..bc0906fbcd3d 100644
--- a/gnome-extra/gnome-color-manager/files/gnome-color-manager-3.2.2-argyll-prefix.patch
+++ b/gnome-extra/gnome-color-manager/files/gnome-color-manager-3.2.2-argyll-prefix.patch
@@ -1,25 +1,99 @@
-From 054fb4c0eb69a9ace62053f9c1b32f2ca6fc2a5c Mon Sep 17 00:00:00 2001
+From 240cd5ab5ec100af64bc337f60ffe4cc8eb98389 Mon Sep 17 00:00:00 2001
From: Alexandre Rostovtsev <tetromino@gentoo.org>
Date: Wed, 7 Mar 2012 17:51:55 -0500
-Subject: [PATCH] argyllcms executables in Gentoo are prefixed with "argyll-"
+Subject: [PATCH] Use gcm_calibrate_argyll_get_tool_filename () for dispcal
+Do not assume that dispcal is /usr/bin/dispcal; in some distros (e.g.
+Gentoo), it's argyll-dispcal.
+
+https://bugzilla.gnome.org/show_bug.cgi?id=672028
---
- src/gcm-calibrate-argyll.c | 2 +-
- 1 files changed, 1 insertions(+), 1 deletions(-)
+ src/gcm-calibrate-argyll.c | 11 ++++++++---
+ src/gcm-calibrate-argyll.h | 6 ++++--
+ src/gcm-calibrate-main.c | 7 +++++--
+ 3 files changed, 17 insertions(+), 7 deletions(-)
diff --git a/src/gcm-calibrate-argyll.c b/src/gcm-calibrate-argyll.c
-index 3f04aa1..393537c 100644
+index 3f04aa1..4d9386d 100644
--- a/src/gcm-calibrate-argyll.c
+++ b/src/gcm-calibrate-argyll.c
-@@ -125,7 +125,7 @@ gcm_calibrate_argyll_get_display (const gchar *output_name, GError **error)
- gchar *name;
+@@ -122,10 +122,14 @@ gcm_calibrate_argyll_get_display (const gchar *output_name, GError **error)
+ gint exit_status;
+ guint display = G_MAXUINT;
+ guint i;
+- gchar *name;
++ gchar *command, *name;
++
++ command = gcm_calibrate_argyll_get_tool_filename ("dispcal", error);
++ if (command == NULL)
++ goto out;
/* execute it and capture stderr */
- ret = g_spawn_command_line_sync ("dispcal", NULL, &data, &exit_status, error);
-+ ret = g_spawn_command_line_sync ("argyll-dispcal", NULL, &data, &exit_status, error);
++ ret = g_spawn_command_line_sync (command, NULL, &data, &exit_status, error);
if (!ret)
goto out;
+@@ -157,6 +161,7 @@ gcm_calibrate_argyll_get_display (const gchar *output_name, GError **error)
+ goto out;
+ }
+ out:
++ g_free (command);
+ g_free (data);
+ g_strfreev (split);
+ return display;
+@@ -198,7 +203,7 @@ gcm_calibrate_argyll_debug_argv (const gchar *program, gchar **argv)
+ /**
+ * gcm_calibrate_argyll_get_tool_filename:
+ **/
+-static gchar *
++gchar *
+ gcm_calibrate_argyll_get_tool_filename (const gchar *command, GError **error)
+ {
+ gboolean ret;
+diff --git a/src/gcm-calibrate-argyll.h b/src/gcm-calibrate-argyll.h
+index e1c84e5..9d98286 100644
+--- a/src/gcm-calibrate-argyll.h
++++ b/src/gcm-calibrate-argyll.h
+@@ -48,8 +48,10 @@ struct _GcmCalibrateArgyllClass
+ GcmCalibrateClass parent_class;
+ };
+
+-GType gcm_calibrate_argyll_get_type (void);
+-GcmCalibrate *gcm_calibrate_argyll_new (void);
++GType gcm_calibrate_argyll_get_type (void);
++GcmCalibrate *gcm_calibrate_argyll_new (void);
++gchar *gcm_calibrate_argyll_get_tool_filename (const gchar *command,
++ GError **error);
+
+ G_END_DECLS
+
+diff --git a/src/gcm-calibrate-main.c b/src/gcm-calibrate-main.c
+index 901a428..9ad57cb 100644
+--- a/src/gcm-calibrate-main.c
++++ b/src/gcm-calibrate-main.c
+@@ -1774,6 +1774,7 @@ gcm_calib_add_pages (GcmCalibratePriv *calib)
+ {
+ gboolean ret;
+ const gchar *xrandr_name;
++ gchar *command;
+
+ /* device not found */
+ if (calib->device_kind == CD_DEVICE_KIND_UNKNOWN) {
+@@ -1789,9 +1790,11 @@ gcm_calib_add_pages (GcmCalibratePriv *calib)
+ gcm_calib_setup_page_sensor (calib);
+
+ /* find whether argyllcms is installed using a tool which should exist */
+- ret = g_file_test ("/usr/bin/dispcal", G_FILE_TEST_EXISTS);
+- if (!ret)
++ command = gcm_calibrate_argyll_get_tool_filename ("dispcal", NULL);
++ if (command == NULL)
+ gcm_calib_setup_page_install_argyllcms (calib);
++ else
++ g_free (command);
+
+ xrandr_name = cd_device_get_metadata_item (calib->device,
+ CD_DEVICE_METADATA_XRANDR_NAME);
--
1.7.8.5
diff --git a/gnome-extra/gnome-color-manager/gnome-color-manager-3.2.2-r1.ebuild b/gnome-extra/gnome-color-manager/gnome-color-manager-3.2.2-r2.ebuild
index 7e6544f34058..5eb64553940b 100644
--- a/gnome-extra/gnome-color-manager/gnome-color-manager-3.2.2-r1.ebuild
+++ b/gnome-extra/gnome-color-manager/gnome-color-manager-3.2.2-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-extra/gnome-color-manager/gnome-color-manager-3.2.2-r1.ebuild,v 1.1 2012/03/07 23:04:30 tetromino Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnome-extra/gnome-color-manager/gnome-color-manager-3.2.2-r2.ebuild,v 1.1 2012/03/14 03:46:32 tetromino Exp $
EAPI="4"
GCONF_DEBUG="no"
@@ -64,7 +64,8 @@ pkg_setup() {
}
src_prepare() {
- # argyllcms executables are prefixed with "argyll-" in Gentoo; bug #407319
+ # argyllcms executables are prefixed with "argyll-" in Gentoo; bug #407319,
+ # https://bugzilla.gnome.org/show_bug.cgi?id=672028
epatch "${FILESDIR}/${PN}-3.2.2-argyll-prefix.patch"
gnome2_src_prepare