summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2009-10-29 22:05:08 +0000
committerGilles Dartiguelongue <eva@gentoo.org>2009-10-29 22:05:08 +0000
commitacf7508b68c627b123ca3b6d057b808bc3e926e1 (patch)
tree85dfb15421d2bf331da944861e502cd9c2ac3fa8 /gnome-extra
parentDrop down the added blockers since they does not work how i expected. (diff)
downloadgentoo-2-acf7508b68c627b123ca3b6d057b808bc3e926e1.tar.gz
gentoo-2-acf7508b68c627b123ca3b6d057b808bc3e926e1.tar.bz2
gentoo-2-acf7508b68c627b123ca3b6d057b808bc3e926e1.zip
Initial ebuild for GNOME 2.28.
(Portage version: 2.2_rc46/cvs/Linux x86_64)
Diffstat (limited to 'gnome-extra')
-rw-r--r--gnome-extra/bug-buddy/ChangeLog8
-rw-r--r--gnome-extra/bug-buddy/bug-buddy-2.28.0.ebuild42
2 files changed, 49 insertions, 1 deletions
diff --git a/gnome-extra/bug-buddy/ChangeLog b/gnome-extra/bug-buddy/ChangeLog
index 547b26075f87..39e638338348 100644
--- a/gnome-extra/bug-buddy/ChangeLog
+++ b/gnome-extra/bug-buddy/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for gnome-extra/bug-buddy
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-extra/bug-buddy/ChangeLog,v 1.166 2009/10/24 17:04:13 nixnut Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnome-extra/bug-buddy/ChangeLog,v 1.167 2009/10/29 22:05:08 eva Exp $
+
+*bug-buddy-2.28.0 (29 Oct 2009)
+
+ 29 Oct 2009; Gilles Dartiguelongue <eva@gentoo.org>
+ +bug-buddy-2.28.0.ebuild:
+ Initial ebuild for GNOME 2.28.
24 Oct 2009; nixnut <nixnut@gentoo.org> ChangeLog:
ppc stable #281427
diff --git a/gnome-extra/bug-buddy/bug-buddy-2.28.0.ebuild b/gnome-extra/bug-buddy/bug-buddy-2.28.0.ebuild
new file mode 100644
index 000000000000..024ddf419503
--- /dev/null
+++ b/gnome-extra/bug-buddy/bug-buddy-2.28.0.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/gnome-extra/bug-buddy/bug-buddy-2.28.0.ebuild,v 1.1 2009/10/29 22:05:08 eva Exp $
+
+GCONF_DEBUG="no"
+
+inherit gnome2
+
+DESCRIPTION="A graphical bug reporting tool"
+HOMEPAGE="http://www.gnome.org/"
+
+LICENSE="Ximian-logos GPL-2"
+SLOT="2"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="eds"
+
+# Articifially raise gtk+ dep to support loading through XSettings
+RDEPEND=">=gnome-base/libbonobo-2
+ >=dev-libs/glib-2.16.0
+ >=dev-libs/libxml2-2.4.6
+ >=x11-libs/gtk+-2.14.0
+ >=net-libs/libsoup-2.4
+ >=gnome-base/libgtop-2.13.3
+ eds? ( >=gnome-extra/evolution-data-server-1.3 )
+ >=gnome-base/gconf-2
+ || ( dev-libs/elfutils dev-libs/libelf )
+ >=sys-devel/gdb-5.1"
+
+DEPEND=${RDEPEND}"
+ >=app-text/gnome-doc-utils-0.3.2
+ >=dev-util/pkgconfig-0.9
+ >=dev-util/intltool-0.40"
+
+DOCS="AUTHORS ChangeLog NEWS README TODO"
+
+pkg_setup() {
+ # Google-breakpad seems to support only x86.
+ # It is mostly useless for a distro like gentoo. Disable for now.
+ G2CONF="${G2CONF}
+ --disable-google-breakpad
+ $(use_enable eds)"
+}