summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexandre Rostovtsev <tetromino@gentoo.org>2011-10-31 07:43:52 +0000
committerAlexandre Rostovtsev <tetromino@gentoo.org>2011-10-31 07:43:52 +0000
commit8f5cf001f412afc9968ebbb94546397112372c77 (patch)
tree592d5b18c013706f6f077cf099a75ed4a47dac0e /gnome-extra
parentBump to 3.2.1 from the gnome overlay. Add a patch to fix building when clutte... (diff)
downloadgentoo-2-8f5cf001f412afc9968ebbb94546397112372c77.tar.gz
gentoo-2-8f5cf001f412afc9968ebbb94546397112372c77.tar.bz2
gentoo-2-8f5cf001f412afc9968ebbb94546397112372c77.zip
Bump to 3.2.1 from the gnome overlay. Drop alpha, ia64, ppc, ppc64, sparc keywords because evolution-3.2 and evolution-data-server-3.2 are not keyworded there. Keywording bug will be filed later for all of gnome-3.2.
(Portage version: 2.2.0_alpha72/cvs/Linux x86_64)
Diffstat (limited to 'gnome-extra')
-rw-r--r--gnome-extra/evolution-exchange/ChangeLog10
-rw-r--r--gnome-extra/evolution-exchange/evolution-exchange-3.2.1.ebuild52
2 files changed, 61 insertions, 1 deletions
diff --git a/gnome-extra/evolution-exchange/ChangeLog b/gnome-extra/evolution-exchange/ChangeLog
index 8ca1afe99318..3405b4dd2bdc 100644
--- a/gnome-extra/evolution-exchange/ChangeLog
+++ b/gnome-extra/evolution-exchange/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for gnome-extra/evolution-exchange
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-extra/evolution-exchange/ChangeLog,v 1.142 2011/10/30 16:20:17 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnome-extra/evolution-exchange/ChangeLog,v 1.143 2011/10/31 07:43:52 tetromino Exp $
+
+*evolution-exchange-3.2.1 (31 Oct 2011)
+
+ 31 Oct 2011; Alexandre Rostovtsev <tetromino@gentoo.org>
+ +evolution-exchange-3.2.1.ebuild:
+ Bump to 3.2.1 from the gnome overlay. Drop alpha, ia64, ppc, ppc64, sparc
+ keywords because evolution-3.2 and evolution-data-server-3.2 are not
+ keyworded there.
30 Oct 2011; Raúl Porcel <armin76@gentoo.org>
evolution-exchange-2.32.3.ebuild:
diff --git a/gnome-extra/evolution-exchange/evolution-exchange-3.2.1.ebuild b/gnome-extra/evolution-exchange/evolution-exchange-3.2.1.ebuild
new file mode 100644
index 000000000000..a511746bae58
--- /dev/null
+++ b/gnome-extra/evolution-exchange/evolution-exchange-3.2.1.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/gnome-extra/evolution-exchange/evolution-exchange-3.2.1.ebuild,v 1.1 2011/10/31 07:43:52 tetromino Exp $
+
+EAPI="4"
+GCONF_DEBUG="yes"
+GNOME2_LA_PUNT="yes"
+
+inherit gnome2
+
+DESCRIPTION="Evolution module for connecting to Microsoft Exchange"
+HOMEPAGE="http://projects.gnome.org/evolution/"
+LICENSE="GPL-2"
+
+SLOT="2.0"
+IUSE="debug doc static"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ >=mail-client/evolution-${PV}:2.0
+ >=gnome-extra/evolution-data-server-${PV}[ldap,kerberos]
+ >=dev-libs/glib-2.28:2
+ >=x11-libs/gtk+-3.0:3
+ >=gnome-base/gconf-2:2
+ dev-libs/libxml2:2
+ net-libs/libsoup:2.4
+ >=net-nds/openldap-2.1.30-r2
+ virtual/krb5"
+
+DEPEND="${RDEPEND}
+ >=dev-util/intltool-0.40
+ dev-util/pkgconfig
+ doc? ( >=dev-util/gtk-doc-1.9 )"
+
+pkg_setup() {
+ G2CONF="${G2CONF}
+ --with-krb5=${EPREFIX}/usr
+ --with-openldap
+ --disable-static
+ $(use_enable debug e2k-debug)
+ $(use_with static static-ldap)"
+ DOCS="AUTHORS ChangeLog NEWS README"
+}
+
+src_prepare() {
+ gnome2_src_prepare
+
+ # FIXME: Fix compilation flags crazyness
+ # Touch configure.ac if eautoreconf
+ sed 's/^\(AM_CPPFLAGS="\)$WARNING_FLAGS/\1/' \
+ -i configure || die "sed 1 failed"
+}