summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2012-04-29 18:58:06 +0000
committerPacho Ramos <pacho@gentoo.org>2012-04-29 18:58:06 +0000
commit8f2a1d670216678b16473d69f057529cdd274c29 (patch)
tree0ec6e6aa16d621be1221a242f7c07da796b08427 /gnome-extra
parentVersion bump, remove old. (diff)
downloadgentoo-2-8f2a1d670216678b16473d69f057529cdd274c29.tar.gz
gentoo-2-8f2a1d670216678b16473d69f057529cdd274c29.tar.bz2
gentoo-2-8f2a1d670216678b16473d69f057529cdd274c29.zip
Fix test compilation problems reported by Hans de Graaff in bug #413701 with upstream patch.
(Portage version: 2.1.10.57/cvs/Linux x86_64)
Diffstat (limited to 'gnome-extra')
-rw-r--r--gnome-extra/libgsf/ChangeLog7
-rw-r--r--gnome-extra/libgsf/files/libgsf-1.14.23-clone-identifier.patch133
-rw-r--r--gnome-extra/libgsf/libgsf-1.14.23.ebuild5
3 files changed, 143 insertions, 2 deletions
diff --git a/gnome-extra/libgsf/ChangeLog b/gnome-extra/libgsf/ChangeLog
index 2e32c17e1bd9..9b5bc2feef20 100644
--- a/gnome-extra/libgsf/ChangeLog
+++ b/gnome-extra/libgsf/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for gnome-extra/libgsf
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-extra/libgsf/ChangeLog,v 1.196 2012/04/29 15:52:13 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnome-extra/libgsf/ChangeLog,v 1.197 2012/04/29 18:58:06 pacho Exp $
+
+ 29 Apr 2012; Pacho Ramos <pacho@gentoo.org>
+ +files/libgsf-1.14.23-clone-identifier.patch, libgsf-1.14.23.ebuild:
+ Fix test compilation problems reported by Hans de Graaff in bug #413701 with
+ upstream patch.
29 Apr 2012; Markus Meier <maekke@gentoo.org> libgsf-1.14.22.ebuild:
x86 stable, bug #410611
diff --git a/gnome-extra/libgsf/files/libgsf-1.14.23-clone-identifier.patch b/gnome-extra/libgsf/files/libgsf-1.14.23-clone-identifier.patch
new file mode 100644
index 000000000000..d270a3134658
--- /dev/null
+++ b/gnome-extra/libgsf/files/libgsf-1.14.23-clone-identifier.patch
@@ -0,0 +1,133 @@
+From 7a4a9d62e0efa8510a9c8aa957233327d11f355b Mon Sep 17 00:00:00 2001
+From: Morten Welinder <terra@gnome.org>
+Date: Fri, 20 Apr 2012 13:54:54 +0000
+Subject: compilation: avoid identifier "clone".
+
+It clashes with the clone syscall when the wrong headers get included.
+---
+diff --git a/tests/test-cp-msole.c b/tests/test-cp-msole.c
+index e076bb4..4ed3246 100644
+--- a/tests/test-cp-msole.c
++++ b/tests/test-cp-msole.c
+@@ -34,7 +34,7 @@
+ static void clone_dir (GsfInfile *in, GsfOutfile *out);
+
+ static void
+-clone (GsfInput *input, GsfOutput *output)
++clone_ (GsfInput *input, GsfOutput *output)
+ {
+ if (gsf_input_size (input) > 0) {
+ guint8 const *data;
+@@ -87,7 +87,7 @@ clone_dir (GsfInfile *in, GsfOutfile *out)
+ gsf_infile_name_by_index (in, i),
+ is_dir);
+
+- clone (new_input, new_output);
++ clone_ (new_input, new_output);
+ }
+ /* An observation: when you think about the explanation to is_dir
+ * above, you realize that clone_dir is called even for regular files.
+@@ -137,7 +137,7 @@ test (char *argv[])
+
+ outfile = gsf_outfile_msole_new (output);
+ g_object_unref (G_OBJECT (output));
+- clone (GSF_INPUT (infile), GSF_OUTPUT (outfile));
++ clone_ (GSF_INPUT (infile), GSF_OUTPUT (outfile));
+
+ return 0;
+ }
+diff --git a/tests/test-cp-zip.c b/tests/test-cp-zip.c
+index 5523f33..3263c02 100644
+--- a/tests/test-cp-zip.c
++++ b/tests/test-cp-zip.c
+@@ -32,7 +32,7 @@
+ #include <stdio.h>
+
+ static void
+-clone (GsfInfile *in, GsfOutfile *out)
++clone_ (GsfInfile *in, GsfOutfile *out)
+ {
+ GsfInput *input = GSF_INPUT (in);
+ GsfOutput *output = GSF_OUTPUT (out);
+@@ -85,7 +85,7 @@ clone (GsfInfile *in, GsfOutfile *out)
+ output = gsf_outfile_new_child_full (out, name, is_dir,
+ "compression-level", level,
+ NULL);
+- clone (GSF_INFILE (input), GSF_OUTFILE (output));
++ clone_ (GSF_INFILE (input), GSF_OUTFILE (output));
+ }
+ }
+ gsf_output_close (GSF_OUTPUT (out));
+@@ -137,7 +137,7 @@ test (char *argv[])
+
+ outfile = gsf_outfile_zip_new (output, &err);
+ g_object_unref (G_OBJECT (output));
+- clone (infile, outfile);
++ clone_ (infile, outfile);
+
+ return 0;
+ }
+diff --git a/tests/test-dump-msole.c b/tests/test-dump-msole.c
+index 3837394..b6ef5ce 100644
+--- a/tests/test-dump-msole.c
++++ b/tests/test-dump-msole.c
+@@ -32,7 +32,7 @@
+ #include <stdio.h>
+
+ static void
+-clone (GsfInput *input, GsfOutput *output)
++clone_ (GsfInput *input, GsfOutput *output)
+ {
+ guint8 const *data;
+ size_t len;
+@@ -72,7 +72,7 @@ clone (GsfInput *input, GsfOutput *output)
+ dst = gsf_outfile_new_child (out,
+ gsf_infile_name_by_index (in, i),
+ is_dir);
+- clone (src, dst);
++ clone_ (src, dst);
+ }
+ }
+
+@@ -118,7 +118,7 @@ test (char *argv[])
+ g_error_free (err);
+ return 1;
+ }
+- clone (GSF_INPUT (infile), GSF_OUTPUT (outfile));
++ clone_ (GSF_INPUT (infile), GSF_OUTPUT (outfile));
+
+ return 0;
+ }
+diff --git a/tests/test-restore-msole.c b/tests/test-restore-msole.c
+index cfd1d68..b9c54b5 100644
+--- a/tests/test-restore-msole.c
++++ b/tests/test-restore-msole.c
+@@ -32,7 +32,7 @@
+ #include <stdio.h>
+
+ static void
+-clone (GsfInput *input, GsfOutput *output)
++clone_ (GsfInput *input, GsfOutput *output)
+ {
+ guint8 const *data;
+ size_t len;
+@@ -72,7 +72,7 @@ clone (GsfInput *input, GsfOutput *output)
+ dst = gsf_outfile_new_child (out,
+ gsf_infile_name_by_index (in, i),
+ is_dir);
+- clone (src, dst);
++ clone_ (src, dst);
+ }
+ }
+
+@@ -111,7 +111,7 @@ test (char *argv[])
+
+ outfile = gsf_outfile_msole_new (output);
+ g_object_unref (G_OBJECT (output));
+- clone (GSF_INPUT (infile), GSF_OUTPUT (outfile));
++ clone_ (GSF_INPUT (infile), GSF_OUTPUT (outfile));
+
+ return 0;
+ }
+--
+cgit v0.9.0.2
diff --git a/gnome-extra/libgsf/libgsf-1.14.23.ebuild b/gnome-extra/libgsf/libgsf-1.14.23.ebuild
index 1b9a51bc99cd..2af6582e914a 100644
--- a/gnome-extra/libgsf/libgsf-1.14.23.ebuild
+++ b/gnome-extra/libgsf/libgsf-1.14.23.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-extra/libgsf/libgsf-1.14.23.ebuild,v 1.1 2012/04/23 10:47:41 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnome-extra/libgsf/libgsf-1.14.23.ebuild,v 1.2 2012/04/29 18:58:06 pacho Exp $
EAPI="4"
GCONF_DEBUG="no"
@@ -57,6 +57,9 @@ src_prepare() {
use python && python_clean_py-compile_files
+ # compilation: avoid identifier "clone", fixed in next version
+ epatch "${FILESDIR}/${P}-clone-identifier.patch"
+
intltoolize --force --copy --automake || die "intltoolize failed"
eautoreconf
gnome2_src_prepare