summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2009-07-19 09:25:49 +0000
committerGilles Dartiguelongue <eva@gentoo.org>2009-07-19 09:25:49 +0000
commit8e0911ff6ad331ae593ea9af8e0cf53eb509c69e (patch)
tree272a4f5656c2bfef9219362d78d1354c72e729d5 /gnome-extra
parentVersion bump. Bug fixes and translation updates. (diff)
downloadgentoo-2-8e0911ff6ad331ae593ea9af8e0cf53eb509c69e.tar.gz
gentoo-2-8e0911ff6ad331ae593ea9af8e0cf53eb509c69e.tar.bz2
gentoo-2-8e0911ff6ad331ae593ea9af8e0cf53eb509c69e.zip
Version bump. Emit signal in HTML mode, change toolbar style, translation updates.
(Portage version: 2.2_rc33/cvs/Linux x86_64)
Diffstat (limited to 'gnome-extra')
-rw-r--r--gnome-extra/gtkhtml/ChangeLog9
-rw-r--r--gnome-extra/gtkhtml/gtkhtml-3.26.3.ebuild60
2 files changed, 68 insertions, 1 deletions
diff --git a/gnome-extra/gtkhtml/ChangeLog b/gnome-extra/gtkhtml/ChangeLog
index 01e2cf75fe78..ffe94c7361d0 100644
--- a/gnome-extra/gtkhtml/ChangeLog
+++ b/gnome-extra/gtkhtml/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for gnome-extra/gtkhtml
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-extra/gtkhtml/ChangeLog,v 1.189 2009/06/08 22:16:10 eva Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnome-extra/gtkhtml/ChangeLog,v 1.190 2009/07/19 09:25:49 eva Exp $
+
+*gtkhtml-3.26.3 (19 Jul 2009)
+
+ 19 Jul 2009; Gilles Dartiguelongue <eva@gentoo.org>
+ +gtkhtml-3.26.3.ebuild:
+ Version bump. Emit signal in HTML mode, change toolbar style, translation
+ updates.
08 Jun 2009; Gilles Dartiguelongue <eva@gentoo.org> gtkhtml-3.26.2.ebuild:
Set GCONF_DEBUG=no, bug #268745.
diff --git a/gnome-extra/gtkhtml/gtkhtml-3.26.3.ebuild b/gnome-extra/gtkhtml/gtkhtml-3.26.3.ebuild
new file mode 100644
index 000000000000..c83e8d0e045b
--- /dev/null
+++ b/gnome-extra/gtkhtml/gtkhtml-3.26.3.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/gnome-extra/gtkhtml/gtkhtml-3.26.3.ebuild,v 1.1 2009/07/19 09:25:49 eva Exp $
+
+EAPI="2"
+GCONF_DEBUG="no"
+
+inherit gnome2
+
+DESCRIPTION="Lightweight HTML Rendering/Printing/Editing Engine"
+HOMEPAGE="http://www.gnome.org/"
+
+LICENSE="GPL-2 LGPL-2"
+SLOT="3.14"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="glade"
+
+# We keep bonobo until we can make sure no apps in tree uses
+# the old composer code.
+RDEPEND=">=x11-libs/gtk+-2.14
+ >=gnome-base/gail-1.1
+ >=x11-themes/gnome-icon-theme-2.22.0
+ >=gnome-base/libbonobo-2.20.3
+ >=gnome-base/libbonoboui-2.2.4
+ >=gnome-base/orbit-2
+ >=gnome-base/libglade-2
+ >=gnome-base/libgnomeui-2
+ app-text/enchant
+ gnome-base/gconf:2
+ >=app-text/iso-codes-0.49
+ net-libs/libsoup:2.4
+ glade? ( dev-util/glade:3 )"
+DEPEND="${RDEPEND}
+ sys-devel/gettext
+ >=dev-util/intltool-0.40.0
+ >=dev-util/pkgconfig-0.9"
+
+DOCS="AUTHORS BUGS ChangeLog NEWS README TODO"
+
+pkg_setup() {
+ ELTCONF="--reverse-deps"
+ G2CONF="${G2CONF}
+ --disable-static
+ --with-bonobo-editor
+ $(use_with glade glade-catalog)"
+}
+
+src_prepare() {
+ gnome2_src_prepare
+
+ # Fix deprecated API disabling in used glib library - this is not future-proof, bug 210657
+ sed -i -e '/G_DISABLE_DEPRECATED/d' \
+ "${S}/gtkhtml/Makefile.am" "${S}/gtkhtml/Makefile.in" \
+ "${S}/components/html-editor/Makefile.am" \
+ "${S}/components/html-editor/Makefile.in" \
+ || die "sed 1 failed"
+
+ sed -i -e 's:-DGTK_DISABLE_DEPRECATED=1 -DGDK_DISABLE_DEPRECATED=1 -DG_DISABLE_DEPRECATED=1 -DGNOME_DISABLE_DEPRECATED=1::g' \
+ "${S}/a11y/Makefile.am" "${S}/a11y/Makefile.in" || die "sed 2 failed"
+}