summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2011-02-07 10:07:00 +0000
committerPacho Ramos <pacho@gentoo.org>2011-02-07 10:07:00 +0000
commit7c87e373cdf2d435e2fe256eeb70362cf67784dd (patch)
tree0aedd81f6a9d52c51b1c0fe92b7ecb5f237805b2 /gnome-extra
parentRevision bump, improved patches, ebuild and patches by Dennis Schridde (diff)
downloadgentoo-2-7c87e373cdf2d435e2fe256eeb70362cf67784dd.tar.gz
gentoo-2-7c87e373cdf2d435e2fe256eeb70362cf67784dd.tar.bz2
gentoo-2-7c87e373cdf2d435e2fe256eeb70362cf67784dd.zip
Version bump with some bugfixes.
(Portage version: 2.1.9.36/cvs/Linux x86_64)
Diffstat (limited to 'gnome-extra')
-rw-r--r--gnome-extra/evolution-data-server/ChangeLog8
-rw-r--r--gnome-extra/evolution-data-server/evolution-data-server-2.32.2.ebuild141
2 files changed, 148 insertions, 1 deletions
diff --git a/gnome-extra/evolution-data-server/ChangeLog b/gnome-extra/evolution-data-server/ChangeLog
index 18adb3d55344..476fdb99b078 100644
--- a/gnome-extra/evolution-data-server/ChangeLog
+++ b/gnome-extra/evolution-data-server/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for gnome-extra/evolution-data-server
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-extra/evolution-data-server/ChangeLog,v 1.289 2011/02/05 15:15:05 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnome-extra/evolution-data-server/ChangeLog,v 1.290 2011/02/07 10:07:00 pacho Exp $
+
+*evolution-data-server-2.32.2 (07 Feb 2011)
+
+ 07 Feb 2011; Pacho Ramos <pacho@gentoo.org>
+ +evolution-data-server-2.32.2.ebuild:
+ Version bump with some bugfixes.
05 Feb 2011; Pacho Ramos <pacho@gentoo.org>
-evolution-data-server-2.32.1.ebuild:
diff --git a/gnome-extra/evolution-data-server/evolution-data-server-2.32.2.ebuild b/gnome-extra/evolution-data-server/evolution-data-server-2.32.2.ebuild
new file mode 100644
index 000000000000..d4bbbf9db64a
--- /dev/null
+++ b/gnome-extra/evolution-data-server/evolution-data-server-2.32.2.ebuild
@@ -0,0 +1,141 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/gnome-extra/evolution-data-server/evolution-data-server-2.32.2.ebuild,v 1.1 2011/02/07 10:07:00 pacho Exp $
+
+EAPI="3"
+GCONF_DEBUG="no"
+
+inherit autotools db-use eutils flag-o-matic gnome2 versionator virtualx
+
+DESCRIPTION="Evolution groupware backend"
+HOMEPAGE="http://www.gnome.org/projects/evolution/"
+
+LICENSE="LGPL-2 BSD DB"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~ia64-linux ~x86-linux ~x86-solaris"
+
+IUSE="doc ipv6 kerberos gnome-keyring ldap ssl +weather"
+
+RDEPEND=">=dev-libs/glib-2.25.12:2
+ >=x11-libs/gtk+-2.20:2
+ >=gnome-base/gconf-2
+ >=dev-db/sqlite-3.5
+ >=dev-libs/libgdata-0.6.3
+ >=dev-libs/libical-0.43
+ >=net-libs/libsoup-2.4:2.4
+ >=dev-libs/libxml2-2
+ >=sys-libs/db-4
+ sys-libs/zlib
+ virtual/libiconv
+ gnome-keyring? ( >=gnome-base/gnome-keyring-2.20.1 )
+ kerberos? ( virtual/krb5 )
+ ldap? ( >=net-nds/openldap-2 )
+ ssl? (
+ >=dev-libs/nspr-4.4
+ >=dev-libs/nss-3.9 )
+ weather? ( >=dev-libs/libgweather-2.25.4:2 )
+"
+DEPEND="${RDEPEND}
+ >=dev-util/pkgconfig-0.9
+ >=dev-util/intltool-0.35.5
+ sys-devel/bison
+ >=gnome-base/gnome-common-2
+ >=dev-util/gtk-doc-am-1.9
+ doc? ( >=dev-util/gtk-doc-1.9 )"
+# eautoreconf needs:
+# >=gnome-base/gnome-common-2
+# >=dev-util/gtk-doc-am-1.9
+
+pkg_setup() {
+ DOCS="ChangeLog MAINTAINERS NEWS TODO"
+ G2CONF="${G2CONF}
+ $(use_enable gnome-keyring)
+ $(use_enable ipv6)
+ $(use_with kerberos krb5 /usr)
+ $(use_with ldap openldap)
+ $(use_enable ssl ssl)
+ $(use_enable ssl smime)
+ $(use_with weather)
+ --disable-gtk3
+ --enable-largefile
+ --with-libdb=/usr"
+}
+
+src_prepare() {
+ gnome2_src_prepare
+
+ # Adjust to gentoo's /etc/service
+ epatch "${FILESDIR}/${PN}-2.31-gentoo_etc_services.patch"
+
+ # GNOME bug 611353 (skips failing test atm)
+ epatch "${FILESDIR}/e-d-s-camel-skip-failing-test.patch"
+
+ # GNOME bug 621763 (skip failing test-ebook-stress-factory--fifo)
+ sed -e 's/\(SUBDIRS =.*\)ebook/\1/' \
+ -i addressbook/tests/Makefile.{am,in} \
+ || die "failing test sed 1 failed"
+
+ # Fix build with >=libgdata-0.7
+ epatch "${FILESDIR}/${PN}-2.32.1-libgdata07.patch"
+
+ # /usr/include/db.h is always db-1 on FreeBSD
+ # so include the right dir in CPPFLAGS
+ append-cppflags "-I$(db_includedir)"
+
+ # FIXME: Fix compilation flags crazyness
+ sed 's/^\(AM_CPPFLAGS="\)$WARNING_FLAGS/\1/' \
+ -i configure.ac configure || die "sed 3 failed"
+
+ intltoolize --force --copy --automake || die "intltoolize failed"
+ eautoreconf
+}
+
+src_install() {
+ gnome2_src_install
+ find "${ED}" -name "*.la" -delete || die "la files removal failed"
+
+ if use ldap; then
+ MY_MAJORV=$(get_version_component_range 1-2)
+ insinto /etc/openldap/schema
+ doins "${FILESDIR}"/calentry.schema || die "doins failed"
+ dosym /usr/share/${PN}-${MY_MAJORV}/evolutionperson.schema /etc/openldap/schema/evolutionperson.schema
+ fi
+}
+
+src_test() {
+ unset DBUS_SESSION_BUS_ADDRESS
+ unset ORBIT_SOCKETDIR
+ unset SESSION_MANAGER
+ export XDG_DATA_HOME="${T}"
+ unset DISPLAY
+ Xemake check || die "Tests failed."
+}
+
+pkg_preinst() {
+ gnome2_pkg_preinst
+
+ for lib in libcamel-provider-1.2.so.14 libedata-cal-1.2.so.7 \
+ libgdata-1.2.so libgdata-google-1.2.so libcamel-1.2.so.14 \
+ libedata-book-1.2.so.2 libebook-1.2.so.9 \
+ libedataserver-1.2.so.13 libecal-1.2.so.7 libedataserverui-1.2.so.8
+ do
+ preserve_old_lib /usr/$(get_libdir)/$lib
+ done
+}
+
+pkg_postinst() {
+ gnome2_pkg_postinst
+
+ for lib in libcamel-provider-1.2.so.14 libedata-cal-1.2.so.7 \
+ libgdata-1.2.so libgdata-google-1.2.so libcamel-1.2.so.14 \
+ libedata-book-1.2.so.2 libebook-1.2.so.9 \
+ libedataserver-1.2.so.13 libecal-1.2.so.7 libedataserverui-1.2.so.8
+ do
+ preserve_old_lib_notify /usr/$(get_libdir)/$lib
+ done
+
+ if use ldap; then
+ elog ""
+ elog "LDAP schemas needed by evolution are installed in /etc/openldap/schema"
+ fi
+}