summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2010-04-02 14:30:33 +0000
committerHans de Graaff <graaff@gentoo.org>2010-04-02 14:30:33 +0000
commit7a2f7740706863b397fca4977332633824018ec9 (patch)
tree5666fbc774d4a8f7d09ae9d1c0092b4eded43e2e /gnome-extra
parentversion bump (diff)
downloadgentoo-2-7a2f7740706863b397fca4977332633824018ec9.tar.gz
gentoo-2-7a2f7740706863b397fca4977332633824018ec9.tar.bz2
gentoo-2-7a2f7740706863b397fca4977332633824018ec9.zip
Fix compatibility with Mono 2.6. Fixes bug 310371.
(Portage version: 2.1.7.17/cvs/Linux x86_64)
Diffstat (limited to 'gnome-extra')
-rw-r--r--gnome-extra/gnome-do-plugins/ChangeLog11
-rw-r--r--gnome-extra/gnome-do-plugins/files/gnome-do-plugins-0.8.2-mono26.patch17
-rw-r--r--gnome-extra/gnome-do-plugins/gnome-do-plugins-0.8.2-r1.ebuild61
3 files changed, 87 insertions, 2 deletions
diff --git a/gnome-extra/gnome-do-plugins/ChangeLog b/gnome-extra/gnome-do-plugins/ChangeLog
index 2151d40efddd..7ea8042f0770 100644
--- a/gnome-extra/gnome-do-plugins/ChangeLog
+++ b/gnome-extra/gnome-do-plugins/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for gnome-extra/gnome-do-plugins
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-extra/gnome-do-plugins/ChangeLog,v 1.16 2009/08/29 07:26:30 graaff Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/gnome-extra/gnome-do-plugins/ChangeLog,v 1.17 2010/04/02 14:30:33 graaff Exp $
+
+*gnome-do-plugins-0.8.2-r1 (02 Apr 2010)
+
+ 02 Apr 2010; Hans de Graaff <graaff@gentoo.org>
+ +gnome-do-plugins-0.8.2-r1.ebuild,
+ +files/gnome-do-plugins-0.8.2-mono26.patch:
+ Fix compatibility with Mono 2.6. Fixes bug 310371.
29 Aug 2009; Hans de Graaff <graaff@gentoo.org>
gnome-do-plugins-0.8.2.ebuild:
diff --git a/gnome-extra/gnome-do-plugins/files/gnome-do-plugins-0.8.2-mono26.patch b/gnome-extra/gnome-do-plugins/files/gnome-do-plugins-0.8.2-mono26.patch
new file mode 100644
index 000000000000..e4aa8f2e695f
--- /dev/null
+++ b/gnome-extra/gnome-do-plugins/files/gnome-do-plugins-0.8.2-mono26.patch
@@ -0,0 +1,17 @@
+Upstream revision 678 fixes compilation with mono 2.6.
+
+=== modified file 'Evolution/src/ContactItemSource.cs'
+--- Evolution/src/ContactItemSource.cs 2009-06-22 04:05:16 +0000
++++ Evolution/src/ContactItemSource.cs 2010-02-12 01:08:47 +0000
+@@ -32,8 +32,8 @@
+ {
+ public struct ContactAttribute
+ {
+- public string Detail { get; protected set; }
+- public string Key { get; protected set; }
++ public string Detail { get; private set; }
++ public string Key { get; private set; }
+
+ public ContactAttribute (string key, string detail)
+ {
+
diff --git a/gnome-extra/gnome-do-plugins/gnome-do-plugins-0.8.2-r1.ebuild b/gnome-extra/gnome-do-plugins/gnome-do-plugins-0.8.2-r1.ebuild
new file mode 100644
index 000000000000..d2f134f5c581
--- /dev/null
+++ b/gnome-extra/gnome-do-plugins/gnome-do-plugins-0.8.2-r1.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/gnome-extra/gnome-do-plugins/gnome-do-plugins-0.8.2-r1.ebuild,v 1.1 2010/04/02 14:30:33 graaff Exp $
+
+EAPI=2
+
+inherit eutils autotools gnome2 mono versionator
+
+MY_PN="do-plugins"
+PVC=$(get_version_component_range 1-3)
+
+DESCRIPTION="Plugins to put the Do in Gnome Do"
+HOMEPAGE="http://do.davebsd.com/"
+SRC_URI="https://launchpad.net/${MY_PN}/0.8/${PVC}/+download/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="banshee evo"
+
+RDEPEND=">=gnome-extra/gnome-do-${PV}
+ dev-dotnet/wnck-sharp
+ banshee? ( >=media-sound/banshee-1.4.2 )
+ evo? ( dev-dotnet/evolution-sharp )"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+src_prepare() {
+ # Filed upstream as https://bugs.launchpad.net/do/+bug/392422
+ use banshee || sed -i -r -e "/(BANSHEE_INDEXER_DLL)/d" BundledLibraries/Makefile.am
+
+ epatch "${FILESDIR}/${P}-mono26.patch"
+
+ eautomake
+}
+
+src_configure() {
+ econf --enable-debug=no --enable-release=yes \
+ $(use banshee) \
+ $(use evo evolution) \
+ --disable-flickr || die "configure failed"
+}
+
+src_compile()
+{
+ # The make system is unfortunately broken for parallel builds and
+ # upstream indicated on IRC that they have no intention to fix
+ # that.
+ emake -j1 || die "make failed"
+}
+
+pkg_postinst()
+{
+ ewarn "Plugin handling has changed since gnome-do 0.4."
+ ewarn "If you install the gnome-do-plugins package you will have local copies"
+ ewarn "of the plugins, but you still need to manually enable them in Preferences."
+ ewarn "Also note that plugins installed from upstream may not be compatible with"
+ ewarn "your system. When in doubt check the output from gnome-do itself".
+ ewarn "Old plugins may not be compatible either."
+ ewarn "Check ~/.local/share/gnome-do/ if you have problems with plugins."
+}