summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2011-06-16 13:09:17 +0000
committerPacho Ramos <pacho@gentoo.org>2011-06-16 13:09:17 +0000
commit64c503c5042dbdd8c4d76c9528b791abde8dc0f1 (patch)
treeb090cbb3ca5d23373411f11fc5d084be21627309 /gnome-extra
parentFix bug #371889 by flameeyes caused by bad system-zlib patch. (diff)
downloadgentoo-2-64c503c5042dbdd8c4d76c9528b791abde8dc0f1.tar.gz
gentoo-2-64c503c5042dbdd8c4d76c9528b791abde8dc0f1.tar.bz2
gentoo-2-64c503c5042dbdd8c4d76c9528b791abde8dc0f1.zip
Revision bump to regenerate schemas (fixing translations handling and warning at install time) and to have a stable candidate not needing to wait for xulrunner-2. Remove old.
(Portage version: 2.1.9.50/cvs/Linux x86_64)
Diffstat (limited to 'gnome-extra')
-rw-r--r--gnome-extra/yelp/ChangeLog11
-rw-r--r--gnome-extra/yelp/yelp-2.30.2-r5.ebuild84
-rw-r--r--gnome-extra/yelp/yelp-2.30.2-r6.ebuild (renamed from gnome-extra/yelp/yelp-2.30.2-r4.ebuild)10
3 files changed, 101 insertions, 4 deletions
diff --git a/gnome-extra/yelp/ChangeLog b/gnome-extra/yelp/ChangeLog
index d422b88e0aff..57dd8e2165b7 100644
--- a/gnome-extra/yelp/ChangeLog
+++ b/gnome-extra/yelp/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for gnome-extra/yelp
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-extra/yelp/ChangeLog,v 1.261 2011/06/03 19:16:36 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnome-extra/yelp/ChangeLog,v 1.262 2011/06/16 13:09:17 pacho Exp $
+
+*yelp-2.30.2-r6 (16 Jun 2011)
+*yelp-2.30.2-r5 (16 Jun 2011)
+
+ 16 Jun 2011; Pacho Ramos <pacho@gentoo.org> -yelp-2.30.2-r4.ebuild,
+ +yelp-2.30.2-r5.ebuild, +yelp-2.30.2-r6.ebuild:
+ Revision bump to regenerate schemas (fixing translations handling and warning
+ at install time) and to have a stable candidate not needing to wait for
+ xulrunner-2. Remove old.
*yelp-2.30.2-r4 (03 Jun 2011)
diff --git a/gnome-extra/yelp/yelp-2.30.2-r5.ebuild b/gnome-extra/yelp/yelp-2.30.2-r5.ebuild
new file mode 100644
index 000000000000..643080dbb31d
--- /dev/null
+++ b/gnome-extra/yelp/yelp-2.30.2-r5.ebuild
@@ -0,0 +1,84 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/gnome-extra/yelp/yelp-2.30.2-r5.ebuild,v 1.1 2011/06/16 13:09:17 pacho Exp $
+
+EAPI="4"
+GCONF_DEBUG="yes"
+GNOME_TARBALL_SUFFIX="bz2"
+
+inherit autotools eutils gnome2
+
+DESCRIPTION="Help browser for GNOME"
+HOMEPAGE="http://projects.gnome.org/yelp/"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~x86-freebsd ~amd64-linux ~x86-linux ~x86-solaris"
+# FIXME: lzma/xz support will be fixed in yelp3, bug #314923
+IUSE=""
+
+RDEPEND=">=gnome-base/gconf-2:2
+ >=app-text/gnome-doc-utils-0.19.1
+ >=x11-libs/gtk+-2.18:2
+ >=dev-libs/glib-2.16:2
+ >=dev-libs/libxml2-2.6.5:2
+ >=dev-libs/libxslt-1.1.4
+ >=x11-libs/startup-notification-0.8
+ >=dev-libs/dbus-glib-0.71
+ net-libs/xulrunner:1.9
+ sys-libs/zlib
+ app-arch/bzip2
+ >=app-text/rarian-0.7
+ >=app-text/scrollkeeper-9999"
+DEPEND="${RDEPEND}
+ sys-devel/gettext
+ >=dev-util/intltool-0.35
+ >=dev-util/pkgconfig-0.9
+ gnome-base/gnome-common"
+# If eautoreconf:
+# gnome-base/gnome-common
+
+pkg_setup() {
+ DOCS="AUTHORS ChangeLog NEWS README TODO"
+ G2CONF="${G2CONF}
+ --with-gecko=libxul-embedding
+ --with-search=basic
+ --disable-lzma"
+}
+
+src_prepare() {
+ gnome2_src_prepare
+
+ # Fix automagic lzma support, bug #266128
+ epatch "${FILESDIR}/${PN}-2.26.0-automagic-lzma.patch"
+
+ # Fix build with xulrunner-1.9.2
+ epatch "${FILESDIR}/${PN}-2.28.1-system-nspr.patch"
+
+ # Fix build with xulrunner-2.0 (we really need to get rid of this package)
+# epatch "${FILESDIR}/${P}-port-to-xulrunner-2-r1.patch"
+
+ # Use g_build_filename to avoid missing slash problem
+ epatch "${FILESDIR}/${P}-missing-slash.patch"
+
+ # Add schemehandler information to the desktop file
+ epatch "${FILESDIR}/${P}-uri-handler.patch"
+
+ # Fix crash when printing a whole document
+ epatch "${FILESDIR}/${P}-print-crash.patch"
+
+ # Fix crash and infinite loop when printing HTML document
+ epatch "${FILESDIR}/${P}-html-print.patch"
+
+ # Fix small freezes when moving window
+ epatch "${FILESDIR}/${P}-freeze-move.patch"
+
+ # Ensure schema is regenerated properly to prevent warnings
+ rm -f data/yelp.schemas || die
+
+ intltoolize --force --copy --automake || die "intltoolize failed"
+ eautoreconf
+
+ # strip stupid options in configure, see bug #196621
+ sed -i 's|$AM_CFLAGS -pedantic -ansi|$AM_CFLAGS|' configure || die "sed failed"
+}
diff --git a/gnome-extra/yelp/yelp-2.30.2-r4.ebuild b/gnome-extra/yelp/yelp-2.30.2-r6.ebuild
index 072afc984131..7179de1272f0 100644
--- a/gnome-extra/yelp/yelp-2.30.2-r4.ebuild
+++ b/gnome-extra/yelp/yelp-2.30.2-r6.ebuild
@@ -1,14 +1,15 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-extra/yelp/yelp-2.30.2-r4.ebuild,v 1.1 2011/06/03 19:16:36 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnome-extra/yelp/yelp-2.30.2-r6.ebuild,v 1.1 2011/06/16 13:09:17 pacho Exp $
-EAPI="3"
+EAPI="4"
GCONF_DEBUG="yes"
+GNOME_TARBALL_SUFFIX="bz2"
inherit autotools eutils gnome2
DESCRIPTION="Help browser for GNOME"
-HOMEPAGE="http://www.gnome.org/"
+HOMEPAGE="http://projects.gnome.org/yelp/"
LICENSE="GPL-2"
SLOT="0"
@@ -72,6 +73,9 @@ src_prepare() {
# Fix small freezes when moving window
epatch "${FILESDIR}/${P}-freeze-move.patch"
+ # Ensure schema is regenerated properly to prevent warnings
+ rm -f data/yelp.schemas || die
+
intltoolize --force --copy --automake || die "intltoolize failed"
eautoreconf