summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2012-11-25 21:12:50 +0000
committerGilles Dartiguelongue <eva@gentoo.org>2012-11-25 21:12:50 +0000
commit1c395a6cf6e7eb3034cce1c916ea239bec3cc9c3 (patch)
treed01006ffd9b937ca5ddfe5d9a4cf4bf5ca463824 /gnome-extra
parentSupport libav-9 (diff)
downloadgentoo-2-1c395a6cf6e7eb3034cce1c916ea239bec3cc9c3.tar.gz
gentoo-2-1c395a6cf6e7eb3034cce1c916ea239bec3cc9c3.tar.bz2
gentoo-2-1c395a6cf6e7eb3034cce1c916ea239bec3cc9c3.zip
Version bump. Migrate to python-r1.eclass. Fix introspection support. Drop old revision.
(Portage version: 2.2.0_alpha142/cvs/Linux x86_64, signed Manifest commit with key C6085806)
Diffstat (limited to 'gnome-extra')
-rw-r--r--gnome-extra/libgsf/ChangeLog9
-rw-r--r--gnome-extra/libgsf/libgsf-1.14.22.ebuild123
-rw-r--r--gnome-extra/libgsf/libgsf-1.14.25.ebuild95
3 files changed, 103 insertions, 124 deletions
diff --git a/gnome-extra/libgsf/ChangeLog b/gnome-extra/libgsf/ChangeLog
index 5745496ef2dd..94ce628ba32e 100644
--- a/gnome-extra/libgsf/ChangeLog
+++ b/gnome-extra/libgsf/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for gnome-extra/libgsf
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-extra/libgsf/ChangeLog,v 1.210 2012/10/28 15:55:49 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnome-extra/libgsf/ChangeLog,v 1.211 2012/11/25 21:12:50 eva Exp $
+
+*libgsf-1.14.25 (25 Nov 2012)
+
+ 25 Nov 2012; Gilles Dartiguelongue <eva@gentoo.org> -libgsf-1.14.22.ebuild,
+ +libgsf-1.14.25.ebuild:
+ Version bump. Migrate to python-r1.eclass. Fix introspection support. Drop
+ old revision.
28 Oct 2012; Raúl Porcel <armin76@gentoo.org> libgsf-1.14.23.ebuild:
ia64/sh/sparc stable wrt #427544
diff --git a/gnome-extra/libgsf/libgsf-1.14.22.ebuild b/gnome-extra/libgsf/libgsf-1.14.22.ebuild
deleted file mode 100644
index 09eb1f400b66..000000000000
--- a/gnome-extra/libgsf/libgsf-1.14.22.ebuild
+++ /dev/null
@@ -1,123 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-extra/libgsf/libgsf-1.14.22.ebuild,v 1.9 2012/07/15 17:54:51 armin76 Exp $
-
-EAPI="4"
-GCONF_DEBUG="no"
-GNOME2_LA_PUNT="yes"
-PYTHON_DEPEND="python? 2:2.6"
-SUPPORT_PYTHON_ABIS="1"
-RESTRICT_PYTHON_ABIS="2.[45] 3.* *-jython *-pypy-*"
-
-inherit autotools eutils gnome2 python multilib
-
-DESCRIPTION="The GNOME Structured File Library"
-HOMEPAGE="http://projects.gnome.org/libgsf/"
-
-LICENSE="GPL-2 LGPL-2.1"
-SLOT="0"
-KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 sh sparc x86 ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
-IUSE="bzip2 doc gtk python"
-
-RDEPEND=">=dev-libs/glib-2.16:2
- >=dev-libs/libxml2-2.4.16:2
- sys-libs/zlib
- bzip2? ( app-arch/bzip2 )
- gtk? ( x11-libs/gtk+:2 )
- python? (
- >=dev-python/pygobject-2.10:2
- >=dev-python/pygtk-2.10:2 )"
-
-DEPEND="${RDEPEND}
- >=dev-util/intltool-0.35.0
- dev-util/gtk-doc-am
- virtual/pkgconfig
- doc? ( >=dev-util/gtk-doc-1 )"
-
-pkg_setup() {
- DOCS="AUTHORS BUGS ChangeLog HACKING NEWS README TODO"
- G2CONF="${G2CONF}
- --with-gio
- --disable-static
- $(use_with bzip2 bz2)
- $(use_with python)
- $(use_with gtk gdk-pixbuf)"
-
- if use python; then
- python_pkg_setup
- fi
-}
-
-src_prepare() {
- # Drop DEPRECATED flags
- sed -i -e "s/ -DG_DISABLE_DEPRECATED//" configure.in configure || die
-
- # Python bindings are built/installed manually.
- sed -e "/SUBDIRS += python/d" -i Makefile.am || die
-
- intltoolize --force --copy --automake || die "intltoolize failed"
- eautoreconf
-
- # disable pyc compiling
- echo '#!/bin/sh' > py-compile
-
- gnome2_src_prepare
-}
-
-src_compile() {
- gnome2_src_compile
-
- if use python; then
- python_copy_sources python
-
- building() {
- emake \
- PYTHON_INCLUDES="-I$(python_get_includedir)" \
- pyexecdir="$(python_get_sitedir)" \
- pythondir="$(python_get_sitedir)"
- }
- python_execute_function -s --source-dir python building
- fi
-}
-
-src_install() {
- gnome2_src_install
-
- if use python; then
- installation() {
- emake \
- DESTDIR="${D}" \
- pyexecdir="$(python_get_sitedir)" \
- pythondir="$(python_get_sitedir)" \
- install
- }
- python_execute_function -s --source-dir python installation
-
- python_clean_installation_image
- fi
-}
-
-pkg_preinst() {
- gnome2_pkg_preinst
- preserve_old_lib /usr/$(get_libdir)/libgsf-1.so.1
- preserve_old_lib /usr/$(get_libdir)/libgsf-gnome-1.so.1
-}
-
-pkg_postinst() {
- gnome2_pkg_postinst
-
- if use python; then
- python_mod_optimize gsf
- fi
-
- preserve_old_lib_notify /usr/$(get_libdir)/libgsf-1.so.1
- preserve_old_lib_notify /usr/$(get_libdir)/libgsf-gnome-1.so.1
-}
-
-pkg_postrm() {
- gnome2_pkg_postrm
-
- if use python; then
- python_mod_cleanup gsf
- fi
-}
diff --git a/gnome-extra/libgsf/libgsf-1.14.25.ebuild b/gnome-extra/libgsf/libgsf-1.14.25.ebuild
new file mode 100644
index 000000000000..055a3a905f04
--- /dev/null
+++ b/gnome-extra/libgsf/libgsf-1.14.25.ebuild
@@ -0,0 +1,95 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/gnome-extra/libgsf/libgsf-1.14.25.ebuild,v 1.1 2012/11/25 21:12:50 eva Exp $
+
+EAPI="4"
+GCONF_DEBUG="no"
+GNOME2_LA_PUNT="yes"
+PYTHON_COMPAT=( python2_{6,7} )
+
+inherit eutils gnome2 multilib python-r1
+
+DESCRIPTION="The GNOME Structured File Library"
+HOMEPAGE="http://projects.gnome.org/libgsf/"
+
+LICENSE="GPL-2 LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
+IUSE="bzip2 gtk +introspection python"
+
+RDEPEND=">=dev-libs/glib-2.26:2
+ >=dev-libs/libxml2-2.4.16:2
+ sys-libs/zlib
+ bzip2? ( app-arch/bzip2 )
+ gtk? ( x11-libs/gtk+:2 )
+ introspection? ( >=dev-libs/gobject-introspection-1 )
+ python? (
+ ${PYTHON_DEPS}
+ >=dev-python/pygobject-2.10:2
+ >=dev-python/pygtk-2.10:2 )"
+
+DEPEND="${RDEPEND}
+ >=dev-util/gtk-doc-am-1.12
+ >=dev-util/intltool-0.35.0
+ dev-libs/gobject-introspection-common
+ virtual/pkgconfig
+"
+
+BUILD_DIR="${S}/python"
+
+src_configure() {
+ DOCS="AUTHORS BUGS ChangeLog HACKING NEWS README TODO"
+ G2CONF="${G2CONF}
+ --disable-static
+ $(use_with bzip2 bz2)
+ $(use_enable introspection)
+ $(use_with gtk gdk-pixbuf)"
+
+ if use python ; then
+ copy_binding() {
+ gnome2_src_configure --with-python
+ cp -r python "${BUILD_DIR}"
+ }
+ python_foreach_impl copy_binding
+ fi
+
+ gnome2_src_configure --without-python
+}
+
+src_compile() {
+ gnome2_src_compile
+
+ if use python ; then
+ building() {
+ cd "${BUILD_DIR}"
+ python_export PYTHON_SITEDIR
+ default
+ }
+ python_foreach_impl building
+ fi
+}
+
+src_install() {
+ gnome2_src_install
+
+ if use python ; then
+ installation() {
+ cd "${BUILD_DIR}"
+ emake install DESTDIR="${D}"
+ }
+ python_foreach_impl installation
+ prune_libtool_files --modules
+ fi
+}
+
+pkg_preinst() {
+ gnome2_pkg_preinst
+ preserve_old_lib /usr/$(get_libdir)/libgsf-1.so.1
+ preserve_old_lib /usr/$(get_libdir)/libgsf-gnome-1.so.1
+}
+
+pkg_postinst() {
+ gnome2_pkg_postinst
+ preserve_old_lib_notify /usr/$(get_libdir)/libgsf-1.so.1
+ preserve_old_lib_notify /usr/$(get_libdir)/libgsf-gnome-1.so.1
+}