summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2012-07-07 12:15:48 +0000
committerPacho Ramos <pacho@gentoo.org>2012-07-07 12:15:48 +0000
commit1b50f79076b0c039f6b399dc57611f6c8342c370 (patch)
tree6125d60da089f0e26813d8c075675b74aef55414 /gnome-extra
parentBuild with CFLAGS and CC. (diff)
downloadgentoo-2-1b50f79076b0c039f6b399dc57611f6c8342c370.tar.gz
gentoo-2-1b50f79076b0c039f6b399dc57611f6c8342c370.tar.bz2
gentoo-2-1b50f79076b0c039f6b399dc57611f6c8342c370.zip
Fix for systems with python3 as main interpreter, drop old testing versions that will never hit stable.
(Portage version: 2.1.11.5/cvs/Linux x86_64)
Diffstat (limited to 'gnome-extra')
-rw-r--r--gnome-extra/gnome-games/ChangeLog8
-rw-r--r--gnome-extra/gnome-games/gnome-games-2.28.2.ebuild9
-rw-r--r--gnome-extra/gnome-games/gnome-games-2.30.2-r1.ebuild174
-rw-r--r--gnome-extra/gnome-games/gnome-games-2.30.2-r2.ebuild176
-rw-r--r--gnome-extra/gnome-games/gnome-games-3.2.1.ebuild190
5 files changed, 12 insertions, 545 deletions
diff --git a/gnome-extra/gnome-games/ChangeLog b/gnome-extra/gnome-games/ChangeLog
index 20d8f3988ae6..5aa66ecb1c88 100644
--- a/gnome-extra/gnome-games/ChangeLog
+++ b/gnome-extra/gnome-games/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for gnome-extra/gnome-games
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-extra/gnome-games/ChangeLog,v 1.318 2012/05/20 08:24:41 tetromino Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnome-extra/gnome-games/ChangeLog,v 1.319 2012/07/07 12:15:48 pacho Exp $
+
+ 07 Jul 2012; Pacho Ramos <pacho@gentoo.org> -gnome-games-2.30.2-r1.ebuild,
+ -gnome-games-2.30.2-r2.ebuild, -gnome-games-3.2.1.ebuild,
+ gnome-games-2.28.2.ebuild:
+ Fix for systems with python3 as main interpreter, drop old testing versions
+ that will never hit stable.
*gnome-games-3.4.2 (20 May 2012)
diff --git a/gnome-extra/gnome-games/gnome-games-2.28.2.ebuild b/gnome-extra/gnome-games/gnome-games-2.28.2.ebuild
index d5272f279760..61f2d8786974 100644
--- a/gnome-extra/gnome-games/gnome-games-2.28.2.ebuild
+++ b/gnome-extra/gnome-games/gnome-games-2.28.2.ebuild
@@ -1,9 +1,10 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-extra/gnome-games/gnome-games-2.28.2.ebuild,v 1.13 2012/05/05 06:25:20 jdhore Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnome-extra/gnome-games/gnome-games-2.28.2.ebuild,v 1.14 2012/07/07 12:15:48 pacho Exp $
-EAPI="3"
+EAPI="4"
GCONF_DEBUG="no"
+GNOME_TARBALL_SUFFIX="bz2"
WANT_AUTOMAKE="1.11"
PYTHON_DEPEND="2"
@@ -119,8 +120,8 @@ pkg_setup() {
}
src_prepare() {
- # disable pyc compiling
- echo > py-compile
+ python_clean_py-compile_files
+ python_convert_shebangs -r 2 .
# Fix implicit declaration of yylex.
epatch "${FILESDIR}/${PN}-2.26.3-implicit-declaration.patch"
diff --git a/gnome-extra/gnome-games/gnome-games-2.30.2-r1.ebuild b/gnome-extra/gnome-games/gnome-games-2.30.2-r1.ebuild
deleted file mode 100644
index 0c10c8aeaee9..000000000000
--- a/gnome-extra/gnome-games/gnome-games-2.30.2-r1.ebuild
+++ /dev/null
@@ -1,174 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-extra/gnome-games/gnome-games-2.30.2-r1.ebuild,v 1.16 2012/05/05 06:25:20 jdhore Exp $
-
-EAPI="3"
-GCONF_DEBUG="no"
-WANT_AUTOMAKE="1.11"
-PYTHON_DEPEND="2"
-
-# make sure games is inherited first so that the gnome2
-# functions will be called if they are not overridden
-inherit games games-ggz gnome2 python virtualx
-
-DESCRIPTION="Collection of games for the GNOME desktop"
-HOMEPAGE="http://live.gnome.org/GnomeGames/"
-
-LICENSE="GPL-2 FDL-1.1"
-SLOT="0"
-
-# 2.30.x versions are not ready to go to stable, please confirm before changing KEYWORDS
-KEYWORDS="alpha ~amd64 ~arm ia64 ppc ppc64 sh sparc ~x86 ~x86-fbsd"
-IUSE="artworkextra +clutter guile opengl test"
-
-# USE=clutter also enables introspection because gnome-games is the only known
-# consumer of introspection on libgames-support etc. If something else pops up,
-# we'll have to enable it unconditionally because we have no sane way of
-# representing inter-use-flag dependencies
-COMMON_DEPEND="
- >=dev-games/libggz-0.0.14
- >=dev-games/ggz-client-libs-0.0.14
- >=dev-libs/dbus-glib-0.75
- >=dev-libs/glib-2.6.3:2
- >=dev-libs/libxml2-2.4.0:2
- >=dev-python/gconf-python-2.17.3
- >=dev-python/pygobject-2:2
- >=dev-python/pygtk-2.14:2
- >=dev-python/pycairo-1
- >=gnome-base/gconf-2:2
- >=gnome-base/librsvg-2.14:2
- media-libs/libcanberra[gtk]
- >=x11-libs/cairo-1
- >=x11-libs/gtk+-2.16:2
- x11-libs/libSM
-
- artworkextra? ( gnome-extra/gnome-games-extra-data )
- clutter? (
- >=dev-libs/gobject-introspection-0.6.3
- >=media-libs/clutter-1.0.0:1.0
- >=media-libs/clutter-gtk-0.10.2:0.10 )
- guile? ( >=dev-scheme/guile-1.6.5[deprecated,regex] )
- opengl? (
- dev-python/pygtkglext
- >=dev-python/pyopengl-3 )
- !games-board/glchess"
-RDEPEND="${COMMON_DEPEND}
- clutter? (
- dev-libs/seed
- x11-libs/gtk+:2[introspection]
- >=media-libs/clutter-1.0.0:1.0[introspection]
- >=media-libs/clutter-gtk-0.10.2:0.10[introspection] )"
-DEPEND="${COMMON_DEPEND}
- >=sys-devel/autoconf-2.53
- virtual/pkgconfig
- >=dev-util/intltool-0.40.4
- >=sys-devel/gettext-0.10.40
- >=gnome-base/gnome-common-2.12.0
- >=app-text/scrollkeeper-0.3.8
- >=app-text/gnome-doc-utils-0.10
- test? ( >=dev-libs/check-0.9.4 )"
-
-# Others are installed below; multiples in this package.
-DOCS="AUTHORS HACKING MAINTAINERS TODO"
-
-# dang make-check fails on docs with -j > 1. Restrict them for the moment until
-# it can be chased down.
-RESTRICT="test"
-
-_omitgame() {
- G2CONF="${G2CONF},${1}"
-}
-
-pkg_setup() {
- python_set_active_version 2
- python_pkg_setup
-
- # create the games user / group
- games_pkg_setup
-
- G2CONF="${G2CONF}
- $(use_enable clutter introspection)
- --disable-aisleriot-clutter
- --disable-card-themes-installer
- --enable-sound
- --with-scores-group=${GAMES_GROUP}
- --with-platform=gnome
- --with-card-theme-formats=all
- --with-smclient
- --enable-omitgames=none" # This line should be last for _omitgame
-
- if ! use clutter; then
- ewarn "USE=-clutter means no quadrapassel, lightsoff, swell-foop, gnibbles"
- _omitgame quadrapassel
- _omitgame lightsoff
- _omitgame swell-foop
- _omitgame gnibbles
- fi
-
- if ! use guile; then
- ewarn "USE=-guile implies that Aisleriot won't be installed"
- _omitgame aisleriot
- fi
-
- if ! use opengl; then
- ewarn "USE=-opengl implies that glchess won't be installed"
- _omitgame glchess
- fi
-}
-
-src_prepare() {
- gnome2_src_prepare
-
- # disable pyc compiling
- echo > py-compile
-}
-
-src_test() {
- Xemake check || die "tests failed"
-}
-
-src_install() {
- gnome2_src_install
-
- # Documentation install for each of the games
- for game in \
- $(find . -maxdepth 1 -type d ! -name po ! -name libgames-support); do
- docinto ${game}
- for doc in AUTHORS ChangeLog NEWS README TODO; do
- [ -s ${game}/${doc} ] && dodoc ${game}/${doc}
- done
- done
-}
-
-pkg_preinst() {
- gnome2_pkg_preinst
- # Avoid overwriting previous .scores files
- local basefile
- for scorefile in "${D}"/var/lib/games/*.scores; do
- basefile=$(basename $scorefile)
- if [ -s "${ROOT}/var/lib/games/${basefile}" ]; then
- cp "${ROOT}/var/lib/games/${basefile}" \
- "${D}/var/lib/games/${basefile}"
- fi
- done
-}
-
-pkg_postinst() {
- games_pkg_postinst
- games-ggz_update_modules
- gnome2_pkg_postinst
- python_need_rebuild
- python_mod_optimize gnome_sudoku
- if use opengl; then
- python_mod_optimize glchess
- fi
-}
-
-pkg_postrm() {
- games-ggz_update_modules
- gnome2_pkg_postrm
- python_mod_cleanup gnome_sudoku
- if use opengl; then
- python_mod_cleanup glchess
- fi
-}
diff --git a/gnome-extra/gnome-games/gnome-games-2.30.2-r2.ebuild b/gnome-extra/gnome-games/gnome-games-2.30.2-r2.ebuild
deleted file mode 100644
index 38852e73d74a..000000000000
--- a/gnome-extra/gnome-games/gnome-games-2.30.2-r2.ebuild
+++ /dev/null
@@ -1,176 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-extra/gnome-games/gnome-games-2.30.2-r2.ebuild,v 1.3 2012/05/05 06:25:20 jdhore Exp $
-
-EAPI="3"
-GCONF_DEBUG="no"
-WANT_AUTOMAKE="1.11"
-PYTHON_DEPEND="2"
-
-# make sure games is inherited first so that the gnome2
-# functions will be called if they are not overridden
-inherit games games-ggz gnome2 python virtualx
-
-DESCRIPTION="Collection of games for the GNOME desktop"
-HOMEPAGE="http://live.gnome.org/GnomeGames/"
-
-LICENSE="GPL-2 FDL-1.1"
-SLOT="0"
-
-# 2.30.x versions are not ready to go to stable, please confirm before changing KEYWORDS
-KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd"
-IUSE="artworkextra +clutter guile opengl test"
-
-# USE=clutter also enables introspection because gnome-games is the only known
-# consumer of introspection on libgames-support etc. If something else pops up,
-# we'll have to enable it unconditionally because we have no sane way of
-# representing inter-use-flag dependencies
-COMMON_DEPEND="
- >=dev-games/libggz-0.0.14
- >=dev-games/ggz-client-libs-0.0.14
- >=dev-libs/dbus-glib-0.75
- >=dev-libs/glib-2.6.3:2
- >=dev-libs/libxml2-2.4.0:2
- >=dev-python/gconf-python-2.17.3
- >=dev-python/pygobject-2:2
- >=dev-python/pygtk-2.14:2
- >=dev-python/pycairo-1
- >=gnome-base/gconf-2:2
- >=gnome-base/librsvg-2.14:2
- media-libs/libcanberra[gtk]
- >=x11-libs/cairo-1
- >=x11-libs/gtk+-2.16:2
- x11-libs/libSM
-
- artworkextra? ( gnome-extra/gnome-games-extra-data )
- clutter? (
- >=dev-libs/gobject-introspection-0.6.3
- >=media-libs/clutter-1.0.0:1.0
- >=media-libs/clutter-gtk-0.10.2:0.10 )
- guile? ( >=dev-scheme/guile-1.6.5[deprecated,regex] )
- opengl? (
- dev-python/pygtkglext
- >=dev-python/pyopengl-3 )
- !games-board/glchess"
-RDEPEND="${COMMON_DEPEND}
- clutter? (
- dev-libs/seed
- x11-libs/gtk+:2[introspection]
- >=media-libs/clutter-1.0.0:1.0[introspection]
- >=media-libs/clutter-gtk-0.10.2:0.10[introspection] )"
-DEPEND="${COMMON_DEPEND}
- >=sys-devel/autoconf-2.53
- virtual/pkgconfig
- >=dev-util/intltool-0.40.4
- >=sys-devel/gettext-0.10.40
- >=gnome-base/gnome-common-2.12.0
- >=app-text/scrollkeeper-0.3.8
- >=app-text/gnome-doc-utils-0.10
- test? ( >=dev-libs/check-0.9.4 )"
-
-# Others are installed below; multiples in this package.
-DOCS="AUTHORS HACKING MAINTAINERS TODO"
-
-# dang make-check fails on docs with -j > 1. Restrict them for the moment until
-# it can be chased down.
-RESTRICT="test"
-
-_omitgame() {
- G2CONF="${G2CONF},${1}"
-}
-
-pkg_setup() {
- python_set_active_version 2
- python_pkg_setup
-
- # create the games user / group
- games_pkg_setup
-
- G2CONF="${G2CONF}
- $(use_enable clutter introspection)
- --disable-aisleriot-clutter
- --disable-card-themes-installer
- --enable-sound
- --with-scores-group=${GAMES_GROUP}
- --with-platform=gnome
- --with-card-theme-formats=all
- --with-smclient
- --enable-omitgames=none" # This line should be last for _omitgame
-
- if ! use clutter; then
- ewarn "USE=-clutter means no quadrapassel, lightsoff, swell-foop, gnibbles"
- _omitgame quadrapassel
- _omitgame lightsoff
- _omitgame swell-foop
- _omitgame gnibbles
- fi
-
- if ! use guile; then
- ewarn "USE=-guile implies that Aisleriot won't be installed"
- _omitgame aisleriot
- fi
-
- if ! use opengl; then
- ewarn "USE=-opengl implies that glchess won't be installed"
- _omitgame glchess
- fi
-}
-
-src_prepare() {
- gnome2_src_prepare
-
- python_convert_shebangs -r 2 gnome-sudoku/src
-
- # disable pyc compiling
- echo > py-compile
-}
-
-src_test() {
- Xemake check || die "tests failed"
-}
-
-src_install() {
- gnome2_src_install
-
- # Documentation install for each of the games
- for game in \
- $(find . -maxdepth 1 -type d ! -name po ! -name libgames-support); do
- docinto ${game}
- for doc in AUTHORS ChangeLog NEWS README TODO; do
- [ -s ${game}/${doc} ] && dodoc ${game}/${doc}
- done
- done
-}
-
-pkg_preinst() {
- gnome2_pkg_preinst
- # Avoid overwriting previous .scores files
- local basefile
- for scorefile in "${D}"/var/lib/games/*.scores; do
- basefile=$(basename $scorefile)
- if [ -s "${ROOT}/var/lib/games/${basefile}" ]; then
- cp "${ROOT}/var/lib/games/${basefile}" \
- "${D}/var/lib/games/${basefile}"
- fi
- done
-}
-
-pkg_postinst() {
- games_pkg_postinst
- games-ggz_update_modules
- gnome2_pkg_postinst
- python_need_rebuild
- python_mod_optimize gnome_sudoku
- if use opengl; then
- python_mod_optimize glchess
- fi
-}
-
-pkg_postrm() {
- games-ggz_update_modules
- gnome2_pkg_postrm
- python_mod_cleanup gnome_sudoku
- if use opengl; then
- python_mod_cleanup glchess
- fi
-}
diff --git a/gnome-extra/gnome-games/gnome-games-3.2.1.ebuild b/gnome-extra/gnome-games/gnome-games-3.2.1.ebuild
deleted file mode 100644
index 62c14350e6b4..000000000000
--- a/gnome-extra/gnome-games/gnome-games-3.2.1.ebuild
+++ /dev/null
@@ -1,190 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-extra/gnome-games/gnome-games-3.2.1.ebuild,v 1.5 2012/05/05 06:25:20 jdhore Exp $
-
-EAPI="3"
-GNOME_TARBALL_SUFFIX="xz"
-GCONF_DEBUG="no"
-GNOME2_LA_PUNT="yes"
-WANT_AUTOMAKE="1.11"
-PYTHON_DEPEND="2:2.5"
-PYTHON_USE_WITH="xml"
-
-# make sure games is inherited first so that the gnome2
-# functions will be called if they are not overridden
-inherit autotools games eutils gnome2 python virtualx
-
-DESCRIPTION="Collection of games for the GNOME desktop"
-HOMEPAGE="http://live.gnome.org/GnomeGames/"
-
-LICENSE="GPL-2 GPL-3 FDL-1.1"
-SLOT="0"
-# TODO: file KEYWORDREQ bug once it's determined that seed is usable
-KEYWORDS="~amd64 ~x86"
-IUSE="artworkextra +aisleriot +clutter +introspection glchess seed +sudoku test"
-
-COMMON_DEPEND="
- >=dev-libs/dbus-glib-0.75
- >=dev-libs/glib-2.25.7
- >=dev-libs/libxml2-2.4.0
- >=gnome-base/gconf-2.31.1
- >=gnome-base/librsvg-2.32
- >=x11-libs/cairo-1
- >=x11-libs/gtk+-2.91.7:3[introspection?]
-
- media-libs/libcanberra[gtk3]
- x11-libs/libSM
-
- artworkextra? ( >=gnome-extra/gnome-games-extra-data-3.0.0 )
- clutter? (
- >=dev-libs/gobject-introspection-0.6.3
- >=x11-libs/gtk+-2.90:3[introspection]
- >=gnome-base/gconf-2.31.1[introspection]
- >=media-libs/clutter-gtk-0.91.6:1.0[introspection]
- seed? ( >=dev-libs/seed-2.91.90 ) )
- introspection? (
- >=dev-libs/gobject-introspection-0.6.3
- media-libs/clutter:1.0[introspection] )
- glchess? (
- dev-db/sqlite:3
- >=gnome-base/librsvg-2.32
- virtual/opengl
- x11-libs/libX11 )"
-RDEPEND="${COMMON_DEPEND}
- sudoku? (
- || (
- dev-python/pygobject:3[cairo]
- >=dev-python/pygobject-2.28.3:2[cairo,introspection] )
- dev-python/pycairo
- x11-libs/gdk-pixbuf:2[introspection]
- x11-libs/pango[introspection]
- >=x11-libs/gtk+-3.0.0:3[introspection] )
-
- !<gnome-extra/gnome-games-extra-data-3.0.0"
-DEPEND="${COMMON_DEPEND}
- glchess? ( >=dev-lang/vala-0.13.0:0.14 )
- virtual/pkgconfig
- >=dev-util/intltool-0.40.4
- >=sys-devel/gettext-0.10.40
- >=gnome-base/gnome-common-2.12.0
- >=app-text/scrollkeeper-0.3.8
- >=app-text/gnome-doc-utils-0.10
- test? ( >=dev-libs/check-0.9.4 )"
-
-# For compatibility with older versions of the gnome-games package
-PDEPEND="aisleriot? ( games-board/aisleriot )"
-
-# Others are installed below; multiples in this package.
-DOCS="AUTHORS HACKING MAINTAINERS TODO"
-
-_omitgame() {
- G2CONF="${G2CONF},${1}"
-}
-
-pkg_setup() {
- # create the games user / group
- games_pkg_setup
-
- python_set_active_version 2
- python_pkg_setup
-
- G2CONF="${G2CONF}
- --disable-schemas-compile
- --enable-sound
- $(use_enable introspection)"
-
- # Should be after $(use_enable introspection), but before --enable-omitgames
- use clutter && G2CONF="${G2CONF} --enable-introspection"
-
- use glchess && G2CONF="${G2CONF} VALAC=$(type -p valac-0.14)"
-
- # Staging games are needed for swell-foop and lightsoff
- G2CONF="${G2CONF}
- --enable-staging
- --with-scores-group=${GAMES_GROUP}
- --with-platform=gnome
- --with-smclient
- --with-gtk=3.0
- --enable-omitgames=none" # This line should be last for _omitgame
-
- # FIXME: Use REQUIRED_USE once games.eclass is ported to EAPI 4
- if ! use clutter; then
- ewarn "USE='-clutter' => quadrapassel, swell-foop, lightsoff, gnibbles won't be installed"
- _omitgame quadrapassel
- _omitgame gnibbles
- _omitgame swell-foop
- _omitgame lightsoff
- use seed && ewarn "USE='seed' has no effect with USE='-clutter'"
- elif ! use seed; then
- ewarn "USE='-seed' => swell-foop, lightsoff won't be installed"
- _omitgame swell-foop
- _omitgame lightsoff
- fi
-
- if ! use glchess; then
- _omitgame glchess
- fi
-
- if ! use sudoku; then
- _omitgame gnome-sudoku
- fi
-}
-
-src_prepare() {
- use sudoku && python_convert_shebangs -r 2 gnome-sudoku/src
-
- # TODO: File upstream bug for this
- epatch "${FILESDIR}/${PN}-2.91.90-fix-conditional-ac-prog-cxx.patch"
-
- # Without this, --enable-staging enables all those games unconditionally
- epatch "${FILESDIR}/${PN}-fix-staging-games.patch"
-
- eautoreconf
-
- # disable pyc compiling
- echo > py-compile
-
- gnome2_src_prepare
-}
-
-src_test() {
- Xemake check || die "tests failed"
-}
-
-src_install() {
- gnome2_src_install
-
- # Documentation install for each of the games
- for game in \
- $(find . -maxdepth 1 -type d ! -name po ! -name libgames-support); do
- docinto ${game}
- for doc in AUTHORS ChangeLog NEWS README TODO; do
- [ -s ${game}/${doc} ] && dodoc ${game}/${doc}
- done
- done
-}
-
-pkg_preinst() {
- gnome2_pkg_preinst
- # Avoid overwriting previous .scores files
- local basefile
- for scorefile in "${ED}"/var/lib/games/*.scores; do
- basefile=$(basename $scorefile)
- if [ -s "${EROOT}/var/lib/games/${basefile}" ]; then
- cp "${EROOT}/var/lib/games/${basefile}" \
- "${ED}/var/lib/games/${basefile}"
- fi
- done
-}
-
-pkg_postinst() {
- games_pkg_postinst
- gnome2_pkg_postinst
- python_need_rebuild
- use sudoku && python_mod_optimize gnome_sudoku
-}
-
-pkg_postrm() {
- gnome2_pkg_postrm
- python_mod_cleanup gnome_sudoku
-}