summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2008-02-24 22:33:31 +0000
committerGilles Dartiguelongue <eva@gentoo.org>2008-02-24 22:33:31 +0000
commit0040db4802a06b6259b28c4762e2ef071a738552 (patch)
treefc66d7520ea2e23e40594413df3eb0ebfab360db /gnome-extra
parentPick up maintainership. (diff)
downloadgentoo-2-0040db4802a06b6259b28c4762e2ef071a738552.tar.gz
gentoo-2-0040db4802a06b6259b28c4762e2ef071a738552.tar.bz2
gentoo-2-0040db4802a06b6259b28c4762e2ef071a738552.zip
fix bug #206459, removing GTK_DISABLE_DEPRECATED stanzas
(Portage version: 2.1.4.4)
Diffstat (limited to 'gnome-extra')
-rw-r--r--gnome-extra/lock-keys-applet/ChangeLog9
-rw-r--r--gnome-extra/lock-keys-applet/files/lock-keys-applet-1.0-gtk-disable-deprecated.patch28
-rw-r--r--gnome-extra/lock-keys-applet/lock-keys-applet-1.0.ebuild14
3 files changed, 46 insertions, 5 deletions
diff --git a/gnome-extra/lock-keys-applet/ChangeLog b/gnome-extra/lock-keys-applet/ChangeLog
index 141ddb494b6d..f98c6b741493 100644
--- a/gnome-extra/lock-keys-applet/ChangeLog
+++ b/gnome-extra/lock-keys-applet/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for gnome-extra/lock-keys-applet
-# Copyright 2000-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-extra/lock-keys-applet/ChangeLog,v 1.7 2005/07/19 02:55:10 tester Exp $
+# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/gnome-extra/lock-keys-applet/ChangeLog,v 1.8 2008/02/24 22:33:31 eva Exp $
+
+ 24 Feb 2008; Gilles Dartiguelongue <eva@gentoo.org>
+ +files/lock-keys-applet-1.0-gtk-disable-deprecated.patch,
+ lock-keys-applet-1.0.ebuild:
+ fix bug #206459, removing GTK_DISABLE_DEPRECATED stanzas
19 Jul 2005; Olivier Crête <tester@gentoo.org>
lock-keys-applet-1.0.ebuild:
diff --git a/gnome-extra/lock-keys-applet/files/lock-keys-applet-1.0-gtk-disable-deprecated.patch b/gnome-extra/lock-keys-applet/files/lock-keys-applet-1.0-gtk-disable-deprecated.patch
new file mode 100644
index 000000000000..b38987e8f0c0
--- /dev/null
+++ b/gnome-extra/lock-keys-applet/files/lock-keys-applet-1.0-gtk-disable-deprecated.patch
@@ -0,0 +1,28 @@
+#
+# Remove GTK_DISABLE_DEPRECATED stanzas to allow building against >= GTK+ 2.12
+#
+# Patch taken from:
+# http://patches.ubuntu.com/by-release/extracted/ubuntu/l/lock-keys-applet/1.0-8.1/02_gtk_disable_deprecated.patch
+#
+diff -Naur lock-keys-applet-1.0/src/Makefile.am lock-keys-applet.new/src/Makefile.am
+--- lock-keys-applet-1.0/src/Makefile.am 2003-01-07 22:20:40.000000000 +0100
++++ lock-keys-applet.new/src/Makefile.am 2007-12-10 19:37:37.000000000 +0100
+@@ -1,7 +1,6 @@
+ INCLUDES = -I$(top_srcdir) -I$(includedir) $(LK_APPLET_CFLAGS) \
+ -DGNOMELOCALEDIR=\""$(datadir)/locale"\" \
+ -DGNOME_DISABLE_DEPRECATED \
+- -DGTK_DISABLE_DEPRECATED \
+ -DGDK_DISABLE_DEPRECATED \
+ -DG_DISABLE_DEPRECATED \
+ -DDATADIR=\""$(datadir)/"\" \
+diff -Naur lock-keys-applet-1.0/src/Makefile.in lock-keys-applet.new/src/Makefile.in
+--- lock-keys-applet-1.0/src/Makefile.in 2007-12-10 19:36:28.000000000 +0100
++++ lock-keys-applet.new/src/Makefile.in 2007-12-10 19:37:42.000000000 +0100
+@@ -174,7 +174,6 @@
+ INCLUDES = -I$(top_srcdir) -I$(includedir) $(LK_APPLET_CFLAGS) \
+ -DGNOMELOCALEDIR=\""$(datadir)/locale"\" \
+ -DGNOME_DISABLE_DEPRECATED \
+- -DGTK_DISABLE_DEPRECATED \
+ -DGDK_DISABLE_DEPRECATED \
+ -DG_DISABLE_DEPRECATED \
+ -DDATADIR=\""$(datadir)/"\" \
diff --git a/gnome-extra/lock-keys-applet/lock-keys-applet-1.0.ebuild b/gnome-extra/lock-keys-applet/lock-keys-applet-1.0.ebuild
index 31c9556a8d8c..b9df6d1e4edd 100644
--- a/gnome-extra/lock-keys-applet/lock-keys-applet-1.0.ebuild
+++ b/gnome-extra/lock-keys-applet/lock-keys-applet-1.0.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-extra/lock-keys-applet/lock-keys-applet-1.0.ebuild,v 1.10 2007/11/21 11:41:12 drac Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnome-extra/lock-keys-applet/lock-keys-applet-1.0.ebuild,v 1.11 2008/02/24 22:33:31 eva Exp $
-inherit gnome2
+inherit gnome2 eutils
DESCRIPTION="An applet that shows the status of your Caps, Num and Scroll Lock keys"
HOMEPAGE="http://mfcn.ilo.de/led_applet"
@@ -21,3 +21,11 @@ DEPEND="${RDEPEND}
app-text/scrollkeeper"
DOCS="AUTHORS ChangeLog NEWS README TODO"
+
+src_unpack() {
+ gnome2_src_unpack
+
+ # remove deprecated definitions, bug #206459
+ # courtesy of ubuntu/debian developers
+ epatch "${FILESDIR}/${P}-gtk-disable-deprecated.patch"
+}