summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2009-07-09 21:46:00 +0000
committerGilles Dartiguelongue <eva@gentoo.org>2009-07-09 21:46:00 +0000
commitbff1137dcc6ae0e83025bbd38fcfc9c7704c6c0d (patch)
treeaf86275dd31b1dc7636c4cdffa5f9ddece96c927 /gnome-extra/tasks
parentMore strict init.d dependency, ought to fix bug #144592 thanks to Stefano Pri... (diff)
downloadgentoo-2-bff1137dcc6ae0e83025bbd38fcfc9c7704c6c0d.tar.gz
gentoo-2-bff1137dcc6ae0e83025bbd38fcfc9c7704c6c0d.tar.bz2
gentoo-2-bff1137dcc6ae0e83025bbd38fcfc9c7704c6c0d.zip
Add missing config.h include, bug #277115. Add libunique to DEPEND.
(Portage version: 2.2_rc33/cvs/Linux x86_64)
Diffstat (limited to 'gnome-extra/tasks')
-rw-r--r--gnome-extra/tasks/ChangeLog8
-rw-r--r--gnome-extra/tasks/files/tasks-0.14-configh.patch10
-rw-r--r--gnome-extra/tasks/tasks-0.14.ebuild21
3 files changed, 33 insertions, 6 deletions
diff --git a/gnome-extra/tasks/ChangeLog b/gnome-extra/tasks/ChangeLog
index fbdac9211edf..76b8470743a8 100644
--- a/gnome-extra/tasks/ChangeLog
+++ b/gnome-extra/tasks/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for gnome-extra/tasks
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-extra/tasks/ChangeLog,v 1.2 2008/10/02 21:00:38 eva Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/gnome-extra/tasks/ChangeLog,v 1.3 2009/07/09 21:46:00 eva Exp $
+
+ 09 Jul 2009; Gilles Dartiguelongue <eva@gentoo.org> tasks-0.14.ebuild,
+ +files/tasks-0.14-configh.patch:
+ Add missing config.h include, bug #277115. Add libunique to DEPEND.
*tasks-0.14 (02 Oct 2008)
diff --git a/gnome-extra/tasks/files/tasks-0.14-configh.patch b/gnome-extra/tasks/files/tasks-0.14-configh.patch
new file mode 100644
index 000000000000..4b42323752a8
--- /dev/null
+++ b/gnome-extra/tasks/files/tasks-0.14-configh.patch
@@ -0,0 +1,10 @@
+--- libkoto/ical-util.c 2008-02-18 20:43:35.000000000 +0100
++++ libkoto/ical-util.c 2009-07-09 23:37:25.000000000 +0200
+@@ -34,6 +34,7 @@
+ }
+
+ #include "ical-util.h"
++#include <config.h>
+
+ #include <glib.h>
+ #include <glib/gi18n-lib.h>
diff --git a/gnome-extra/tasks/tasks-0.14.ebuild b/gnome-extra/tasks/tasks-0.14.ebuild
index ed3ce8b9d5e6..355a4459bb01 100644
--- a/gnome-extra/tasks/tasks-0.14.ebuild
+++ b/gnome-extra/tasks/tasks-0.14.ebuild
@@ -1,8 +1,11 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-extra/tasks/tasks-0.14.ebuild,v 1.1 2008/10/02 21:00:38 eva Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnome-extra/tasks/tasks-0.14.ebuild,v 1.2 2009/07/09 21:46:00 eva Exp $
-inherit gnome2
+EAPI="2"
+GCONF_DEBUG="no"
+
+inherit eutils gnome2
DESCRIPTION="A small, lightweight to-do list for Gnome"
HOMEPAGE="http://pimlico-project.org/tasks.html"
@@ -18,7 +21,8 @@ IUSE=""
RDEPEND=">=gnome-extra/evolution-data-server-1.8
>=x11-libs/gtk+-2.6
- >=dev-libs/glib-2.14"
+ >=dev-libs/glib-2.14
+ >=dev-libs/libunique-1"
DEPEND="${RDEPEND}
>=dev-util/pkgconfig-0.9.0
@@ -26,3 +30,12 @@ DEPEND="${RDEPEND}
sys-devel/gettext"
DOCS="AUTHORS ChangeLog INSTALL NEWS README"
+
+pkg_setup() {
+ G2CONF="${G2CONF} --with-unique --enable-gtk"
+}
+
+src_prepare() {
+ # Add missing config.h, bug #277115
+ epatch "${FILESDIR}/${P}-configh.patch"
+}