summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobert Buchholz <rbu@gentoo.org>2009-04-24 12:28:16 +0000
committerRobert Buchholz <rbu@gentoo.org>2009-04-24 12:28:16 +0000
commit35c3715253dfa0e04da60ed4640594aacab55f07 (patch)
treeeaffd6f96ac1c830886c3c73746053ad2e85b1bc /gnome-extra/nm-applet
parentReadd NM 0.6.5 for ppc. (diff)
downloadgentoo-2-35c3715253dfa0e04da60ed4640594aacab55f07.tar.gz
gentoo-2-35c3715253dfa0e04da60ed4640594aacab55f07.tar.bz2
gentoo-2-35c3715253dfa0e04da60ed4640594aacab55f07.zip
Readd NM 0.6.5 for ppc.
(Portage version: 2.1.6.11/cvs/Linux x86_64, RepoMan options: --force)
Diffstat (limited to 'gnome-extra/nm-applet')
-rw-r--r--gnome-extra/nm-applet/ChangeLog5
-rw-r--r--gnome-extra/nm-applet/nm-applet-0.6.5.ebuild61
2 files changed, 65 insertions, 1 deletions
diff --git a/gnome-extra/nm-applet/ChangeLog b/gnome-extra/nm-applet/ChangeLog
index 5c4141d36db1..8ac46905bd9f 100644
--- a/gnome-extra/nm-applet/ChangeLog
+++ b/gnome-extra/nm-applet/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for gnome-extra/nm-applet
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-extra/nm-applet/ChangeLog,v 1.24 2009/04/22 14:28:41 rbu Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnome-extra/nm-applet/ChangeLog,v 1.25 2009/04/24 12:28:16 rbu Exp $
+
+ 24 Apr 2009; Robert Buchholz <rbu@gentoo.org> +nm-applet-0.6.5.ebuild:
+ Readd NM 0.6.5 for ppc.
*nm-applet-0.7.1 (22 Apr 2009)
diff --git a/gnome-extra/nm-applet/nm-applet-0.6.5.ebuild b/gnome-extra/nm-applet/nm-applet-0.6.5.ebuild
new file mode 100644
index 000000000000..9b0cfbc7a406
--- /dev/null
+++ b/gnome-extra/nm-applet/nm-applet-0.6.5.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/gnome-extra/nm-applet/nm-applet-0.6.5.ebuild,v 1.12 2009/04/24 12:28:16 rbu Exp $
+
+inherit gnome2 eutils
+
+MY_PV=${PV/_*/}
+
+DESCRIPTION="Gnome applet for NetworkManager."
+HOMEPAGE="http://www.gnome.org/projects/NetworkManager/"
+SRC_URI="http://ftp.gnome.org/pub/gnome/sources/network-manager-applet/0.6/network-manager-applet-0.6.5.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="ppc"
+IUSE="debug doc libnotify"
+
+RDEPEND=">=sys-apps/dbus-0.60
+ >=sys-apps/hal-0.5
+ sys-apps/iproute2
+ >=net-misc/dhcdbd-1.4
+ net-misc/networkmanager
+ >=net-wireless/wireless-tools-28_pre9
+ >=net-wireless/wpa_supplicant-0.4.8
+ >=dev-libs/glib-2.10
+ libnotify? ( >=x11-libs/libnotify-0.4.3 )
+ >=x11-libs/gtk+-2.10
+ >=gnome-base/libglade-2
+ >=gnome-base/gnome-keyring-0.4
+ || ( >=gnome-base/gnome-panel-2 xfce-base/xfce4-panel )
+ >=gnome-base/gconf-2
+ >=gnome-base/libgnomeui-2"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ >=dev-util/intltool-0.35"
+
+DOCS="AUTHORS COPYING ChangeLog INSTALL NEWS README"
+USE_DESTDIR="1"
+
+G2CONF="${G2CONF} \
+ --disable-more-warnings \
+ --localstatedir=/var \
+ --with-dbus-sys=/etc/dbus-1/system.d \
+ $(use_with libnotify notify)"
+
+S=${WORKDIR}/${PN}-${MY_PV}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}/${PN}-0.6.5-confchanges.patch"
+}
+
+pkg_postinst() {
+ gnome2_pkg_postinst
+ elog "Your user needs to be in the plugdev group in order to use this"
+ elog "package. If it doesn't start in Gnome for you automatically after"
+ elog 'you log back in, simply run "nm-applet --sm-disable"'
+ elog "You also need the notification area applet on your panel for"
+ elog "this to show up."
+}