summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2008-07-28 22:38:57 +0000
committerGilles Dartiguelongue <eva@gentoo.org>2008-07-28 22:38:57 +0000
commite360d364699d499912bf215be003645add501fa2 (patch)
treed0b7a560f3c62146e7d4d0f524015896da8cd839 /gnome-extra/music-applet
parentremove old revisions. (diff)
downloadgentoo-2-e360d364699d499912bf215be003645add501fa2.tar.gz
gentoo-2-e360d364699d499912bf215be003645add501fa2.tar.bz2
gentoo-2-e360d364699d499912bf215be003645add501fa2.zip
bump to 2.4.1 and fix changelog
(Portage version: 2.2_rc3/cvs/Linux 2.6.24-gentoo-r8-mactel x86_64)
Diffstat (limited to 'gnome-extra/music-applet')
-rw-r--r--gnome-extra/music-applet/ChangeLog15
-rw-r--r--gnome-extra/music-applet/music-applet-2.4.1.ebuild48
2 files changed, 62 insertions, 1 deletions
diff --git a/gnome-extra/music-applet/ChangeLog b/gnome-extra/music-applet/ChangeLog
index be498ec66e35..8e0cc4c7b35f 100644
--- a/gnome-extra/music-applet/ChangeLog
+++ b/gnome-extra/music-applet/ChangeLog
@@ -1,11 +1,24 @@
# ChangeLog for gnome-extra/music-applet
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-extra/music-applet/ChangeLog,v 1.14 2008/05/29 17:11:44 hawking Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnome-extra/music-applet/ChangeLog,v 1.15 2008/07/28 22:38:57 eva Exp $
+
+*music-applet-2.4.1 (28 Jul 2008)
+
+ 28 Jul 2008; Gilles Dartiguelongue <eva@gentoo.org>
+ +music-applet-2.4.1.ebuild:
+ bump to 2.4.1 and fix changelog
29 May 2008; Ali Polatel <hawking@gentoo.org> music-applet-2.3.0.ebuild,
music-applet-2.3.0-r1.ebuild, music-applet-2.3.1.ebuild:
python_mod_optimize is ROOT aware. Fixed python_mod_cleanup.
+*music-applet-2.3.0-r1 (05 May 2008)
+
+ 05 May 2008; Olivier Crete <tester@gentoo.org>
+ +music-applet-2.3.0-r1.ebuild:
+ Add patch to install the .so files in the proper directly in
+ multilib systems
+
*music-applet-2.3.1 (17 Apr 2008)
17 Apr 2008; Gilles Dartiguelongue <eva@gentoo.org>
diff --git a/gnome-extra/music-applet/music-applet-2.4.1.ebuild b/gnome-extra/music-applet/music-applet-2.4.1.ebuild
new file mode 100644
index 000000000000..c1196f512951
--- /dev/null
+++ b/gnome-extra/music-applet/music-applet-2.4.1.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/gnome-extra/music-applet/music-applet-2.4.1.ebuild,v 1.1 2008/07/28 22:38:57 eva Exp $
+
+inherit gnome2 python eutils
+
+DESCRIPTION="GNOME applet to control various music players"
+HOMEPAGE="http://www.kuliniewicz.org/music-applet"
+SRC_URI="http://www.kuliniewicz.org/${PN}/downloads/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="libnotify"
+
+# This ebuild is far from perfect, it does a lot of automagic detection
+
+RDEPEND=">=x11-libs/gtk+-2.6
+ >=x11-libs/pango-1.6
+ >=gnome-base/libgnomeui-2
+ >=gnome-base/gnome-panel-2
+ >=dev-python/gnome-python-desktop-2.14
+ >=dev-python/numeric-24.2
+ >=dev-python/dbus-python-0.80
+ >=dev-libs/dbus-glib-0.71
+ >=dev-python/pygtk-2.6
+ libnotify? ( dev-python/notify-python )"
+DEPEND="dev-util/pkgconfig
+ dev-util/intltool"
+
+src_unpack() {
+ gnome2_src_unpack
+
+ # disable pyc compiling
+ mv py-compile py-compile.orig
+ ln -s $(type -P true) py-compile
+}
+
+pkg_postinst() {
+ gnome2_pkg_postinst
+ python_version
+ python_mod_optimize /usr/$(get_libdir)/python${PYVER}/site-packages/musicapplet
+}
+
+pkg_postrm() {
+ gnome2_pkg_postrm
+ python_mod_cleanup /usr/$(get_libdir)/python*/site-packages/musicapplet
+}