summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2009-01-03 14:20:37 +0000
committerGilles Dartiguelongue <eva@gentoo.org>2009-01-03 14:20:37 +0000
commitcaa92eb6e12854c4038318ff8a0363b118703cf6 (patch)
treefece737808dc4d9936394bc877f5e18ac2f51af2 /gnome-extra/music-applet
parentQA: Respect CC (bug 243940) (diff)
downloadgentoo-2-caa92eb6e12854c4038318ff8a0363b118703cf6.tar.gz
gentoo-2-caa92eb6e12854c4038318ff8a0363b118703cf6.tar.bz2
gentoo-2-caa92eb6e12854c4038318ff8a0363b118703cf6.zip
Bump to 2.5.0. Leaks less, encoding fixes and bug fixes. Uses split gnome python bindings, bug #242640.
(Portage version: 2.2_rc20/cvs/Linux 2.6.28-gentoo x86_64)
Diffstat (limited to 'gnome-extra/music-applet')
-rw-r--r--gnome-extra/music-applet/ChangeLog11
-rw-r--r--gnome-extra/music-applet/music-applet-2.5.0.ebuild50
2 files changed, 59 insertions, 2 deletions
diff --git a/gnome-extra/music-applet/ChangeLog b/gnome-extra/music-applet/ChangeLog
index 1a0332706e28..578757c3cfce 100644
--- a/gnome-extra/music-applet/ChangeLog
+++ b/gnome-extra/music-applet/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for gnome-extra/music-applet
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-extra/music-applet/ChangeLog,v 1.19 2008/11/16 19:01:40 eva Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/gnome-extra/music-applet/ChangeLog,v 1.20 2009/01/03 14:20:37 eva Exp $
+
+*music-applet-2.5.0 (03 Jan 2009)
+
+ 03 Jan 2009; Gilles Dartiguelongue <eva@gentoo.org>
+ +music-applet-2.5.0.ebuild:
+ Bump to 2.5.0. Leaks less, encoding fixes and bug fixes.
+ Uses split gnome python bindings, bug #242640.
16 Nov 2008; Gilles Dartiguelongue <eva@gentoo.org>
music-applet-2.3.1.ebuild, -music-applet-2.4.1.ebuild,
diff --git a/gnome-extra/music-applet/music-applet-2.5.0.ebuild b/gnome-extra/music-applet/music-applet-2.5.0.ebuild
new file mode 100644
index 000000000000..c36974117d5a
--- /dev/null
+++ b/gnome-extra/music-applet/music-applet-2.5.0.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/gnome-extra/music-applet/music-applet-2.5.0.ebuild,v 1.1 2009/01/03 14:20:37 eva Exp $
+
+inherit gnome2 python eutils
+
+DESCRIPTION="GNOME applet to control various music players"
+HOMEPAGE="http://www.kuliniewicz.org/music-applet"
+SRC_URI="http://www.kuliniewicz.org/${PN}/downloads/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="libnotify"
+
+# This ebuild is far from perfect, it does a lot of automagic detection
+
+RDEPEND=">=x11-libs/gtk+-2.6
+ >=x11-libs/pango-1.6
+ >=gnome-base/libgnomeui-2
+ >=gnome-base/gnome-panel-2
+ >=dev-python/gconf-python-2.14
+ >=dev-python/gnome-keyring-python-2.14
+ >=dev-python/gnome-applets-python-2.14
+ >=dev-python/dbus-python-0.80
+ >=dev-libs/dbus-glib-0.71
+ >=dev-python/pygtk-2.6
+ dev-python/pygobject
+ libnotify? ( dev-python/notify-python )"
+DEPEND="dev-util/pkgconfig
+ dev-util/intltool"
+
+src_unpack() {
+ gnome2_src_unpack
+
+ # disable pyc compiling
+ mv py-compile py-compile.orig
+ ln -s $(type -P true) py-compile
+}
+
+pkg_postinst() {
+ gnome2_pkg_postinst
+ python_version
+ python_mod_optimize /usr/$(get_libdir)/python${PYVER}/site-packages/musicapplet
+}
+
+pkg_postrm() {
+ gnome2_pkg_postrm
+ python_mod_cleanup /usr/$(get_libdir)/python*/site-packages/musicapplet
+}