summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2008-08-17 21:39:55 +0000
committerGilles Dartiguelongue <eva@gentoo.org>2008-08-17 21:39:55 +0000
commit484f04588fdb228e7508f4f3b3191956e33d88ed (patch)
tree309a46f01100a7341b9a30ddd188ff3f2d91e3a6 /gnome-extra/music-applet
parentamd64 stable, bug #234615 (diff)
downloadgentoo-2-484f04588fdb228e7508f4f3b3191956e33d88ed.tar.gz
gentoo-2-484f04588fdb228e7508f4f3b3191956e33d88ed.tar.bz2
gentoo-2-484f04588fdb228e7508f4f3b3191956e33d88ed.zip
bump to 2.4.2. Fixed gradual increase in CPU usage after each song change.
(Portage version: 2.2_rc8/cvs/Linux 2.6.26-gentoo-mactel x86_64)
Diffstat (limited to 'gnome-extra/music-applet')
-rw-r--r--gnome-extra/music-applet/ChangeLog8
-rw-r--r--gnome-extra/music-applet/music-applet-2.4.2.ebuild48
2 files changed, 55 insertions, 1 deletions
diff --git a/gnome-extra/music-applet/ChangeLog b/gnome-extra/music-applet/ChangeLog
index 561c132e3895..0175911a1a7b 100644
--- a/gnome-extra/music-applet/ChangeLog
+++ b/gnome-extra/music-applet/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for gnome-extra/music-applet
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-extra/music-applet/ChangeLog,v 1.17 2008/08/09 12:51:27 eva Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnome-extra/music-applet/ChangeLog,v 1.18 2008/08/17 21:39:55 eva Exp $
+
+*music-applet-2.4.2 (17 Aug 2008)
+
+ 17 Aug 2008; Gilles Dartiguelongue <eva@gentoo.org>
+ +music-applet-2.4.2.ebuild:
+ bump to 2.4.2. Fixed gradual increase in CPU usage after each song change.
09 Aug 2008; Gilles Dartiguelongue <eva@gentoo.org>
-files/music-applet-2.3.0-pyexecdir.patch, -music-applet-2.3.0.ebuild,
diff --git a/gnome-extra/music-applet/music-applet-2.4.2.ebuild b/gnome-extra/music-applet/music-applet-2.4.2.ebuild
new file mode 100644
index 000000000000..34c8967b784d
--- /dev/null
+++ b/gnome-extra/music-applet/music-applet-2.4.2.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/gnome-extra/music-applet/music-applet-2.4.2.ebuild,v 1.1 2008/08/17 21:39:55 eva Exp $
+
+inherit gnome2 python eutils
+
+DESCRIPTION="GNOME applet to control various music players"
+HOMEPAGE="http://www.kuliniewicz.org/music-applet"
+SRC_URI="http://www.kuliniewicz.org/${PN}/downloads/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="libnotify"
+
+# This ebuild is far from perfect, it does a lot of automagic detection
+
+RDEPEND=">=x11-libs/gtk+-2.6
+ >=x11-libs/pango-1.6
+ >=gnome-base/libgnomeui-2
+ >=gnome-base/gnome-panel-2
+ >=dev-python/gnome-python-desktop-2.14
+ >=dev-python/numeric-24.2
+ >=dev-python/dbus-python-0.80
+ >=dev-libs/dbus-glib-0.71
+ >=dev-python/pygtk-2.6
+ libnotify? ( dev-python/notify-python )"
+DEPEND="dev-util/pkgconfig
+ dev-util/intltool"
+
+src_unpack() {
+ gnome2_src_unpack
+
+ # disable pyc compiling
+ mv py-compile py-compile.orig
+ ln -s $(type -P true) py-compile
+}
+
+pkg_postinst() {
+ gnome2_pkg_postinst
+ python_version
+ python_mod_optimize /usr/$(get_libdir)/python${PYVER}/site-packages/musicapplet
+}
+
+pkg_postrm() {
+ gnome2_pkg_postrm
+ python_mod_cleanup /usr/$(get_libdir)/python*/site-packages/musicapplet
+}