summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRoy Marples <uberlord@gentoo.org>2007-07-27 14:19:11 +0000
committerRoy Marples <uberlord@gentoo.org>2007-07-27 14:19:11 +0000
commit9599a75777a89af7a4951891398cc29c28de9dab (patch)
tree140c763e4e06cd64d800491788dd4fe3b3be2c55 /gnome-extra/libgda
parentStable for HPPA (bug #186737). (diff)
downloadgentoo-2-9599a75777a89af7a4951891398cc29c28de9dab.tar.gz
gentoo-2-9599a75777a89af7a4951891398cc29c28de9dab.tar.bz2
gentoo-2-9599a75777a89af7a4951891398cc29c28de9dab.zip
Fix using berkdb on FreeBSD
(Portage version: 2.1.2.9)
Diffstat (limited to 'gnome-extra/libgda')
-rw-r--r--gnome-extra/libgda/ChangeLog6
-rw-r--r--gnome-extra/libgda/libgda-1.2.4.ebuild5
-rw-r--r--gnome-extra/libgda/libgda-3.0.1.ebuild5
3 files changed, 11 insertions, 5 deletions
diff --git a/gnome-extra/libgda/ChangeLog b/gnome-extra/libgda/ChangeLog
index 2a93db8adeba..9a8b8db5c6ba 100644
--- a/gnome-extra/libgda/ChangeLog
+++ b/gnome-extra/libgda/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for gnome-extra/libgda
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-extra/libgda/ChangeLog,v 1.108 2007/07/05 14:42:42 uberlord Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnome-extra/libgda/ChangeLog,v 1.109 2007/07/27 14:19:11 uberlord Exp $
+
+ 27 Jul 2007; Roy Marples <uberlord@gentoo.org> libgda-1.2.4.ebuild,
+ libgda-3.0.1.ebuild:
+ Fix using berkdb on FreeBSD
05 Jul 2007; Roy Marples <uberlord@gentoo.org> libgda-1.2.4.ebuild:
Keyworded ~x86-fbsd.
diff --git a/gnome-extra/libgda/libgda-1.2.4.ebuild b/gnome-extra/libgda/libgda-1.2.4.ebuild
index 19035621d0c8..3cfe3ffac8aa 100644
--- a/gnome-extra/libgda/libgda-1.2.4.ebuild
+++ b/gnome-extra/libgda/libgda-1.2.4.ebuild
@@ -1,11 +1,11 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-extra/libgda/libgda-1.2.4.ebuild,v 1.3 2007/07/12 04:19:34 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnome-extra/libgda/libgda-1.2.4.ebuild,v 1.4 2007/07/27 14:19:11 uberlord Exp $
WANT_AUTOMAKE="1.9"
WANT_AUTOCONF="2.5"
-inherit autotools eutils gnome2
+inherit autotools db-use eutils flag-o-matic gnome2
DESCRIPTION="Gnome Database Access Library"
HOMEPAGE="http://www.gnome-db.org/"
@@ -56,6 +56,7 @@ pkg_setup() {
$(use_with sqlite3 sqlite /usr) \
$(use_with xbase xbase /usr)"
+ use berkdb && append-cppflags "-I$(db_includedir)"
use oci8 || G2CONF="${G2CONF} --without-oracle"
# not in portage
diff --git a/gnome-extra/libgda/libgda-3.0.1.ebuild b/gnome-extra/libgda/libgda-3.0.1.ebuild
index 6f0a51039216..e4d97fd6ea91 100644
--- a/gnome-extra/libgda/libgda-3.0.1.ebuild
+++ b/gnome-extra/libgda/libgda-3.0.1.ebuild
@@ -1,11 +1,11 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-extra/libgda/libgda-3.0.1.ebuild,v 1.2 2007/07/12 04:19:34 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnome-extra/libgda/libgda-3.0.1.ebuild,v 1.3 2007/07/27 14:19:11 uberlord Exp $
# TODO:
# * Verify if the parallel compilation problems persist, and if so fix them.
-inherit gnome2
+inherit db-use flag-o-matic gnome2
DESCRIPTION="Gnome Database Access Library"
HOMEPAGE="http://www.gnome-db.org/"
@@ -53,6 +53,7 @@ pkg_setup() {
--without-mdb"
# $(use_with mdb mdb /usr) \
+ use berkdb && append-cppflags "-I$(db_includedir)"
use oci8 || G2CONF="${G2CONF} --without-oracle"
# Not in portage