summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexandre Rostovtsev <tetromino@gentoo.org>2012-01-26 01:06:31 +0000
committerAlexandre Rostovtsev <tetromino@gentoo.org>2012-01-26 01:06:31 +0000
commit32f9852d2a197e6c3dff74b5f8f47d4f111b1ded (patch)
tree767df3988f297e0511f70d93dc0a45e554489dee /gnome-extra/libgda
parentAdd USE=tcpd support #400607 by Tor. (diff)
downloadgentoo-2-32f9852d2a197e6c3dff74b5f8f47d4f111b1ded.tar.gz
gentoo-2-32f9852d2a197e6c3dff74b5f8f47d4f111b1ded.tar.bz2
gentoo-2-32f9852d2a197e6c3dff74b5f8f47d4f111b1ded.zip
Disable building vala bindings for now due to https://bugzilla.gnome.org/show_bug.cgi?id=668701
(Portage version: 2.2.0_alpha84/cvs/Linux x86_64)
Diffstat (limited to 'gnome-extra/libgda')
-rw-r--r--gnome-extra/libgda/ChangeLog7
-rw-r--r--gnome-extra/libgda/files/libgda-5.0.3-custom.vala6
-rw-r--r--gnome-extra/libgda/libgda-5.0.3.ebuild16
3 files changed, 23 insertions, 6 deletions
diff --git a/gnome-extra/libgda/ChangeLog b/gnome-extra/libgda/ChangeLog
index 5e7fb0612318..d670be4e7fc4 100644
--- a/gnome-extra/libgda/ChangeLog
+++ b/gnome-extra/libgda/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for gnome-extra/libgda
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-extra/libgda/ChangeLog,v 1.191 2012/01/25 11:01:11 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnome-extra/libgda/ChangeLog,v 1.192 2012/01/26 01:06:31 tetromino Exp $
+
+ 26 Jan 2012; Alexandre Rostovtsev <tetromino@gentoo.org> libgda-5.0.3.ebuild,
+ +files/libgda-5.0.3-custom.vala:
+ Disable building vala bindings for now due to
+ https://bugzilla.gnome.org/show_bug.cgi?id=668701
*libgda-5.0.3 (25 Jan 2012)
diff --git a/gnome-extra/libgda/files/libgda-5.0.3-custom.vala b/gnome-extra/libgda/files/libgda-5.0.3-custom.vala
new file mode 100644
index 000000000000..d464a8f9cc06
--- /dev/null
+++ b/gnome-extra/libgda/files/libgda-5.0.3-custom.vala
@@ -0,0 +1,6 @@
+namespace Gda {
+ public class DataProxy : GLib.Object, Gda.DataModel {
+ [CCode (cname="gda_data_proxy_new")]
+ public static GLib.Object @new (Gda.DataModel model);
+ }
+}
diff --git a/gnome-extra/libgda/libgda-5.0.3.ebuild b/gnome-extra/libgda/libgda-5.0.3.ebuild
index 7aa88a18fdb8..258a50bfcfcf 100644
--- a/gnome-extra/libgda/libgda-5.0.3.ebuild
+++ b/gnome-extra/libgda/libgda-5.0.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-extra/libgda/libgda-5.0.3.ebuild,v 1.1 2012/01/25 11:01:11 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnome-extra/libgda/libgda-5.0.3.ebuild,v 1.2 2012/01/26 01:06:31 tetromino Exp $
EAPI="4"
GNOME2_LA_PUNT="yes"
@@ -13,7 +13,7 @@ DESCRIPTION="Gnome Database Access Library"
HOMEPAGE="http://www.gnome-db.org/"
LICENSE="GPL-2 LGPL-2"
-IUSE="berkdb bindist canvas doc firebird gnome-keyring gtk graphviz http +introspection json ldap mdb mysql oci8 postgres sourceview ssl vala"
+IUSE="berkdb bindist canvas doc firebird gnome-keyring gtk graphviz http +introspection json ldap mdb mysql oci8 postgres sourceview ssl" # vala
SLOT="5"
KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
@@ -47,8 +47,8 @@ DEPEND="${RDEPEND}
>=dev-util/pkgconfig-0.18
>=dev-util/intltool-0.35.5
>=app-text/gnome-doc-utils-0.9
- doc? ( >=dev-util/gtk-doc-1 )
- vala? ( >=dev-lang/vala-0.14:0.14[vapigen] )"
+ doc? ( >=dev-util/gtk-doc-1 )"
+# vala? ( >=dev-lang/vala-0.14:0.14[vapigen] )
pkg_setup() {
DOCS="AUTHORS ChangeLog NEWS README"
@@ -82,7 +82,10 @@ pkg_setup() {
$(use_with mysql mysql /usr)
$(use_with postgres postgres /usr)
$(use_enable ssl crypto)
- $(use_enable vala)"
+ --disable-vala
+ VAPIGEN=$(type -P vapigen-0.14)"
+# $(use_enable vala)
+ # Disable vala due to https://bugzilla.gnome.org/show_bug.cgi?id=668701
if use bindist; then
# firebird license is not GPL compatible
@@ -129,6 +132,9 @@ src_prepare() {
python_convert_shebangs -r 2 libgda-report/RML/trml2{html,pdf}
+ # Missing from tarball
+ cp "${FILESDIR}/libgda-${PV}-custom.vala" libgda/libgda-5.0-custom.vala || die
+
intltoolize --force --copy --automake || die "intltoolize failed"
eautoreconf
gnome2_src_prepare