summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2015-06-20 09:59:11 +0000
committerPacho Ramos <pacho@gentoo.org>2015-06-20 09:59:11 +0000
commit2fbcf55d672c32d31cd406e906a5daa598eb798a (patch)
tree2f64d1b7b3b5ca4bc6b5c52b852f649c0e31d0ee /gnome-extra/libgda
parentCleanup (diff)
downloadgentoo-2-2fbcf55d672c32d31cd406e906a5daa598eb798a.tar.gz
gentoo-2-2fbcf55d672c32d31cd406e906a5daa598eb798a.tar.bz2
gentoo-2-2fbcf55d672c32d31cd406e906a5daa598eb798a.zip
Version bump, fix java detection (#450004 by Juergen Rose and Tom Wijsman (TomWij)), enable vala (#507022 by Markus Moll), fix compilation with format-security (#517610 by Agostino Sarubbo)
(Portage version: 2.2.20/cvs/Linux x86_64, signed Manifest commit with key A188FBD4)
Diffstat (limited to 'gnome-extra/libgda')
-rw-r--r--gnome-extra/libgda/ChangeLog11
-rw-r--r--gnome-extra/libgda/files/libgda-5.2.4-format-security.patch29
-rw-r--r--gnome-extra/libgda/files/libgda-5.2.4-jre18.patch14
-rw-r--r--gnome-extra/libgda/libgda-5.2.4.ebuild168
4 files changed, 221 insertions, 1 deletions
diff --git a/gnome-extra/libgda/ChangeLog b/gnome-extra/libgda/ChangeLog
index 4673c2705668..7be17a583386 100644
--- a/gnome-extra/libgda/ChangeLog
+++ b/gnome-extra/libgda/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for gnome-extra/libgda
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-extra/libgda/ChangeLog,v 1.231 2015/04/18 08:08:07 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnome-extra/libgda/ChangeLog,v 1.232 2015/06/20 09:59:11 pacho Exp $
+
+*libgda-5.2.4 (20 Jun 2015)
+
+ 20 Jun 2015; Pacho Ramos <pacho@gentoo.org>
+ +files/libgda-5.2.4-format-security.patch, +files/libgda-5.2.4-jre18.patch,
+ +libgda-5.2.4.ebuild:
+ Version bump, fix java detection (#450004 by Juergen Rose and Tom Wijsman
+ (TomWij)), enable vala (#507022 by Markus Moll), fix compilation with format-
+ security (#517610 by Agostino Sarubbo)
18 Apr 2015; Pacho Ramos <pacho@gentoo.org> libgda-5.2.2.ebuild:
yelp-tools needed at build time (#514320)
diff --git a/gnome-extra/libgda/files/libgda-5.2.4-format-security.patch b/gnome-extra/libgda/files/libgda-5.2.4-format-security.patch
new file mode 100644
index 000000000000..81c7804c512c
--- /dev/null
+++ b/gnome-extra/libgda/files/libgda-5.2.4-format-security.patch
@@ -0,0 +1,29 @@
+From 68af249e1c36cbac2e39903b0fc357e3ad2bf1ee Mon Sep 17 00:00:00 2001
+From: Vivien Malerba <malerba@gnome-db.org>
+Date: Wed, 16 Apr 2014 14:59:50 +0200
+Subject: [PATCH] Markup message correction
+
+---
+ libgda-ui/demos/ddl_queries.c | 6 +++---
+ 1 file changed, 3 insertions(+), 3 deletions(-)
+
+diff --git a/libgda-ui/demos/ddl_queries.c b/libgda-ui/demos/ddl_queries.c
+index a47630f..4b29377 100644
+--- a/libgda-ui/demos/ddl_queries.c
++++ b/libgda-ui/demos/ddl_queries.c
+@@ -475,9 +475,9 @@ show_sql (G_GNUC_UNUSED GtkButton *button, DemoData *data)
+ else
+ msg = g_strdup_printf ("<b>SQL:</b>\n%s", sql);
+
+- dlg = gtk_message_dialog_new_with_markup (GTK_WINDOW (data->top_window),
+- GTK_DIALOG_MODAL,
+- msg_type, GTK_BUTTONS_CLOSE, msg);
++ dlg = gtk_message_dialog_new (GTK_WINDOW (data->top_window),
++ GTK_DIALOG_MODAL, msg_type, GTK_BUTTONS_CLOSE, NULL);
++ gtk_message_dialog_set_markup (GTK_MESSAGE_DIALOG (dlg), msg);
+ g_free (sql);
+ g_free (msg);
+
+--
+1.9.0
+
diff --git a/gnome-extra/libgda/files/libgda-5.2.4-jre18.patch b/gnome-extra/libgda/files/libgda-5.2.4-jre18.patch
new file mode 100644
index 000000000000..f66fa8f95846
--- /dev/null
+++ b/gnome-extra/libgda/files/libgda-5.2.4-jre18.patch
@@ -0,0 +1,14 @@
+--- libgda-5.2.2/configure.orig 2014-05-17 14:58:33.206028742 +0200
++++ libgda-5.2.2/configure 2014-05-17 14:58:45.937790443 +0200
+@@ -23200,6 +23259,11 @@
+ JTYPE="Sun JRE 1.7"
+ JFLAGS="-Xlint:unchecked -Xlint:deprecation"
+ ;;
++ JRE1.8.*)
++ try_java=true
++ JTYPE="Sun JRE 1.8"
++ JFLAGS="-Xlint:unchecked -Xlint:deprecation"
++ ;;
+ JREgcj-4*)
+ try_java=true
+ JTYPE="GCJ"
diff --git a/gnome-extra/libgda/libgda-5.2.4.ebuild b/gnome-extra/libgda/libgda-5.2.4.ebuild
new file mode 100644
index 000000000000..b8d5407cc5be
--- /dev/null
+++ b/gnome-extra/libgda/libgda-5.2.4.ebuild
@@ -0,0 +1,168 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/gnome-extra/libgda/libgda-5.2.4.ebuild,v 1.1 2015/06/20 09:59:11 pacho Exp $
+
+EAPI="5"
+GNOME2_LA_PUNT="yes"
+GCONF_DEBUG="yes"
+PYTHON_COMPAT=( python2_7 )
+VALA_MIN_API_VERSION="0.26"
+VALA_MAX_API_VERSION="0.26" # configure explicitly checks for that version
+VALA_USE_DEPEND="vapigen"
+
+inherit autotools db-use eutils flag-o-matic gnome2 java-pkg-opt-2 python-single-r1 vala
+
+DESCRIPTION="GNOME database access library"
+HOMEPAGE="http://www.gnome-db.org/"
+LICENSE="GPL-2+ LGPL-2+"
+
+IUSE="berkdb canvas firebird gnome-keyring gtk graphviz http +introspection json ldap mdb mysql oci8 postgres reports sourceview ssl vala"
+REQUIRED_USE="
+ reports? ( ${PYTHON_REQUIRED_USE} )
+ canvas? ( gtk )
+ graphviz? ( gtk )
+ sourceview? ( gtk )
+"
+# firebird license is not GPL compatible
+
+SLOT="5/4" # subslot = libgda-5.0 soname version
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+
+RDEPEND="
+ app-text/iso-codes
+ >=dev-libs/glib-2.32:2
+ >=dev-libs/libxml2-2
+ dev-libs/libxslt
+ sys-libs/readline:=
+ sys-libs/ncurses:=
+ berkdb? ( sys-libs/db:* )
+ firebird? ( dev-db/firebird )
+ gnome-keyring? ( app-crypt/libsecret )
+ gtk? (
+ >=x11-libs/gtk+-3.0.0:3
+ canvas? ( x11-libs/goocanvas:2.0= )
+ sourceview? ( x11-libs/gtksourceview:3.0 )
+ graphviz? ( media-gfx/graphviz )
+ )
+ http? ( >=net-libs/libsoup-2.24:2.4 )
+ introspection? ( >=dev-libs/gobject-introspection-1.30:= )
+ json? ( dev-libs/json-glib )
+ ldap? ( net-nds/openldap:= )
+ mdb? ( >app-office/mdbtools-0.5:= )
+ mysql? ( virtual/mysql:= )
+ postgres? ( dev-db/postgresql:= )
+ reports? (
+ ${PYTHON_DEPS}
+ dev-java/fop
+ dev-python/reportlab )
+ ssl? ( dev-libs/openssl:= )
+ >=dev-db/sqlite-3.6.22:3=
+ vala? ( dev-libs/libgee:0.8 )
+"
+
+# java dep shouldn't rely on slots, bug #450004
+DEPEND="${RDEPEND}
+ >=app-text/gnome-doc-utils-0.9
+ app-text/yelp-tools
+ dev-util/gtk-doc-am
+ >=dev-util/intltool-0.40.6
+ virtual/pkgconfig
+ java? ( >=virtual/jdk-1.6 )
+ vala? ( $(vala_depend) )
+"
+
+# FIXME: lots of tests failing. Check if they still fail in 5.1.2
+# firebird support bindist-restricted because it is not GPL compatible
+RESTRICT="
+ test
+ firebird? ( bindist )
+"
+
+pkg_setup() {
+ java-pkg-opt-2_pkg_setup
+ use reports && python-single-r1_pkg_setup
+}
+
+src_prepare() {
+ # Fix compilation with -Werror=format-security (from 'master')
+ epatch "${FILESDIR}"/${PN}-5.2.4-format-security.patch
+
+ # Support JRE 1.8 (from Fedora)
+ epatch "${FILESDIR}"/${PN}-5.2.4-jre18.patch
+
+ use berkdb && append-cppflags "-I$(db_includedir)"
+
+ use reports ||
+ sed -e '/SUBDIRS =/ s/trml2html//' \
+ -e '/SUBDIRS =/ s/trml2pdf//' \
+ -i libgda-report/RML/Makefile.{am,in} || die
+
+ # Prevent file collisions with libgda:4
+ epatch "${FILESDIR}/${PN}-4.99.1-gda-browser-doc-collision.patch"
+ epatch "${FILESDIR}/${PN}-4.99.1-control-center-icon-collision.patch"
+ # Move files with mv (since epatch can't handle rename diffs) and
+ # update pre-generated gtk-doc files (for non-git versions of libgda)
+ local f
+ for f in tools/browser/doc/gda-browser* ; do
+ mv ${f} ${f/gda-browser/gda-browser-5.0} || die "mv ${f} failed"
+ done
+ for f in tools/browser/doc/html/gda-browser.devhelp* ; do
+ sed -e 's:name="gda-browser":name="gda-browser-5.0":' \
+ -i ${f} || die "sed ${f} failed"
+ mv ${f} ${f/gda-browser/gda-browser-5.0} || die "mv ${f} failed"
+ done
+ for f in control-center/data/*_gda-control-center.png ; do
+ mv ${f} ${f/_gda-control-center.png/_gda-control-center-5.0.png} ||
+ die "mv ${f} failed"
+ done
+
+ eautoreconf
+ gnome2_src_prepare
+ java-pkg-opt-2_src_prepare
+ use vala && vala_src_prepare
+}
+
+src_configure() {
+ gnome2_src_configure \
+ --with-help \
+ --disable-default-binary \
+ --disable-static \
+ --enable-system-sqlite \
+ $(use_with berkdb bdb /usr) \
+ $(use_with canvas goocanvas) \
+ $(use_with firebird firebird /usr) \
+ $(use_with gnome-keyring libsecret) \
+ $(use_with graphviz) \
+ $(use_with gtk ui) \
+ $(use_with http libsoup) \
+ $(use_enable introspection) \
+ "$(use_with java java $JAVA_HOME)" \
+ $(use_enable json) \
+ $(use_with ldap) \
+ $(use_with mdb mdb /usr) \
+ $(use_with mysql mysql /usr) \
+ $(use_with oci8 oracle) \
+ $(use_with postgres postgres /usr) \
+ $(use_enable ssl crypto) \
+ $(use_with sourceview gtksourceview) \
+ $(use_enable vala) \
+ $(use_enable vala vala-extensions) \
+ $(use_enable vala gda-gi) \
+ $(use_enable vala gdaui-gi) \
+ $(use_enable vala gdaui-vala)
+}
+
+pkg_preinst() {
+ gnome2_pkg_preinst
+ java-pkg-opt-2_pkg_preinst
+}
+
+src_install() {
+ gnome2_src_install
+ if use reports; then
+ for t in trml2{html,pdf}; do
+ python_scriptinto /usr/share/libgda-5.0/gda_${t}
+ python_doscript libgda-report/RML/${t}/${t}.py
+ done
+ fi
+}