summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLeonardo Boshell <leonardop@gentoo.org>2006-01-31 05:22:16 +0000
committerLeonardo Boshell <leonardop@gentoo.org>2006-01-31 05:22:16 +0000
commit3cd2bec8cdab96763514039d75d6ce1d1abfba16 (patch)
treeacccef747a8189f5515ac436f69bf09e41c778a7 /gnome-extra/libgda/libgda-1.2.3.ebuild
parentWork around gnome eclass writing files to /var/tmp/portage/* (diff)
downloadgentoo-2-3cd2bec8cdab96763514039d75d6ce1d1abfba16.tar.gz
gentoo-2-3cd2bec8cdab96763514039d75d6ce1d1abfba16.tar.bz2
gentoo-2-3cd2bec8cdab96763514039d75d6ce1d1abfba16.zip
New version: 1.2.3
(Portage version: 2.1_pre4-r1)
Diffstat (limited to 'gnome-extra/libgda/libgda-1.2.3.ebuild')
-rw-r--r--gnome-extra/libgda/libgda-1.2.3.ebuild73
1 files changed, 73 insertions, 0 deletions
diff --git a/gnome-extra/libgda/libgda-1.2.3.ebuild b/gnome-extra/libgda/libgda-1.2.3.ebuild
new file mode 100644
index 000000000000..a52e1ef4bc36
--- /dev/null
+++ b/gnome-extra/libgda/libgda-1.2.3.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/gnome-extra/libgda/libgda-1.2.3.ebuild,v 1.1 2006/01/31 05:22:16 leonardop Exp $
+
+inherit eutils gnome2
+
+DESCRIPTION="Gnome Database Access Library"
+HOMEPAGE="http://www.gnome-db.org/"
+LICENSE="GPL-2 LGPL-2"
+
+IUSE="berkdb doc firebird freetds ldap mdb mysql oci8 odbc postgres sqlite xbase"
+SLOT="1"
+KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
+
+RDEPEND=">=dev-libs/glib-2
+ >=dev-libs/libxml2-2
+ >=dev-libs/libxslt-1.0.9
+ sys-libs/readline
+ sys-libs/ncurses
+ dev-libs/popt
+ berkdb? ( sys-libs/db )
+ odbc? ( >=dev-db/unixODBC-2.0.6 )
+ mysql? ( >=dev-db/mysql-3.23.51 )
+ postgres? ( >=dev-db/postgresql-7.2.1 )
+ freetds? ( >=dev-db/freetds-0.62 )
+ x86? ( firebird? ( dev-db/firebird ) )
+ xbase? ( dev-db/xbase )
+ sqlite? ( >=dev-db/sqlite-3 )
+ mdb? ( >=app-office/mdbtools-0.5 )
+ ldap? ( >=net-nds/openldap-2.0.25 )"
+
+DEPEND="${RDEPEND}
+ >=dev-util/pkgconfig-0.9
+ >=dev-util/intltool-0.30
+ app-text/scrollkeeper
+ doc? ( >=dev-util/gtk-doc-1 )"
+
+DOCS="AUTHORS ChangeLog NEWS README"
+USE_DESTDIR="1"
+
+# problems with parallel builds
+MAKEOPTS="${MAKEOPTS} -j1"
+
+
+pkg_setup() {
+ G2CONF="$(use_with berkdb bdb /usr) \
+ $(use_with firebird firebird /usr) \
+ $(use_with freetds tds /usr) \
+ $(use_with ldap ldap /usr) \
+ $(use_with mdb mdb /usr) \
+ $(use_with mysql mysql /usr) \
+ $(use_with odbc odbc /usr) \
+ $(use_with postgres postgres /usr) \
+ $(use_with sqlite sqlite /usr) \
+ $(use_with xbase xbase /usr)"
+
+ use oci8 || G2CONF="${G2CONF} --without-oracle"
+
+ # not in portage
+ G2CONF="${G2CONF} --without-msql --without-sybase --without-ibmdb2"
+}
+
+src_unpack() {
+ unpack "${A}"
+ cd "${S}"
+
+ # Fix freetds API problems
+ epatch "${FILESDIR}"/${PN}-1.0.2-freetds_fix.patch
+ # Fix compilation of the mdb provider
+ epatch "${FILESDIR}"/${PN}-1.2.1-mdb_fix.patch
+
+ gnome2_omf_fix doc/Makefile.in
+}