summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2009-10-29 21:59:53 +0000
committerGilles Dartiguelongue <eva@gentoo.org>2009-10-29 21:59:53 +0000
commitf33775caeefb76646beca1faa525cc7423b4f533 (patch)
tree26eff28d67e48103468ed8ce078a4958ebd83513 /gnome-extra/gtkhtml
parentNew version for GNOME 2.28. Clean up old revision. (diff)
downloadgentoo-2-f33775caeefb76646beca1faa525cc7423b4f533.tar.gz
gentoo-2-f33775caeefb76646beca1faa525cc7423b4f533.tar.bz2
gentoo-2-f33775caeefb76646beca1faa525cc7423b4f533.zip
New version for GNOME 2.28.
(Portage version: 2.2_rc46/cvs/Linux x86_64)
Diffstat (limited to 'gnome-extra/gtkhtml')
-rw-r--r--gnome-extra/gtkhtml/ChangeLog8
-rw-r--r--gnome-extra/gtkhtml/files/gtkhtml-editor.xml28
-rw-r--r--gnome-extra/gtkhtml/gtkhtml-3.28.1.ebuild60
3 files changed, 95 insertions, 1 deletions
diff --git a/gnome-extra/gtkhtml/ChangeLog b/gnome-extra/gtkhtml/ChangeLog
index 190a726c6498..05028cbaf513 100644
--- a/gnome-extra/gtkhtml/ChangeLog
+++ b/gnome-extra/gtkhtml/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for gnome-extra/gtkhtml
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-extra/gtkhtml/ChangeLog,v 1.196 2009/10/24 16:50:57 nixnut Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnome-extra/gtkhtml/ChangeLog,v 1.197 2009/10/29 21:59:53 eva Exp $
+
+*gtkhtml-3.28.1 (29 Oct 2009)
+
+ 29 Oct 2009; Gilles Dartiguelongue <eva@gentoo.org>
+ +gtkhtml-3.28.1.ebuild, +files/gtkhtml-editor.xml:
+ New version for GNOME 2.28.
24 Oct 2009; nixnut <nixnut@gentoo.org> gtkhtml-3.26.3.ebuild:
ppc stable #281427
diff --git a/gnome-extra/gtkhtml/files/gtkhtml-editor.xml b/gnome-extra/gtkhtml/files/gtkhtml-editor.xml
new file mode 100644
index 000000000000..cd91de3679d6
--- /dev/null
+++ b/gnome-extra/gtkhtml/files/gtkhtml-editor.xml
@@ -0,0 +1,28 @@
+<glade-catalog name="gtkhtml-editor" library="glade-gtkhtml-editor" depends="gtk+">
+
+ <glade-widget-classes>
+ <glade-widget-class name="GtkhtmlColorCombo" generic-name="color-combo" title="Color Combo Box">
+ <properties>
+ <property id="color"/>
+ <property id="popup-shown"/>
+ </properties>
+ </glade-widget-class>
+ <glade-widget-class name="GtkhtmlColorSwatch" generic-name="color-swatch" title="Color Swatch">
+ <properties>
+ <property id="color"/>
+ </properties>
+ </glade-widget-class>
+ <glade-widget-class name="GtkhtmlComboBox" generic-name="combo-box" title="Radio Action Combo Box">
+ <properties>
+ <property id="action"/>
+ </properties>
+ </glade-widget-class>
+ </glade-widget-classes>
+
+ <glade-widget-group name="widgets" title="GtkHTML Editor">
+ <glade-widget-class-ref name="GtkhtmlColorCombo"/>
+ <glade-widget-class-ref name="GtkhtmlColorSwatch"/>
+ <glade-widget-class-ref name="GtkhtmlComboBox"/>
+ </glade-widget-group>
+
+</glade-catalog>
diff --git a/gnome-extra/gtkhtml/gtkhtml-3.28.1.ebuild b/gnome-extra/gtkhtml/gtkhtml-3.28.1.ebuild
new file mode 100644
index 000000000000..4947dbd9e809
--- /dev/null
+++ b/gnome-extra/gtkhtml/gtkhtml-3.28.1.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/gnome-extra/gtkhtml/gtkhtml-3.28.1.ebuild,v 1.1 2009/10/29 21:59:53 eva Exp $
+
+EAPI="2"
+GCONF_DEBUG="no"
+
+inherit autotools eutils gnome2
+
+DESCRIPTION="Lightweight HTML Rendering/Printing/Editing Engine"
+HOMEPAGE="http://www.gnome.org/"
+
+LICENSE="GPL-2 LGPL-2"
+SLOT="3.14"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="glade"
+
+# We keep bonobo until we can make sure no apps in tree uses
+# the old composer code.
+RDEPEND=">=x11-libs/gtk+-2.16
+ >=gnome-base/gail-1.1
+ >=x11-themes/gnome-icon-theme-2.22.0
+ >=gnome-base/orbit-2
+ app-text/enchant
+ gnome-base/gconf:2
+ >=app-text/iso-codes-0.49
+ >=net-libs/libsoup-2.26.0:2.4
+ glade? ( dev-util/glade:3 )"
+DEPEND="${RDEPEND}
+ sys-devel/gettext
+ >=dev-util/intltool-0.40.0
+ >=dev-util/pkgconfig-0.9"
+
+DOCS="AUTHORS BUGS ChangeLog NEWS README TODO"
+
+pkg_setup() {
+ ELTCONF="--reverse-deps"
+ G2CONF="${G2CONF}
+ --disable-static
+ $(use_with glade glade-catalog)"
+}
+
+src_prepare() {
+ gnome2_src_prepare
+
+ # Add missing file, upstream bug #597361
+ cp "${FILESDIR}/gtkhtml-editor.xml" \
+ "${S}/components/editor/gtkhtml-editor.xml" || die "cp failed"
+
+ # FIXME: Fix compilation flags crazyness
+ sed 's/CFLAGS="$CFLAGS $WARNING_FLAGS"//' \
+ -i configure.ac configure || die "sed 1 failed"
+
+ sed -i -e 's:-DGTK_DISABLE_DEPRECATED=1 -DGDK_DISABLE_DEPRECATED=1 -DG_DISABLE_DEPRECATED=1 -DGNOME_DISABLE_DEPRECATED=1::g' \
+ a11y/Makefile.am a11y/Makefile.in || die "sed 2 failed"
+
+ # ./../doltcompile: line 31: --silent : command not found
+ intltoolize --force --copy --automake || die "intltoolize failed"
+ eautoreconf
+}