summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2012-10-10 21:48:06 +0000
committerGilles Dartiguelongue <eva@gentoo.org>2012-10-10 21:48:06 +0000
commit1a21bd61a2810ef6a9d99cce5b7d105365b4dd7c (patch)
treee314849ddd44758ebc8a8a34fc1aa1461771e125 /gnome-extra/gtkhtml
parentrecent ebuild cleanup seems to have left out SRC_URI... fixed (diff)
downloadgentoo-2-1a21bd61a2810ef6a9d99cce5b7d105365b4dd7c.tar.gz
gentoo-2-1a21bd61a2810ef6a9d99cce5b7d105365b4dd7c.tar.bz2
gentoo-2-1a21bd61a2810ef6a9d99cce5b7d105365b4dd7c.zip
Fix build with recent glib, bug #436462.
(Portage version: 2.2.0_alpha134/cvs/Linux x86_64)
Diffstat (limited to 'gnome-extra/gtkhtml')
-rw-r--r--gnome-extra/gtkhtml/ChangeLog6
-rw-r--r--gnome-extra/gtkhtml/files/gtkhtml-3.32.2-g_thread_init.patch25
-rw-r--r--gnome-extra/gtkhtml/gtkhtml-3.32.2.ebuild26
3 files changed, 47 insertions, 10 deletions
diff --git a/gnome-extra/gtkhtml/ChangeLog b/gnome-extra/gtkhtml/ChangeLog
index 6a1253c22f25..74c54e5aaaa6 100644
--- a/gnome-extra/gtkhtml/ChangeLog
+++ b/gnome-extra/gtkhtml/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for gnome-extra/gtkhtml
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-extra/gtkhtml/ChangeLog,v 1.262 2012/10/07 02:02:09 blueness Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnome-extra/gtkhtml/ChangeLog,v 1.263 2012/10/10 21:48:06 eva Exp $
+
+ 10 Oct 2012; Gilles Dartiguelongue <eva@gentoo.org> gtkhtml-3.32.2.ebuild,
+ +files/gtkhtml-3.32.2-g_thread_init.patch:
+ Fix build with recent glib, bug #436462.
07 Oct 2012; Anthony G. Basile <blueness@gentoo.org> gtkhtml-4.4.3.ebuild:
stable ppc64, bug #427544
diff --git a/gnome-extra/gtkhtml/files/gtkhtml-3.32.2-g_thread_init.patch b/gnome-extra/gtkhtml/files/gtkhtml-3.32.2-g_thread_init.patch
new file mode 100644
index 000000000000..5109cbc8db0b
--- /dev/null
+++ b/gnome-extra/gtkhtml/files/gtkhtml-3.32.2-g_thread_init.patch
@@ -0,0 +1,25 @@
+From b9882960dab978b85cbd32fc9b31e588c8c817ff Mon Sep 17 00:00:00 2001
+From: Gilles Dartiguelongue <eva@gentoo.org>
+Date: Wed, 10 Oct 2012 23:37:48 +0200
+Subject: [PATCH] Drop deprecated g_thread_init
+
+---
+ components/editor/main.c | 2 --
+ 1 file changed, 2 deletions(-)
+
+diff --git a/components/editor/main.c b/components/editor/main.c
+index 0a0a37f..3c729a2 100644
+--- a/components/editor/main.c
++++ b/components/editor/main.c
+@@ -373,8 +373,6 @@ main (gint argc, gchar **argv)
+ bind_textdomain_codeset (GETTEXT_PACKAGE, "UTF-8");
+ textdomain (GETTEXT_PACKAGE);
+
+- g_thread_init (NULL);
+-
+ gtk_init (&argc, &argv);
+
+ editor = gtkhtml_editor_new ();
+--
+1.7.12
+
diff --git a/gnome-extra/gtkhtml/gtkhtml-3.32.2.ebuild b/gnome-extra/gtkhtml/gtkhtml-3.32.2.ebuild
index 0329a38dc71b..869e715936fc 100644
--- a/gnome-extra/gtkhtml/gtkhtml-3.32.2.ebuild
+++ b/gnome-extra/gtkhtml/gtkhtml-3.32.2.ebuild
@@ -1,11 +1,11 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-extra/gtkhtml/gtkhtml-3.32.2.ebuild,v 1.7 2012/05/05 06:25:21 jdhore Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnome-extra/gtkhtml/gtkhtml-3.32.2.ebuild,v 1.8 2012/10/10 21:48:06 eva Exp $
EAPI="3"
GCONF_DEBUG="no"
-inherit gnome2 eutils
+inherit eutils gnome2
DESCRIPTION="Lightweight HTML Rendering/Printing/Editing Engine"
HOMEPAGE="http://www.gnome.org/"
@@ -15,7 +15,9 @@ SLOT="3.14"
KEYWORDS="alpha amd64 arm ia64 ppc ppc64 sh sparc x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~ia64-linux ~x86-linux"
IUSE=""
-RDEPEND=">=x11-libs/gtk+-2.20:2
+RDEPEND="
+ >=dev-libs/glib-2.24:2
+ >=x11-libs/gtk+-2.20:2
>=x11-themes/gnome-icon-theme-2.22.0
>=gnome-base/orbit-2
>=app-text/enchant-1.1.7
@@ -36,6 +38,18 @@ pkg_setup() {
DOCS="AUTHORS BUGS ChangeLog NEWS README TODO"
}
+src_prepare() {
+ # Fix build with recent glib, bug #436462
+ epatch "${FILESDIR}/${P}-g_thread_init.patch"
+ gnome2_src_prepare
+}
+
+src_install() {
+ gnome2_src_install
+ # Remove .la files since old will be removed anyway while updating
+ find "${ED}" -name "*.la" -delete || die "remove of la files failed"
+}
+
pkg_preinst() {
gnome2_pkg_preinst
preserve_old_lib /usr/$(get_libdir)/libgtkhtml-editor.so.0
@@ -45,9 +59,3 @@ pkg_postinst() {
gnome2_pkg_postinst
preserve_old_lib_notify /usr/$(get_libdir)/libgtkhtml-editor.so.0
}
-
-src_install() {
- gnome2_src_install
- # Remove .la files since old will be removed anyway while updating
- find "${ED}" -name "*.la" -delete || die "remove of la files failed"
-}