summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTiziano Müller <dev-zero@gentoo.org>2011-02-24 09:30:11 +0000
committerTiziano Müller <dev-zero@gentoo.org>2011-02-24 09:30:11 +0000
commit60b60ca9522515ebe30db02f461f35ac7b12e08e (patch)
treebd63b723798df993cdd3cacdba84cfbba7c6c2e3 /gnome-extra/gpointing-device-settings
parentOne more bit for hanno. I_KNOW_WHAT_IM_DOING=1 will now enable you to install... (diff)
downloadgentoo-2-60b60ca9522515ebe30db02f461f35ac7b12e08e.tar.gz
gentoo-2-60b60ca9522515ebe30db02f461f35ac7b12e08e.tar.bz2
gentoo-2-60b60ca9522515ebe30db02f461f35ac7b12e08e.zip
Added patch to fix crash on VT switch (bug #345343, thanks to Alexandre Rostovtsev for the patch and Robert Swain for the analysis), removed our own desktop entry (bug #345959).
(Portage version: 2.1.9.39/cvs/Linux x86_64)
Diffstat (limited to 'gnome-extra/gpointing-device-settings')
-rw-r--r--gnome-extra/gpointing-device-settings/ChangeLog11
-rw-r--r--gnome-extra/gpointing-device-settings/files/gpointing-device-settings-1.5.1-gsd-crash.patch35
-rw-r--r--gnome-extra/gpointing-device-settings/gpointing-device-settings-1.5.1-r2.ebuild41
3 files changed, 86 insertions, 1 deletions
diff --git a/gnome-extra/gpointing-device-settings/ChangeLog b/gnome-extra/gpointing-device-settings/ChangeLog
index 91ac6fa46090..9e5f2573af85 100644
--- a/gnome-extra/gpointing-device-settings/ChangeLog
+++ b/gnome-extra/gpointing-device-settings/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for gnome-extra/gpointing-device-settings
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-extra/gpointing-device-settings/ChangeLog,v 1.9 2011/02/13 12:39:54 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnome-extra/gpointing-device-settings/ChangeLog,v 1.10 2011/02/24 09:30:11 dev-zero Exp $
+
+*gpointing-device-settings-1.5.1-r2 (24 Feb 2011)
+
+ 24 Feb 2011; Tiziano Müller <dev-zero@gentoo.org>
+ +gpointing-device-settings-1.5.1-r2.ebuild,
+ +files/gpointing-device-settings-1.5.1-gsd-crash.patch:
+ Added patch to fix crash on VT switch (bug #345343, thanks to Alexandre
+ Rostovtsev for the patch and Robert Swain for the analysis), removed our own
+ desktop entry (bug #345959).
13 Feb 2011; Pacho Ramos <pacho@gentoo.org>
gpointing-device-settings-1.5.1.ebuild:
diff --git a/gnome-extra/gpointing-device-settings/files/gpointing-device-settings-1.5.1-gsd-crash.patch b/gnome-extra/gpointing-device-settings/files/gpointing-device-settings-1.5.1-gsd-crash.patch
new file mode 100644
index 000000000000..f694556b74ec
--- /dev/null
+++ b/gnome-extra/gpointing-device-settings/files/gpointing-device-settings-1.5.1-gsd-crash.patch
@@ -0,0 +1,35 @@
+diff -ru gpointing-device-settings-1.5.1-orig/modules/gnome-settings-daemon-plugins/gsd-pointing-device-plugin.c gpointing-device-settings-1.5.1/modules/gnome-settings-daemon-plugins/gsd-pointing-device-plugin.c
+--- gpointing-device-settings-1.5.1-orig/modules/gnome-settings-daemon-plugins/gsd-pointing-device-plugin.c 2010-12-20 01:29:09.204274003 -0500
++++ gpointing-device-settings-1.5.1/modules/gnome-settings-daemon-plugins/gsd-pointing-device-plugin.c 2010-12-20 02:15:21.652274002 -0500
+@@ -96,19 +96,21 @@
+ XDevicePresenceNotifyEvent *notify_event = (XDevicePresenceNotifyEvent *)xev;
+
+ device_info = gpds_xinput_utils_get_device_info_from_id(notify_event->deviceid, NULL);
+- if (notify_event->devchange == DeviceEnabled) {
+- GsdPointingDeviceManager *manager;
++ if (device_info) {
++ if (notify_event->devchange == DeviceEnabled) {
++ GsdPointingDeviceManager *manager;
+
+- if (has_manager(plugin, device_info->name))
+- return GDK_FILTER_CONTINUE;
++ if (has_manager(plugin, device_info->name))
++ return GDK_FILTER_CONTINUE;
+
+- manager = gsd_pointing_device_manager_new(gdk_x11_get_xatom_name(device_info->type),
+- device_info->name);
+- if (manager) {
+- gsd_pointing_device_manager_start(manager, NULL);
+- plugin->managers = g_list_prepend(plugin->managers, manager);
++ manager = gsd_pointing_device_manager_new(gdk_x11_get_xatom_name(device_info->type),
++ device_info->name);
++ if (manager) {
++ gsd_pointing_device_manager_start(manager, NULL);
++ plugin->managers = g_list_prepend(plugin->managers, manager);
++ }
++ } else if (notify_event->devchange == DeviceRemoved) {
+ }
+- } else if (notify_event->devchange == DeviceRemoved) {
+ }
+ }
+
diff --git a/gnome-extra/gpointing-device-settings/gpointing-device-settings-1.5.1-r2.ebuild b/gnome-extra/gpointing-device-settings/gpointing-device-settings-1.5.1-r2.ebuild
new file mode 100644
index 000000000000..3003b05ec5db
--- /dev/null
+++ b/gnome-extra/gpointing-device-settings/gpointing-device-settings-1.5.1-r2.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/gnome-extra/gpointing-device-settings/gpointing-device-settings-1.5.1-r2.ebuild,v 1.1 2011/02/24 09:30:11 dev-zero Exp $
+
+EAPI="2"
+GCONF_DEBUG="no"
+inherit eutils gnome2
+
+DESCRIPTION="A GTK+ based configuration utility for the synaptics driver"
+HOMEPAGE="http://live.gnome.org/GPointingDeviceSettings"
+SRC_URI="mirror://sourceforge.jp/gsynaptics/45812/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+# recent enough x11-base/xorg-server required
+RDEPEND=">=dev-libs/glib-2.10
+ >=x11-libs/gtk+-2.14.0
+ >=gnome-base/gconf-2.24
+ >=gnome-base/gnome-settings-daemon-2.28
+ >=x11-libs/libXi-1.2
+ >=x11-libs/libX11-1.2.0
+ !<=x11-base/xorg-server-1.6.0
+ !gnome-extra/gsynaptics"
+DEPEND="${RDEPEND}
+ >=dev-util/pkgconfig-0.19
+ >=dev-util/intltool-0.35.5"
+
+DOCS="MAINTAINERS NEWS TODO"
+
+src_prepare() {
+ epatch \
+ "${FILESDIR}/${P}-crash.patch" \
+ "${FILESDIR}/${P}-plugin.patch" \
+ "${FILESDIR}/${P}-reboot.patch" \
+ "${FILESDIR}/${P}-gtk22.patch" \
+ "${FILESDIR}/${P}-gsd-crash.patch"
+ gnome2_src_prepare
+}