summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexandre Rostovtsev <tetromino@gentoo.org>2012-01-04 23:30:10 +0000
committerAlexandre Rostovtsev <tetromino@gentoo.org>2012-01-04 23:30:10 +0000
commitcca03e94b931ea56b36e75f28d0b67da36ee7b58 (patch)
treeedce6c80e9ad42ae95661080eaa02777eb7801e7 /gnome-extra/gnome-games
parentVersion bump. (diff)
downloadgentoo-2-cca03e94b931ea56b36e75f28d0b67da36ee7b58.tar.gz
gentoo-2-cca03e94b931ea56b36e75f28d0b67da36ee7b58.tar.bz2
gentoo-2-cca03e94b931ea56b36e75f28d0b67da36ee7b58.zip
Fix py-compile idiom for automake-1.11.2 compatibility (bugs #396585, #397335). Move gnome2_src_prepare after eautoreconf. Revbump to fix sudoku set_bg_color traceback and pygobject-3.0.3 crashes (bug #397501), and to not install libgames-support-gi.a.
(Portage version: 2.2.0_alpha84/cvs/Linux x86_64)
Diffstat (limited to 'gnome-extra/gnome-games')
-rw-r--r--gnome-extra/gnome-games/ChangeLog16
-rw-r--r--gnome-extra/gnome-games/files/gnome-games-3.2.1-pygobject-3.0.3.patch33
-rw-r--r--gnome-extra/gnome-games/files/gnome-games-3.2.1-sudoku-borders.patch29
-rw-r--r--gnome-extra/gnome-games/gnome-games-2.28.2.ebuild7
-rw-r--r--gnome-extra/gnome-games/gnome-games-2.30.2-r1.ebuild7
-rw-r--r--gnome-extra/gnome-games/gnome-games-2.30.2-r2.ebuild7
-rw-r--r--gnome-extra/gnome-games/gnome-games-3.2.1-r1.ebuild194
-rw-r--r--gnome-extra/gnome-games/gnome-games-3.2.1.ebuild11
8 files changed, 284 insertions, 20 deletions
diff --git a/gnome-extra/gnome-games/ChangeLog b/gnome-extra/gnome-games/ChangeLog
index 88cfd08ec9b9..a4b1ba8932b6 100644
--- a/gnome-extra/gnome-games/ChangeLog
+++ b/gnome-extra/gnome-games/ChangeLog
@@ -1,6 +1,18 @@
# ChangeLog for gnome-extra/gnome-games
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-extra/gnome-games/ChangeLog,v 1.312 2011/11/07 04:03:58 tetromino Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/gnome-extra/gnome-games/ChangeLog,v 1.313 2012/01/04 23:30:09 tetromino Exp $
+
+*gnome-games-3.2.1-r1 (04 Jan 2012)
+
+ 04 Jan 2012; Alexandre Rostovtsev <tetromino@gentoo.org>
+ gnome-games-2.28.2.ebuild, gnome-games-2.30.2-r1.ebuild,
+ gnome-games-2.30.2-r2.ebuild, gnome-games-3.2.1.ebuild,
+ +gnome-games-3.2.1-r1.ebuild, +files/gnome-games-3.2.1-pygobject-3.0.3.patch,
+ +files/gnome-games-3.2.1-sudoku-borders.patch:
+ Fix py-compile idiom for automake-1.11.2 compatibility (bugs #396585,
+ #397335). Move gnome2_src_prepare after eautoreconf. Revbump to fix sudoku
+ set_bg_color traceback and pygobject-3.0.3 crashes (bug #397501), and to not
+ install libgames-support-gi.a.
*gnome-games-3.2.1 (07 Nov 2011)
diff --git a/gnome-extra/gnome-games/files/gnome-games-3.2.1-pygobject-3.0.3.patch b/gnome-extra/gnome-games/files/gnome-games-3.2.1-pygobject-3.0.3.patch
new file mode 100644
index 000000000000..020d9fac5c90
--- /dev/null
+++ b/gnome-extra/gnome-games/files/gnome-games-3.2.1-pygobject-3.0.3.patch
@@ -0,0 +1,33 @@
+From 8ab5a3a28281e6b1b649d9ef93628b3433ddd887 Mon Sep 17 00:00:00 2001
+From: "John (J5) Palmieri" <johnp@redhat.com>
+Date: Mon, 2 Jan 2012 13:39:05 -0500
+Subject: [PATCH] fix type check so gnome-sudoku works with pygobject >= 3.0.3
+
+gnome-sudoku was using if type(grid) == str to check if it needed
+to convert the game board to a list. Unicode fixes in the latest
+pygobject returns unicode strings for any string stored in a
+TreeStore. The fix was to correctly check for any string using
+isinstance(grid, basestring)
+
+Note this will not work in python3 so needs to be looked at when
+porting
+---
+ gnome-sudoku/src/lib/sudoku.py | 2 +-
+ 1 files changed, 1 insertions(+), 1 deletions(-)
+
+diff --git a/gnome-sudoku/src/lib/sudoku.py b/gnome-sudoku/src/lib/sudoku.py
+index a345593..7d28608 100644
+--- a/gnome-sudoku/src/lib/sudoku.py
++++ b/gnome-sudoku/src/lib/sudoku.py
+@@ -130,7 +130,7 @@ class SudokuGrid(object):
+ for n, col in enumerate([[(x, y) for y in range(self.group_size)] for x in range(self.group_size)]):
+ self.col_coords[n] = col
+ if grid:
+- if type(grid) == str:
++ if isinstance(grid, basestring):
+ g = re.split("\s+", grid)
+ side = int(math.sqrt(len(g)))
+ grid = []
+--
+1.7.8.2
+
diff --git a/gnome-extra/gnome-games/files/gnome-games-3.2.1-sudoku-borders.patch b/gnome-extra/gnome-games/files/gnome-games-3.2.1-sudoku-borders.patch
new file mode 100644
index 000000000000..84b3bba59d33
--- /dev/null
+++ b/gnome-extra/gnome-games/files/gnome-games-3.2.1-sudoku-borders.patch
@@ -0,0 +1,29 @@
+From a91b3962d121f4042e7029e30a5c1423dfb0c130 Mon Sep 17 00:00:00 2001
+From: Edward Sheldrake <ejsheldrake@gmail.com>
+Date: Sat, 8 Oct 2011 14:42:32 +0100
+Subject: [PATCH] sudoku: fix borders
+
+Fixes python traceback printed to terminal that ends with:
+TypeError: 'Color' object does not support indexing
+
+Fixes: https://bugzilla.gnome.org/show_bug.cgi?id=658519
+---
+ gnome-sudoku/src/lib/gsudoku.py | 2 +-
+ 1 files changed, 1 insertions(+), 1 deletions(-)
+
+diff --git a/gnome-sudoku/src/lib/gsudoku.py b/gnome-sudoku/src/lib/gsudoku.py
+index 79a0e21..b222f95 100644
+--- a/gnome-sudoku/src/lib/gsudoku.py
++++ b/gnome-sudoku/src/lib/gsudoku.py
+@@ -56,7 +56,7 @@ class SudokuNumberGrid (Gtk.AspectFrame):
+ def set_bg_color (self, color):
+ try:
+ if type(color) == str:
+- color = Gdk.color_parse(color)[1]
++ color = Gdk.color_parse(color)
+ color = Gdk.RGBA(color.red/65535.0, color.green/65535.0, color.blue/65535.0)
+ else:
+ color = Gdk.RGBA(*color)
+--
+1.7.8.1
+
diff --git a/gnome-extra/gnome-games/gnome-games-2.28.2.ebuild b/gnome-extra/gnome-games/gnome-games-2.28.2.ebuild
index 3deb4013a463..58441b4fd716 100644
--- a/gnome-extra/gnome-games/gnome-games-2.28.2.ebuild
+++ b/gnome-extra/gnome-games/gnome-games-2.28.2.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2011 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-extra/gnome-games/gnome-games-2.28.2.ebuild,v 1.10 2011/04/25 21:17:50 arfrever Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnome-extra/gnome-games/gnome-games-2.28.2.ebuild,v 1.11 2012/01/04 23:30:09 tetromino Exp $
EAPI="3"
GCONF_DEBUG="no"
@@ -122,8 +122,7 @@ src_prepare() {
gnome2_src_prepare
# disable pyc compiling
- mv py-compile py-compile.orig
- ln -s $(type -P true) py-compile
+ echo > py-compile
# Fix implicit declaration of yylex.
epatch "${FILESDIR}/${PN}-2.26.3-implicit-declaration.patch"
diff --git a/gnome-extra/gnome-games/gnome-games-2.30.2-r1.ebuild b/gnome-extra/gnome-games/gnome-games-2.30.2-r1.ebuild
index c108468c8c26..c6102acef359 100644
--- a/gnome-extra/gnome-games/gnome-games-2.30.2-r1.ebuild
+++ b/gnome-extra/gnome-games/gnome-games-2.30.2-r1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2011 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-extra/gnome-games/gnome-games-2.30.2-r1.ebuild,v 1.14 2011/04/25 21:17:50 arfrever Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnome-extra/gnome-games/gnome-games-2.30.2-r1.ebuild,v 1.15 2012/01/04 23:30:09 tetromino Exp $
EAPI="3"
GCONF_DEBUG="no"
@@ -120,8 +120,7 @@ src_prepare() {
gnome2_src_prepare
# disable pyc compiling
- mv py-compile py-compile.orig
- ln -s $(type -P true) py-compile
+ echo > py-compile
}
src_test() {
diff --git a/gnome-extra/gnome-games/gnome-games-2.30.2-r2.ebuild b/gnome-extra/gnome-games/gnome-games-2.30.2-r2.ebuild
index ef879e35faa0..2d988a44758d 100644
--- a/gnome-extra/gnome-games/gnome-games-2.30.2-r2.ebuild
+++ b/gnome-extra/gnome-games/gnome-games-2.30.2-r2.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2011 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-extra/gnome-games/gnome-games-2.30.2-r2.ebuild,v 1.1 2011/11/06 05:50:58 tetromino Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnome-extra/gnome-games/gnome-games-2.30.2-r2.ebuild,v 1.2 2012/01/04 23:30:09 tetromino Exp $
EAPI="3"
GCONF_DEBUG="no"
@@ -122,8 +122,7 @@ src_prepare() {
python_convert_shebangs -r 2 gnome-sudoku/src
# disable pyc compiling
- mv py-compile py-compile.orig
- ln -s $(type -P true) py-compile
+ echo > py-compile
}
src_test() {
diff --git a/gnome-extra/gnome-games/gnome-games-3.2.1-r1.ebuild b/gnome-extra/gnome-games/gnome-games-3.2.1-r1.ebuild
new file mode 100644
index 000000000000..ed849d412d08
--- /dev/null
+++ b/gnome-extra/gnome-games/gnome-games-3.2.1-r1.ebuild
@@ -0,0 +1,194 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/gnome-extra/gnome-games/gnome-games-3.2.1-r1.ebuild,v 1.1 2012/01/04 23:30:09 tetromino Exp $
+
+EAPI="3"
+GNOME_TARBALL_SUFFIX="xz"
+GCONF_DEBUG="no"
+GNOME2_LA_PUNT="yes"
+WANT_AUTOMAKE="1.11"
+PYTHON_DEPEND="2:2.4"
+PYTHON_USE_WITH="xml"
+
+# make sure games is inherited first so that the gnome2
+# functions will be called if they are not overridden
+inherit autotools games eutils gnome2 python virtualx
+
+DESCRIPTION="Collection of games for the GNOME desktop"
+HOMEPAGE="http://live.gnome.org/GnomeGames/"
+
+LICENSE="GPL-2 GPL-3 FDL-1.1"
+SLOT="0"
+# TODO: file KEYWORDREQ bug once it's determined that seed is usable
+KEYWORDS="~amd64 ~x86"
+IUSE="artworkextra +aisleriot +clutter +introspection glchess seed +sudoku test"
+
+COMMON_DEPEND="
+ >=dev-libs/dbus-glib-0.75
+ >=dev-libs/glib-2.25.7
+ >=dev-libs/libxml2-2.4.0
+ >=gnome-base/gconf-2.31.1
+ >=gnome-base/librsvg-2.32
+ >=x11-libs/cairo-1
+ >=x11-libs/gtk+-2.91.7:3[introspection?]
+
+ media-libs/libcanberra[gtk3]
+ x11-libs/libSM
+
+ artworkextra? ( >=gnome-extra/gnome-games-extra-data-3.0.0 )
+ clutter? (
+ >=dev-libs/gobject-introspection-0.6.3
+ >=x11-libs/gtk+-2.90:3[introspection]
+ >=gnome-base/gconf-2.31.1[introspection]
+ >=media-libs/clutter-gtk-0.91.6:1.0[introspection]
+ seed? ( >=dev-libs/seed-2.91.90 ) )
+ introspection? (
+ >=dev-libs/gobject-introspection-0.6.3
+ media-libs/clutter:1.0[introspection] )
+ glchess? (
+ dev-db/sqlite:3
+ >=gnome-base/librsvg-2.32
+ virtual/opengl
+ x11-libs/libX11 )"
+RDEPEND="${COMMON_DEPEND}
+ sudoku? (
+ || ( dev-python/pygobject:3 >=dev-python/pygobject-2.28.3:2[introspection] )
+ x11-libs/gdk-pixbuf:2[introspection]
+ x11-libs/pango[introspection]
+ >=x11-libs/gtk+-3.0.0:3[introspection] )
+
+ !<gnome-extra/gnome-games-extra-data-3.0.0"
+DEPEND="${COMMON_DEPEND}
+ glchess? ( >=dev-lang/vala-0.13.0:0.14 )
+ >=dev-util/pkgconfig-0.15
+ >=dev-util/intltool-0.40.4
+ >=sys-devel/gettext-0.10.40
+ >=gnome-base/gnome-common-2.12.0
+ >=app-text/scrollkeeper-0.3.8
+ >=app-text/gnome-doc-utils-0.10
+ test? ( >=dev-libs/check-0.9.4 )"
+
+# For compatibility with older versions of the gnome-games package
+PDEPEND="aisleriot? ( games-board/aisleriot )"
+
+# Others are installed below; multiples in this package.
+DOCS="AUTHORS HACKING MAINTAINERS TODO"
+
+_omitgame() {
+ G2CONF="${G2CONF},${1}"
+}
+
+pkg_setup() {
+ # create the games user / group
+ games_pkg_setup
+
+ python_set_active_version 2
+ python_pkg_setup
+
+ G2CONF="${G2CONF}
+ --disable-schemas-compile
+ --disable-static
+ --enable-sound
+ $(use_enable introspection)"
+
+ # Should be after $(use_enable introspection), but before --enable-omitgames
+ use clutter && G2CONF="${G2CONF} --enable-introspection"
+
+ use glchess && G2CONF="${G2CONF} VALAC=$(type -p valac-0.14)"
+
+ # Staging games are needed for swell-foop and lightsoff
+ G2CONF="${G2CONF}
+ --enable-staging
+ --with-scores-group=${GAMES_GROUP}
+ --with-platform=gnome
+ --with-smclient
+ --with-gtk=3.0
+ --enable-omitgames=none" # This line should be last for _omitgame
+
+ # FIXME: Use REQUIRED_USE once games.eclass is ported to EAPI 4
+ if ! use clutter; then
+ ewarn "USE='-clutter' => quadrapassel, swell-foop, lightsoff, gnibbles won't be installed"
+ _omitgame quadrapassel
+ _omitgame gnibbles
+ _omitgame swell-foop
+ _omitgame lightsoff
+ use seed && ewarn "USE='seed' has no effect with USE='-clutter'"
+ elif ! use seed; then
+ ewarn "USE='-seed' => swell-foop, lightsoff won't be installed"
+ _omitgame swell-foop
+ _omitgame lightsoff
+ fi
+
+ if ! use glchess; then
+ _omitgame glchess
+ fi
+
+ if ! use sudoku; then
+ _omitgame gnome-sudoku
+ fi
+}
+
+src_prepare() {
+ use sudoku && python_convert_shebangs -r 2 gnome-sudoku/src
+
+ # TODO: File upstream bug for this
+ epatch "${FILESDIR}/${PN}-2.91.90-fix-conditional-ac-prog-cxx.patch"
+
+ # Without this, --enable-staging enables all those games unconditionally
+ epatch "${FILESDIR}/${PN}-fix-staging-games.patch"
+
+ # gnome-sudoku patch, will be in next release
+ epatch "${FILESDIR}/${P}-sudoku-borders.patch"
+
+ # patch from upstream git master fixing sudoku with pygobject-3.0.3, #397501
+ epatch "${FILESDIR}/${P}-pygobject-3.0.3.patch"
+
+ eautoreconf
+
+ # disable pyc compiling
+ echo > py-compile
+
+ gnome2_src_prepare
+}
+
+src_test() {
+ Xemake check || die "tests failed"
+}
+
+src_install() {
+ gnome2_src_install
+
+ # Documentation install for each of the games
+ for game in \
+ $(find . -maxdepth 1 -type d ! -name po ! -name libgames-support); do
+ docinto ${game}
+ for doc in AUTHORS ChangeLog NEWS README TODO; do
+ [ -s ${game}/${doc} ] && dodoc ${game}/${doc}
+ done
+ done
+}
+
+pkg_preinst() {
+ gnome2_pkg_preinst
+ # Avoid overwriting previous .scores files
+ local basefile
+ for scorefile in "${ED}"/var/lib/games/*.scores; do
+ basefile=$(basename $scorefile)
+ if [ -s "${EROOT}/var/lib/games/${basefile}" ]; then
+ cp "${EROOT}/var/lib/games/${basefile}" \
+ "${ED}/var/lib/games/${basefile}"
+ fi
+ done
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+ gnome2_pkg_postinst
+ python_need_rebuild
+ use sudoku && python_mod_optimize gnome_sudoku
+}
+
+pkg_postrm() {
+ gnome2_pkg_postrm
+ python_mod_cleanup gnome_sudoku
+}
diff --git a/gnome-extra/gnome-games/gnome-games-3.2.1.ebuild b/gnome-extra/gnome-games/gnome-games-3.2.1.ebuild
index ddc4fbfc4ad7..bc2cefaaebe6 100644
--- a/gnome-extra/gnome-games/gnome-games-3.2.1.ebuild
+++ b/gnome-extra/gnome-games/gnome-games-3.2.1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2011 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-extra/gnome-games/gnome-games-3.2.1.ebuild,v 1.1 2011/11/07 04:03:58 tetromino Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnome-extra/gnome-games/gnome-games-3.2.1.ebuild,v 1.2 2012/01/04 23:30:09 tetromino Exp $
EAPI="3"
GNOME_TARBALL_SUFFIX="xz"
@@ -128,8 +128,6 @@ pkg_setup() {
}
src_prepare() {
- gnome2_src_prepare
-
use sudoku && python_convert_shebangs -r 2 gnome-sudoku/src
# TODO: File upstream bug for this
@@ -141,8 +139,9 @@ src_prepare() {
eautoreconf
# disable pyc compiling
- mv py-compile py-compile.orig
- ln -s $(type -P true) py-compile
+ echo > py-compile
+
+ gnome2_src_prepare
}
src_test() {