summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNirbheek Chauhan <nirbheek@gentoo.org>2011-09-02 08:29:47 +0000
committerNirbheek Chauhan <nirbheek@gentoo.org>2011-09-02 08:29:47 +0000
commit45087c1887437e78f647df4cf050ab2e7883740f (patch)
tree79f64a08d0d9d99b317553c4c2ae1f378f88c9ae /gnome-extra/evolution-exchange
parentRemove unused myconf variable. (diff)
downloadgentoo-2-45087c1887437e78f647df4cf050ab2e7883740f.tar.gz
gentoo-2-45087c1887437e78f647df4cf050ab2e7883740f.tar.bz2
gentoo-2-45087c1887437e78f647df4cf050ab2e7883740f.zip
Bump to 3.0.3, from gnome overlay for GNOME 3
(Portage version: 2.2.0_alpha51/cvs/Linux x86_64)
Diffstat (limited to 'gnome-extra/evolution-exchange')
-rw-r--r--gnome-extra/evolution-exchange/ChangeLog8
-rw-r--r--gnome-extra/evolution-exchange/evolution-exchange-3.0.3.ebuild53
2 files changed, 60 insertions, 1 deletions
diff --git a/gnome-extra/evolution-exchange/ChangeLog b/gnome-extra/evolution-exchange/ChangeLog
index c119c78e06da..5da1bdb5145e 100644
--- a/gnome-extra/evolution-exchange/ChangeLog
+++ b/gnome-extra/evolution-exchange/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for gnome-extra/evolution-exchange
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-extra/evolution-exchange/ChangeLog,v 1.137 2011/06/19 21:38:54 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnome-extra/evolution-exchange/ChangeLog,v 1.138 2011/09/02 08:29:47 nirbheek Exp $
+
+*evolution-exchange-3.0.3 (02 Sep 2011)
+
+ 02 Sep 2011; Nirbheek Chauhan <nirbheek@gentoo.org>
+ +evolution-exchange-3.0.3.ebuild:
+ Bump to 3.0.3, from gnome overlay for GNOME 3
*evolution-exchange-2.32.3 (19 Jun 2011)
diff --git a/gnome-extra/evolution-exchange/evolution-exchange-3.0.3.ebuild b/gnome-extra/evolution-exchange/evolution-exchange-3.0.3.ebuild
new file mode 100644
index 000000000000..004ba87c5771
--- /dev/null
+++ b/gnome-extra/evolution-exchange/evolution-exchange-3.0.3.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/gnome-extra/evolution-exchange/evolution-exchange-3.0.3.ebuild,v 1.1 2011/09/02 08:29:47 nirbheek Exp $
+
+EAPI="4"
+GCONF_DEBUG="yes"
+GNOME2_LA_PUNT="yes"
+
+inherit gnome2
+
+DESCRIPTION="Evolution module for connecting to Microsoft Exchange"
+HOMEPAGE="http://projects.gnome.org/evolution/"
+LICENSE="GPL-2"
+
+SLOT="2.0"
+IUSE="debug doc static"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+
+RDEPEND="
+ >=mail-client/evolution-${PV}:2.0
+ >=gnome-extra/evolution-data-server-${PV}[ldap,kerberos]
+ >=dev-libs/glib-2.28:2
+ >=x11-libs/gtk+-3.0:3
+ >=gnome-base/gconf-2:2
+ dev-libs/libxml2:2
+ net-libs/libsoup:2.4
+ >=net-nds/openldap-2.1.30-r2
+ virtual/krb5"
+
+DEPEND="${RDEPEND}
+ >=dev-util/intltool-0.40
+ dev-util/pkgconfig
+ doc? ( >=dev-util/gtk-doc-1.9 )"
+
+pkg_setup() {
+ G2CONF="${G2CONF}
+ --with-krb5=/usr
+ --with-openldap
+ --disable-static
+ --disable-maintainer-mode
+ $(use_enable debug e2k-debug)
+ $(use_with static static-ldap)"
+ DOCS="AUTHORS ChangeLog NEWS README"
+}
+
+src_prepare() {
+ gnome2_src_prepare
+
+ # FIXME: Fix compilation flags crazyness
+ # Touch configure.ac if eautoreconf
+ sed 's/^\(AM_CPPFLAGS="\)$WARNING_FLAGS/\1/' \
+ -i configure || die "sed 1 failed"
+}