summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexandre Rostovtsev <tetromino@gentoo.org>2012-01-06 06:43:02 +0000
committerAlexandre Rostovtsev <tetromino@gentoo.org>2012-01-06 06:43:02 +0000
commitbb50e5a887758cb5a2f2e162461c4b67739d5f23 (patch)
treebdefeb210ff721bbdf70dae421e474a8fd4e28b8 /gnome-extra/evolution-data-server
parentVersion bump. (diff)
downloadgentoo-2-bb50e5a887758cb5a2f2e162461c4b67739d5f23.tar.gz
gentoo-2-bb50e5a887758cb5a2f2e162461c4b67739d5f23.tar.bz2
gentoo-2-bb50e5a887758cb5a2f2e162461c4b67739d5f23.zip
Fix another glib-2.31 linking problem (bug #395777 comment 5, thanks to Alphat-PC for reporting).
(Portage version: 2.2.0_alpha84/cvs/Linux x86_64)
Diffstat (limited to 'gnome-extra/evolution-data-server')
-rw-r--r--gnome-extra/evolution-data-server/ChangeLog10
-rw-r--r--gnome-extra/evolution-data-server/evolution-data-server-3.2.2-r1.ebuild5
-rw-r--r--gnome-extra/evolution-data-server/files/evolution-data-server-3.2.2-g_thread_init.patch162
3 files changed, 173 insertions, 4 deletions
diff --git a/gnome-extra/evolution-data-server/ChangeLog b/gnome-extra/evolution-data-server/ChangeLog
index 1aec21703450..77429d50ca3a 100644
--- a/gnome-extra/evolution-data-server/ChangeLog
+++ b/gnome-extra/evolution-data-server/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for gnome-extra/evolution-data-server
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-extra/evolution-data-server/ChangeLog,v 1.321 2011/12/31 04:53:23 tetromino Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/gnome-extra/evolution-data-server/ChangeLog,v 1.322 2012/01/06 06:43:02 tetromino Exp $
+
+ 06 Jan 2012; Alexandre Rostovtsev <tetromino@gentoo.org>
+ evolution-data-server-3.2.2-r1.ebuild,
+ +files/evolution-data-server-3.2.2-g_thread_init.patch:
+ Fix another glib-2.31 linking problem (bug #395777 comment 5, thanks to
+ Alphat-PC for reporting).
*evolution-data-server-3.2.2-r1 (31 Dec 2011)
diff --git a/gnome-extra/evolution-data-server/evolution-data-server-3.2.2-r1.ebuild b/gnome-extra/evolution-data-server/evolution-data-server-3.2.2-r1.ebuild
index ca887fa1d7a1..82301a8757fe 100644
--- a/gnome-extra/evolution-data-server/evolution-data-server-3.2.2-r1.ebuild
+++ b/gnome-extra/evolution-data-server/evolution-data-server-3.2.2-r1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2011 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-extra/evolution-data-server/evolution-data-server-3.2.2-r1.ebuild,v 1.1 2011/12/31 04:53:23 tetromino Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnome-extra/evolution-data-server/evolution-data-server-3.2.2-r1.ebuild,v 1.2 2012/01/06 06:43:02 tetromino Exp $
EAPI="4"
GCONF_DEBUG="no"
@@ -90,6 +90,7 @@ src_prepare() {
# fix linking with glib-2.31, bug #395777
epatch "${FILESDIR}/${PN}-3.2.2-gmodule-explicit.patch"
+ epatch "${FILESDIR}/${PN}-3.2.2-g_thread_init.patch"
eautoreconf
diff --git a/gnome-extra/evolution-data-server/files/evolution-data-server-3.2.2-g_thread_init.patch b/gnome-extra/evolution-data-server/files/evolution-data-server-3.2.2-g_thread_init.patch
new file mode 100644
index 000000000000..3c38715de93b
--- /dev/null
+++ b/gnome-extra/evolution-data-server/files/evolution-data-server-3.2.2-g_thread_init.patch
@@ -0,0 +1,162 @@
+From d65649c665c129221a4510831eacb38f7a43a644 Mon Sep 17 00:00:00 2001
+From: Milan Crha <mcrha@redhat.com>
+Date: Mon, 24 Oct 2011 09:42:17 +0200
+Subject: [PATCH] Call g_thread_init() conditionally
+
+---
+ .../libedata-book/e-book-backend-sqlitedb-test.c | 2 ++
+ calendar/backends/file/e-cal-backend-file.c | 2 ++
+ camel/camel-index-control.c | 2 ++
+ camel/camel-text-index.c | 2 ++
+ camel/providers/imapx/test-imapx.c | 2 ++
+ camel/tests/lib/camel-test.c | 2 ++
+ tests/libebook/client/client-test-utils.c | 2 ++
+ tests/libecal/client/client-test-utils.c | 2 ++
+ tests/libedataserverui/test-client-examine-auth.c | 2 ++
+ tests/libedataserverui/test-name-selector.c | 2 ++
+ 10 files changed, 20 insertions(+), 0 deletions(-)
+
+diff --git a/addressbook/libedata-book/e-book-backend-sqlitedb-test.c b/addressbook/libedata-book/e-book-backend-sqlitedb-test.c
+index df39af2..e887abb 100644
+--- a/addressbook/libedata-book/e-book-backend-sqlitedb-test.c
++++ b/addressbook/libedata-book/e-book-backend-sqlitedb-test.c
+@@ -197,7 +197,9 @@ main (gint argc,
+ gchar *argv[])
+ {
+ g_type_init ();
++ #if !GLIB_CHECK_VERSION(2,31,0)
+ g_thread_init (NULL);
++ #endif
+
+ if (argc != 2) {
+ g_print ("Please enter a path to store the cache \n");
+diff --git a/calendar/backends/file/e-cal-backend-file.c b/calendar/backends/file/e-cal-backend-file.c
+index ba1fcf0..b2bee69 100644
+--- a/calendar/backends/file/e-cal-backend-file.c
++++ b/calendar/backends/file/e-cal-backend-file.c
+@@ -3800,7 +3800,9 @@ main (gint argc,
+ FILE * fin = NULL;
+
+ g_type_init ();
++ #if !GLIB_CHECK_VERSION(2,31,0)
+ g_thread_init (NULL);
++ #endif
+
+ context = g_option_context_new ("- test utility for e-d-s file backend");
+ g_option_context_add_main_entries (context, entries, GETTEXT_PACKAGE);
+diff --git a/camel/camel-index-control.c b/camel/camel-index-control.c
+index 87ae760..89ed82e 100644
+--- a/camel/camel-index-control.c
++++ b/camel/camel-index-control.c
+@@ -127,7 +127,9 @@ gint main (gint argc, gchar **argv)
+ if (argc < 2)
+ do_usage (argv[0]);
+
++ #if !GLIB_CHECK_VERSION(2,31,0)
+ g_thread_init (NULL);
++ #endif
+ camel_init (NULL, 0);
+
+ if (!strcmp(argv[1], "compress"))
+diff --git a/camel/camel-text-index.c b/camel/camel-text-index.c
+index 563a332..f5b69fe 100644
+--- a/camel/camel-text-index.c
++++ b/camel/camel-text-index.c
+@@ -1862,7 +1862,9 @@ main (gint argc,
+
+ printf ("Camel text index tester!\n");
+
++ #if !GLIB_CHECK_VERSION(2,31,0)
+ g_thread_init (NULL);
++ #endif
+ camel_init (NULL, 0);
+
+ idx = (CamelIndex *)camel_text_index_new ("textindex", O_CREAT|O_RDWR|O_TRUNC);
+diff --git a/camel/providers/imapx/test-imapx.c b/camel/providers/imapx/test-imapx.c
+index fe71d1c..de9a455 100644
+--- a/camel/providers/imapx/test-imapx.c
++++ b/camel/providers/imapx/test-imapx.c
+@@ -36,7 +36,9 @@ main (gint argc,
+ }
+
+ uri = argv[1];
++ #if !GLIB_CHECK_VERSION(2,31,0)
+ g_thread_init (NULL);
++ #endif
+ system ("rm -rf /tmp/test-camel-imapx");
+ camel_init ("/tmp/test-camel-imapx", TRUE);
+ camel_provider_init ();
+diff --git a/camel/tests/lib/camel-test.c b/camel/tests/lib/camel-test.c
+index 16caf79..743c658 100644
+--- a/camel/tests/lib/camel-test.c
++++ b/camel/tests/lib/camel-test.c
+@@ -103,8 +103,10 @@ camel_test_init (gint argc,
+ setup = 1;
+
+ g_type_init ();
++ #if !GLIB_CHECK_VERSION(2,31,0)
+ /* yeah, we do need ot thread init, even though camel isn't compiled with enable threads */
+ g_thread_init (NULL);
++ #endif
+
+ path = g_strdup_printf ("/tmp/camel-test");
+ if (mkdir (path, 0700) == -1 && errno != EEXIST)
+diff --git a/tests/libebook/client/client-test-utils.c b/tests/libebook/client/client-test-utils.c
+index 710ba25..f778333 100644
+--- a/tests/libebook/client/client-test-utils.c
++++ b/tests/libebook/client/client-test-utils.c
+@@ -67,7 +67,9 @@ main_initialize (void)
+ return;
+
+ g_type_init ();
++ #if !GLIB_CHECK_VERSION(2,31,0)
+ g_thread_init (NULL);
++ #endif
+
+ initialized = TRUE;
+ }
+diff --git a/tests/libecal/client/client-test-utils.c b/tests/libecal/client/client-test-utils.c
+index c6f7062..a39c994 100644
+--- a/tests/libecal/client/client-test-utils.c
++++ b/tests/libecal/client/client-test-utils.c
+@@ -63,7 +63,9 @@ main_initialize (void)
+ return;
+
+ g_type_init ();
++ #if !GLIB_CHECK_VERSION(2,31,0)
+ g_thread_init (NULL);
++ #endif
+
+ initialized = TRUE;
+ }
+diff --git a/tests/libedataserverui/test-client-examine-auth.c b/tests/libedataserverui/test-client-examine-auth.c
+index a02fb04..e94e33b 100644
+--- a/tests/libedataserverui/test-client-examine-auth.c
++++ b/tests/libedataserverui/test-client-examine-auth.c
+@@ -413,7 +413,9 @@ main (gint argc,
+ gchar **argv)
+ {
+ g_type_init ();
++ #if !GLIB_CHECK_VERSION(2,31,0)
+ g_thread_init (NULL);
++ #endif
+ gtk_init (&argc, &argv);
+
+ e_passwords_init ();
+diff --git a/tests/libedataserverui/test-name-selector.c b/tests/libedataserverui/test-name-selector.c
+index 3173382..bab8e4c 100644
+--- a/tests/libedataserverui/test-name-selector.c
++++ b/tests/libedataserverui/test-name-selector.c
+@@ -81,7 +81,9 @@ main (gint argc,
+ gchar **argv)
+ {
+ gtk_init (&argc, &argv);
++ #if !GLIB_CHECK_VERSION(2,31,0)
+ g_thread_init (NULL);
++ #endif
+
+ camel_init (NULL, 0);
+
+--
+1.7.8.2
+