summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArun Raghavan <ford_prefect@gentoo.org>2008-09-14 19:28:17 +0000
committerArun Raghavan <ford_prefect@gentoo.org>2008-09-14 19:28:17 +0000
commit1119e09229904078f4767b76bb7283c88dd8dea5 (patch)
treecf6c4c3696c24ea1605658e40d76c7f1a160d33a /gnome-extra/deskbar-applet
parentmesa-progs has to be in PDEPEND to avoid a circular dependency through freegl... (diff)
downloadgentoo-2-1119e09229904078f4767b76bb7283c88dd8dea5.tar.gz
gentoo-2-1119e09229904078f4767b76bb7283c88dd8dea5.tar.bz2
gentoo-2-1119e09229904078f4767b76bb7283c88dd8dea5.zip
Change deps to use split gnome-python (gconf, gnome-vfs, libgnome) and gnome-python-desktop (gnome-applets, libwnck) bindings. Thanks to Nirbheek Chauhan (bheekling) for the initial work on this.
(Portage version: 2.2_rc8/cvs/Linux 2.6.26.2 i686)
Diffstat (limited to 'gnome-extra/deskbar-applet')
-rw-r--r--gnome-extra/deskbar-applet/ChangeLog10
-rw-r--r--gnome-extra/deskbar-applet/deskbar-applet-2.22.3.1-r1.ebuild79
2 files changed, 88 insertions, 1 deletions
diff --git a/gnome-extra/deskbar-applet/ChangeLog b/gnome-extra/deskbar-applet/ChangeLog
index 988b6a9c8eb4..772618bca0ae 100644
--- a/gnome-extra/deskbar-applet/ChangeLog
+++ b/gnome-extra/deskbar-applet/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for gnome-extra/deskbar-applet
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-extra/deskbar-applet/ChangeLog,v 1.97 2008/09/09 11:25:18 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnome-extra/deskbar-applet/ChangeLog,v 1.98 2008/09/14 19:28:17 ford_prefect Exp $
+
+*deskbar-applet-2.22.3.1-r1 (14 Sep 2008)
+
+ 14 Sep 2008; Arun Raghavan <ford_prefect@gentoo.org>
+ +deskbar-applet-2.22.3.1-r1.ebuild:
+ Change deps to use split gnome-python (gconf, gnome-vfs, libgnome) and
+ gnome-python-desktop (gnome-applets, libwnck) bindings. Thanks to Nirbheek
+ Chauhan (bheekling) for the initial work on this.
09 Sep 2008; Raúl Porcel <armin76@gentoo.org>
deskbar-applet-2.22.3.1.ebuild:
diff --git a/gnome-extra/deskbar-applet/deskbar-applet-2.22.3.1-r1.ebuild b/gnome-extra/deskbar-applet/deskbar-applet-2.22.3.1-r1.ebuild
new file mode 100644
index 000000000000..aed767b2d973
--- /dev/null
+++ b/gnome-extra/deskbar-applet/deskbar-applet-2.22.3.1-r1.ebuild
@@ -0,0 +1,79 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/gnome-extra/deskbar-applet/deskbar-applet-2.22.3.1-r1.ebuild,v 1.1 2008/09/14 19:28:17 ford_prefect Exp $
+
+inherit gnome2 eutils autotools python
+
+DESCRIPTION="An Omnipresent Versatile Search Interface"
+HOMEPAGE="http://raphael.slinckx.net/deskbar/"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="eds spell test"
+
+# TODO: check if gnome-doc-utils doesn't imply scrollkeeper
+
+RDEPEND=">=dev-lang/python-2.4
+ >=x11-libs/gtk+-2.10
+ >=dev-python/pygtk-2.10
+ >=dev-python/gconf-python-2.22.1
+ >=dev-python/gnome-vfs-python-2.22.1
+ >=dev-python/libgnome-python-2.22.1
+ >=gnome-base/gnome-desktop-2.10
+ >=dev-python/dbus-python-0.80.2
+ >=dev-python/gnome-applets-python-2.22.0
+ >=dev-python/libwnck-python-2.22.0
+ >=gnome-base/gconf-2
+ eds? ( >=gnome-extra/evolution-data-server-1.7.92 )
+ spell? ( >=gnome-extra/gnome-utils-2.16.2 )"
+DEPEND="${RDEPEND}
+ sys-devel/gettext
+ >=dev-util/intltool-0.35
+ >=sys-devel/autoconf-2.60
+ app-text/scrollkeeper
+ app-text/gnome-doc-utils
+ dev-util/pkgconfig
+ test? ( ~app-text/docbook-xml-dtd-4.2 )"
+
+DOCS="AUTHORS ChangeLog NEWS README TODO"
+
+pkg_setup() {
+ G2CONF="${G2CONF}
+ $(use_enable eds evolution)
+ --exec-prefix=/usr
+ --disable-scrollkeeper"
+}
+
+src_unpack() {
+ gnome2_src_unpack
+
+ # Fix installing libs into pythondir
+ epatch "${FILESDIR}"/${PN}-2.19.5-multilib.patch
+
+ # disable pyc compiling
+ mv py-compile py-compile.orig
+ ln -s $(type -P true) py-compile
+
+ AT_M4DIR="m4" eautoreconf
+}
+
+pkg_postinst() {
+ gnome2_pkg_postinst
+
+ python_version
+ python_mod_optimize /usr/$(get_libdir)/python${PYVER}/site-packages/deskbar
+ python_mod_optimize /usr/$(get_libdir)/deskbar-applet/modules-2.20-compatible
+
+ ebeep 5
+ ewarn "The dictionary plugin in deskbar-applet uses the dictionary from "
+ ewarn "gnome-extra/gnome-utils. If it is not present, the dictionary "
+ ewarn "plugin will fail silently."
+ epause 5
+}
+
+pkg_postrm() {
+ gnome2_pkg_postrm
+ python_mod_cleanup /usr/$(get_libdir)/python*/site-packages/deskbar
+ python_mod_cleanup /usr/$(get_libdir)/deskbar-applet/modules-2.20-compatible
+}