summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2009-10-29 21:51:30 +0000
committerGilles Dartiguelongue <eva@gentoo.org>2009-10-29 21:51:30 +0000
commitd2c74c0fff86d953409c576115a2a8c2ba984cd6 (patch)
treecefa3719f751c91b14f45e523fdee5dd4d2a4e9f /gnome-extra/at-spi
parentInitial ebuild for GNOME 2.28. (diff)
downloadgentoo-2-d2c74c0fff86d953409c576115a2a8c2ba984cd6.tar.gz
gentoo-2-d2c74c0fff86d953409c576115a2a8c2ba984cd6.tar.bz2
gentoo-2-d2c74c0fff86d953409c576115a2a8c2ba984cd6.zip
New version for GNOME 2.28.
(Portage version: 2.2_rc46/cvs/Linux x86_64)
Diffstat (limited to 'gnome-extra/at-spi')
-rw-r--r--gnome-extra/at-spi/ChangeLog7
-rw-r--r--gnome-extra/at-spi/at-spi-1.28.1.ebuild83
2 files changed, 89 insertions, 1 deletions
diff --git a/gnome-extra/at-spi/ChangeLog b/gnome-extra/at-spi/ChangeLog
index 8776509ba2f0..5ed6390a91b8 100644
--- a/gnome-extra/at-spi/ChangeLog
+++ b/gnome-extra/at-spi/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for gnome-extra/at-spi
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-extra/at-spi/ChangeLog,v 1.190 2009/10/24 17:04:39 nixnut Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnome-extra/at-spi/ChangeLog,v 1.191 2009/10/29 21:51:30 eva Exp $
+
+*at-spi-1.28.1 (29 Oct 2009)
+
+ 29 Oct 2009; Gilles Dartiguelongue <eva@gentoo.org> +at-spi-1.28.1.ebuild:
+ New version for GNOME 2.28.
24 Oct 2009; nixnut <nixnut@gentoo.org> ChangeLog:
ppc stable #281427
diff --git a/gnome-extra/at-spi/at-spi-1.28.1.ebuild b/gnome-extra/at-spi/at-spi-1.28.1.ebuild
new file mode 100644
index 000000000000..cf0740603bd2
--- /dev/null
+++ b/gnome-extra/at-spi/at-spi-1.28.1.ebuild
@@ -0,0 +1,83 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/gnome-extra/at-spi/at-spi-1.28.1.ebuild,v 1.1 2009/10/29 21:51:30 eva Exp $
+
+inherit autotools eutils gnome2 python virtualx
+
+DESCRIPTION="The Gnome Accessibility Toolkit"
+HOMEPAGE="http://developer.gnome.org/projects/gap/"
+
+LICENSE="LGPL-2"
+SLOT="1"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="doc"
+
+RDEPEND=">=dev-libs/atk-1.17
+ >=x11-libs/gtk+-2.10.0
+ >=gnome-base/gail-1.9.0
+ >=gnome-base/libbonobo-1.107
+ >=gnome-base/orbit-2
+ >=dev-libs/dbus-glib-0.76
+ >=gnome-base/gconf-2
+ dev-libs/popt
+
+ x11-libs/libICE
+ x11-libs/libSM
+ x11-libs/libX11
+ x11-libs/libXi
+ x11-libs/libXtst"
+
+DEPEND="${RDEPEND}
+ >=dev-util/pkgconfig-0.9
+ >=dev-util/intltool-0.40
+ gnome-base/gnome-common
+ dev-util/gtk-doc-am
+ doc? ( >=dev-util/gtk-doc-1 )
+
+ x11-libs/libXt
+ x11-proto/xextproto
+ x11-proto/inputproto
+ x11-proto/xproto"
+
+DOCS="AUTHORS ChangeLog NEWS README TODO"
+
+# needs a live properly configured environment. Not really suited to
+# an ebuild restricted environment
+RESTRICT="test"
+
+pkg_setup() {
+ G2CONF="${G2CONF}
+ --enable-sm
+ --disable-xevie"
+}
+
+src_unpack() {
+ gnome2_src_unpack
+
+ # disable pyc compiling
+ mv py-compile py-compile.orig
+ ln -s $(type -P true) py-compile
+
+ # should fix tests
+ epatch "${FILESDIR}"/${PN}-1.22.0-tests.patch
+
+ intltoolize --force --copy --automake || die "intltoolize failed"
+ eautoreconf
+}
+
+src_test() {
+ Xemake check || die "Testing phase failed"
+}
+
+pkg_postinst() {
+ gnome2_pkg_postinst
+
+ python_need_rebuild
+ python_mod_optimize $(python_get_sitedir)/pyatspi
+}
+
+pkg_postrm() {
+ gnome2_pkg_postrm
+
+ python_mod_cleanup /usr/$(get_libdir)/python*/site-packages/pyatspi
+}