summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMart Raudsepp <leio@gentoo.org>2007-07-08 23:19:09 +0000
committerMart Raudsepp <leio@gentoo.org>2007-07-08 23:19:09 +0000
commit5b3fe5c90aece77e0585bdd81d77c6cc8e6b689d (patch)
tree3b1b113a59aeed95ac08505d1cf57cc05a944435 /gnome-extra/at-spi
parentPass -j1 to install. (diff)
downloadgentoo-2-5b3fe5c90aece77e0585bdd81d77c6cc8e6b689d.tar.gz
gentoo-2-5b3fe5c90aece77e0585bdd81d77c6cc8e6b689d.tar.bz2
gentoo-2-5b3fe5c90aece77e0585bdd81d77c6cc8e6b689d.zip
Fix a couple of memory leaks, one of which can result in applications leaking hundreds of megabytes of memory in the matter of a day with lots of typing and assistive technology being enabled.
(Portage version: 2.1.3_rc6)
Diffstat (limited to 'gnome-extra/at-spi')
-rw-r--r--gnome-extra/at-spi/ChangeLog11
-rw-r--r--gnome-extra/at-spi/at-spi-1.18.1-r1.ebuild55
-rw-r--r--gnome-extra/at-spi/files/at-spi-1.18.0-ior-leak.patch19
-rw-r--r--gnome-extra/at-spi/files/at-spi-1.18.1-focus-tracker-leak.patch17
-rw-r--r--gnome-extra/at-spi/files/digest-at-spi-1.18.1-r13
5 files changed, 104 insertions, 1 deletions
diff --git a/gnome-extra/at-spi/ChangeLog b/gnome-extra/at-spi/ChangeLog
index d676cf8423f6..5f78e76fafd8 100644
--- a/gnome-extra/at-spi/ChangeLog
+++ b/gnome-extra/at-spi/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for gnome-extra/at-spi
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-extra/at-spi/ChangeLog,v 1.143 2007/07/05 16:51:21 uberlord Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnome-extra/at-spi/ChangeLog,v 1.144 2007/07/08 23:19:09 leio Exp $
+
+*at-spi-1.18.1-r1 (08 Jul 2007)
+
+ 08 Jul 2007; Mart Raudsepp <leio@gentoo.org>
+ +files/at-spi-1.18.0-ior-leak.patch,
+ +files/at-spi-1.18.1-focus-tracker-leak.patch, +at-spi-1.18.1-r1.ebuild:
+ Fix a couple of memory leaks, one of which can result in applications
+ leaking hundreds of megabytes of memory in the matter of a day with lots of
+ typing and assistive technology being enabled.
05 Jul 2007; Roy Marples <uberlord@gentoo.org> at-spi-1.18.1.ebuild:
Keyworded ~x86-fbsd.
diff --git a/gnome-extra/at-spi/at-spi-1.18.1-r1.ebuild b/gnome-extra/at-spi/at-spi-1.18.1-r1.ebuild
new file mode 100644
index 000000000000..9573ac0cc4ae
--- /dev/null
+++ b/gnome-extra/at-spi/at-spi-1.18.1-r1.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/gnome-extra/at-spi/at-spi-1.18.1-r1.ebuild,v 1.1 2007/07/08 23:19:09 leio Exp $
+
+WANT_AUTOMAKE="1.9"
+
+inherit virtualx autotools eutils gnome2
+
+DESCRIPTION="The Gnome Accessibility Toolkit"
+HOMEPAGE="http://developer.gnome.org/projects/gap/"
+
+LICENSE="LGPL-2"
+SLOT="1"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="doc"
+
+RDEPEND=">=dev-libs/atk-1.17
+ >=x11-libs/gtk+-2.10.0
+ >=gnome-base/gail-1.9.0
+ >=gnome-base/libbonobo-1.107
+ >=gnome-base/orbit-2
+ dev-libs/popt
+
+ x11-libs/libICE
+ x11-libs/libSM
+ x11-libs/libX11
+ x11-libs/libXi
+ x11-libs/libXtst"
+
+DEPEND="${RDEPEND}
+ >=dev-util/pkgconfig-0.9
+ >=dev-util/intltool-0.35
+ doc? ( >=dev-util/gtk-doc-1 )
+
+ x11-libs/libXt
+ x11-proto/xextproto
+ x11-proto/inputproto
+ x11-proto/xproto"
+
+DOCS="AUTHORS ChangeLog NEWS README TODO"
+
+src_unpack() {
+ gnome2_src_unpack
+
+ epatch "${FILESDIR}"/${PN}-1.7.12-tests.patch
+ epatch "${FILESDIR}/${PN}-1.18.0-ior-leak.patch"
+ epatch "${FILESDIR}/${P}-focus-tracker-leak.patch"
+
+ cp aclocal.m4 old_macros.m4
+ AT_M4DIR="." eautoreconf
+}
+
+src_test() {
+ Xmake check || die "Testing phase failed"
+}
diff --git a/gnome-extra/at-spi/files/at-spi-1.18.0-ior-leak.patch b/gnome-extra/at-spi/files/at-spi-1.18.0-ior-leak.patch
new file mode 100644
index 000000000000..6b62cff48c6e
--- /dev/null
+++ b/gnome-extra/at-spi/files/at-spi-1.18.0-ior-leak.patch
@@ -0,0 +1,19 @@
+Patch from http://cvs.fedora.redhat.com/viewcvs/rpms/at-spi/F-7/at-spi-1.18.0-ior-leak.patch?rev=1.1&view=auto
+to not have to duplicate efforts on just including the functional patch and leaving out the whitespace changes at
+upstream http://svn.gnome.org/viewcvs/at-spi/trunk/atk-bridge/bridge.c?r1=903&r2=902&pathrev=903
+
+--- at-spi-1.18.0/atk-bridge/bridge.c.ior-leak 2007-04-09 13:34:13.000000000 +0200
++++ at-spi-1.18.0/atk-bridge/bridge.c 2007-04-09 13:35:35.000000000 +0200
+@@ -420,9 +420,11 @@
+ /* XXX: This presumes that the registry has successfully restarted itself already...*/
+ ior = (char *) spi_atk_bridge_get_registry_ior ();
+
+- if (ior != NULL)
++ if (ior != NULL) {
+ registry = CORBA_ORB_string_to_object (bonobo_activation_orb_get (),
+ ior, &ev);
++ XFree (ior);
++ }
+ else {
+ g_warning ("IOR not set.");
+ registry = CORBA_OBJECT_NIL;
diff --git a/gnome-extra/at-spi/files/at-spi-1.18.1-focus-tracker-leak.patch b/gnome-extra/at-spi/files/at-spi-1.18.1-focus-tracker-leak.patch
new file mode 100644
index 000000000000..6e7392d1ca14
--- /dev/null
+++ b/gnome-extra/at-spi/files/at-spi-1.18.1-focus-tracker-leak.patch
@@ -0,0 +1,17 @@
+Patch from http://svn.gnome.org/viewcvs/at-spi/trunk/atk-bridge/bridge.c?r1=902&r2=901&pathrev=902
+to fix a memory leak in spi_atk_bridge_focus_tracker codepath
+
+--- trunk/atk-bridge/bridge.c 2007/04/09 08:34:50 901
++++ trunk/atk-bridge/bridge.c 2007/04/12 07:06:38 902
+@@ -714,7 +714,10 @@
+ registry_died = TRUE;
+
+ bonobo_object_unref (source);
+-
++
++ if (e.any_data._release)
++ CORBA_free (e.any_data._value);
++
+ CORBA_exception_free (&ev);
+ }
+
diff --git a/gnome-extra/at-spi/files/digest-at-spi-1.18.1-r1 b/gnome-extra/at-spi/files/digest-at-spi-1.18.1-r1
new file mode 100644
index 000000000000..86b90c17028b
--- /dev/null
+++ b/gnome-extra/at-spi/files/digest-at-spi-1.18.1-r1
@@ -0,0 +1,3 @@
+MD5 46c531204df5d39f7e83822372b0ce69 at-spi-1.18.1.tar.bz2 780306
+RMD160 c5e60314414124388d025dc85effb5d9adf5d2b9 at-spi-1.18.1.tar.bz2 780306
+SHA256 3b0be3207eb5cf4b1c1666b1dcd341ac914802b5404defb812e3b2aa9e78e7aa at-spi-1.18.1.tar.bz2 780306