summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2008-12-21 15:35:34 +0000
committerGilles Dartiguelongue <eva@gentoo.org>2008-12-21 15:35:34 +0000
commit59c0672965aeff936050580f267be5f5308b6369 (patch)
treefc63bc5f22cdd2b25c282f99da349acb2f90316b /gnome-extra/at-spi
parentFix bad sed, bug #250644. Clean up old revisions. (diff)
downloadgentoo-2-59c0672965aeff936050580f267be5f5308b6369.tar.gz
gentoo-2-59c0672965aeff936050580f267be5f5308b6369.tar.bz2
gentoo-2-59c0672965aeff936050580f267be5f5308b6369.zip
Bump to 1.24.1. Bug fix, allow apps to not load at-spi module on startup.
(Portage version: 2.2_rc18/cvs/Linux 2.6.24-gentoo-r8-mactel x86_64)
Diffstat (limited to 'gnome-extra/at-spi')
-rw-r--r--gnome-extra/at-spi/ChangeLog7
-rw-r--r--gnome-extra/at-spi/at-spi-1.24.1.ebuild71
2 files changed, 77 insertions, 1 deletions
diff --git a/gnome-extra/at-spi/ChangeLog b/gnome-extra/at-spi/ChangeLog
index f2e72d36ddc0..9627b8bb0147 100644
--- a/gnome-extra/at-spi/ChangeLog
+++ b/gnome-extra/at-spi/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for gnome-extra/at-spi
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-extra/at-spi/ChangeLog,v 1.173 2008/11/13 19:40:52 ranger Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnome-extra/at-spi/ChangeLog,v 1.174 2008/12/21 15:35:34 eva Exp $
+
+*at-spi-1.24.1 (21 Dec 2008)
+
+ 21 Dec 2008; Gilles Dartiguelongue <eva@gentoo.org> +at-spi-1.24.1.ebuild:
+ Bump to 1.24.1. Bug fix, allow apps to not load at-spi module on startup.
13 Nov 2008; Brent Baude <ranger@gentoo.org> at-spi-1.22.1.ebuild:
Marking at-spi-1.22.1 ppc64 stable for bug 236971
diff --git a/gnome-extra/at-spi/at-spi-1.24.1.ebuild b/gnome-extra/at-spi/at-spi-1.24.1.ebuild
new file mode 100644
index 000000000000..9460b45ce68b
--- /dev/null
+++ b/gnome-extra/at-spi/at-spi-1.24.1.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/gnome-extra/at-spi/at-spi-1.24.1.ebuild,v 1.1 2008/12/21 15:35:34 eva Exp $
+
+inherit autotools eutils gnome2 python virtualx
+
+DESCRIPTION="The Gnome Accessibility Toolkit"
+HOMEPAGE="http://developer.gnome.org/projects/gap/"
+
+LICENSE="LGPL-2"
+SLOT="1"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="doc"
+
+RDEPEND=">=dev-libs/atk-1.17
+ >=x11-libs/gtk+-2.10.0
+ >=gnome-base/gail-1.9.0
+ >=gnome-base/libbonobo-1.107
+ >=gnome-base/orbit-2
+ >=gnome-base/gconf-2
+ dev-libs/popt
+
+ x11-libs/libICE
+ x11-libs/libSM
+ x11-libs/libX11
+ x11-libs/libXi
+ x11-libs/libXtst"
+
+DEPEND="${RDEPEND}
+ >=dev-util/pkgconfig-0.9
+ >=dev-util/intltool-0.40
+ doc? ( >=dev-util/gtk-doc-1 )
+
+ x11-libs/libXt
+ x11-proto/xextproto
+ x11-proto/inputproto
+ x11-proto/xproto"
+
+DOCS="AUTHORS ChangeLog NEWS README TODO"
+
+# needs a live properly configured environment. Not really suited to
+# an ebuild restricted environment
+RESTRICT="test"
+
+src_unpack() {
+ gnome2_src_unpack
+
+ # disable pyc compiling
+ mv py-compile py-compile.orig
+ ln -s $(type -P true) py-compile
+
+ # should fix tests
+ epatch "${FILESDIR}"/${PN}-1.22.0-tests.patch
+
+ eautomake
+}
+
+src_test() {
+ Xemake check || die "Testing phase failed"
+}
+
+pkg_postinst() {
+ gnome2_pkg_postinst
+ python_version
+ python_mod_optimize /usr/$(get_libdir)/python${PYVER}/site-packages/pyatspi
+}
+
+pkg_postrm() {
+ gnome2_pkg_postrm
+ python_mod_cleanup /usr/$(get_libdir)/python*/site-packages/pyatspi
+}