summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2013-07-08 06:22:22 +0000
committerJustin Lecher <jlec@gentoo.org>2013-07-08 06:22:22 +0000
commit8051366ecbbf9225519733cdde913aa34d7dd4ff (patch)
treea440eb75a029986bd88c65c12f7b47b8742e023d /gnome-extra/activity-log-manager
parentBump (diff)
downloadgentoo-2-8051366ecbbf9225519733cdde913aa34d7dd4ff.tar.gz
gentoo-2-8051366ecbbf9225519733cdde913aa34d7dd4ff.tar.bz2
gentoo-2-8051366ecbbf9225519733cdde913aa34d7dd4ff.zip
gnome-extra/activity-log-manager: Version Bump
(Portage version: 2.2.0_alpha187/cvs/Linux x86_64, signed Manifest commit with key B9D4F231BD1558AB!)
Diffstat (limited to 'gnome-extra/activity-log-manager')
-rw-r--r--gnome-extra/activity-log-manager/ChangeLog9
-rw-r--r--gnome-extra/activity-log-manager/activity-log-manager-0.9.6.ebuild49
-rw-r--r--gnome-extra/activity-log-manager/files/activity-log-manager-0.9.6-whoopsie.patch55
3 files changed, 112 insertions, 1 deletions
diff --git a/gnome-extra/activity-log-manager/ChangeLog b/gnome-extra/activity-log-manager/ChangeLog
index eab0f65ed51b..252a73cace6f 100644
--- a/gnome-extra/activity-log-manager/ChangeLog
+++ b/gnome-extra/activity-log-manager/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for gnome-extra/activity-log-manager
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-extra/activity-log-manager/ChangeLog,v 1.13 2013/04/24 06:17:46 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnome-extra/activity-log-manager/ChangeLog,v 1.14 2013/07/08 06:22:22 jlec Exp $
+
+*activity-log-manager-0.9.6 (08 Jul 2013)
+
+ 08 Jul 2013; Justin Lecher <jlec@gentoo.org>
+ +activity-log-manager-0.9.6.ebuild,
+ +files/activity-log-manager-0.9.6-whoopsie.patch:
+ Version Bump
24 Apr 2013; Justin Lecher <jlec@gentoo.org>
activity-log-manager-0.9.4.ebuild, activity-log-manager-0.9.4-r1.ebuild:
diff --git a/gnome-extra/activity-log-manager/activity-log-manager-0.9.6.ebuild b/gnome-extra/activity-log-manager/activity-log-manager-0.9.6.ebuild
new file mode 100644
index 000000000000..85604d8826d7
--- /dev/null
+++ b/gnome-extra/activity-log-manager/activity-log-manager-0.9.6.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/gnome-extra/activity-log-manager/activity-log-manager-0.9.6.ebuild,v 1.1 2013/07/08 06:22:22 jlec Exp $
+
+EAPI=5
+
+GNOME2_LA_PUNT="yes"
+VALA_MIN_API_VERSION="0.10"
+
+inherit autotools eutils gnome2 vala versionator
+
+DESCRIPTION="GUI which lets you easily control what gets logged by Zeitgeist"
+HOMEPAGE="https://launchpad.net/activity-log-manager/"
+SRC_URI="
+ http://dev.gentoo.org/~jlec/distfiles/${P}-backport.patch.xz
+ http://launchpad.net/history-manager/$(get_version_component_range 1-2)/${PV}/+download/${P}.tar.xz"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+ dev-libs/libgee:0
+ dev-libs/glib:2
+ gnome-extra/zeitgeist
+ x11-libs/cairo
+ x11-libs/gdk-pixbuf
+ x11-libs/gtk+:3
+ x11-libs/pango"
+DEPEND="${RDEPEND}
+ $(vala_depend)
+ virtual/pkgconfig
+ dev-util/intltool
+ sys-devel/gettext"
+
+src_prepare() {
+ DOCS="README NEWS INSTALL ChangeLog AUTHORS"
+ epatch \
+ "${FILESDIR}"/${PN}-0.9.0.1-gold.patch \
+ "${WORKDIR}"/${P}-backport.patch \
+ "${FILESDIR}"/${P}-whoopsie.patch
+ sed \
+ -e "/^almdocdir/s:=.*$:= \${prefix}/share/doc/${PF}:g" \
+ -i Makefile.am || die
+ vala_src_prepare
+ eautoreconf
+ gnome2_src_prepare
+}
diff --git a/gnome-extra/activity-log-manager/files/activity-log-manager-0.9.6-whoopsie.patch b/gnome-extra/activity-log-manager/files/activity-log-manager-0.9.6-whoopsie.patch
new file mode 100644
index 000000000000..5f12ca30e6f5
--- /dev/null
+++ b/gnome-extra/activity-log-manager/files/activity-log-manager-0.9.6-whoopsie.patch
@@ -0,0 +1,55 @@
+=== modified file 'src/Makefile.am'
+--- src/Makefile.am 2013-07-07 19:51:19 +0000
++++ src/Makefile.am 2013-07-07 22:55:28 +0000
+@@ -70,6 +70,8 @@
+ endif
+
+ if HAVE_DIAG
++VALAFLAGS += \
++ -D DIAGNOSTIC
+ gnomeccuidir = $(datadir)/gnome-control-center/ui/
+ SUBDIRS = diagnostics
+ endif
+
+=== modified file 'src/activity-log-manager.vala'
+--- src/activity-log-manager.vala 2013-07-07 21:51:26 +0000
++++ src/activity-log-manager.vala 2013-07-07 22:55:28 +0000
+@@ -19,7 +19,10 @@
+ * You should have received a copy of the GNU Lesser General Public License
+ * along with this program. If not, see <http://www.gnu.org/licenses/>.";
+ */
++
++#if DIAGNOSTIC
+ extern Gtk.Widget whoopsie_daisy_preferences_new ();
++#endif
+
+ namespace Alm {
+
+@@ -35,13 +38,11 @@
+ Object(orientation: Gtk.Orientation.VERTICAL);
+ this.set_size_request(600, 450);
+ this.spacing = 6;
+-
+ this.margin = 12;
+
+ blacklist = new Blacklist();
+ privacy_widget = new PrivacyWidget(blacklist);
+- whoopsie = whoopsie_daisy_preferences_new ();
+-
++
+ notebook = new Gtk.Notebook();
+ this.pack_start(notebook, true, true, 0);
+ var privacy_label = new Gtk.Label(_("Files & Applications"));
+@@ -54,8 +55,11 @@
+ notebook.prepend_page(security_widget, security_label);
+ }
+
++#if DIAGNOSTIC
++ whoopsie = whoopsie_daisy_preferences_new ();
+ var whoopsie_label = new Gtk.Label(_("Diagnostics"));
+ notebook.append_page(whoopsie, whoopsie_label);
++#endif
+ this.show_all();
+ }
+
+