summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2008-06-30 22:07:24 +0000
committerGilles Dartiguelongue <eva@gentoo.org>2008-06-30 22:07:24 +0000
commite916ee073efc21f4f2d8cf0193052dcd19fed127 (patch)
treefcceb5599d14151f071e51e5ac34c6e1470420c3 /gnome-base
parentbump to 2.22.3. Translation updates. (diff)
downloadgentoo-2-e916ee073efc21f4f2d8cf0193052dcd19fed127.tar.gz
gentoo-2-e916ee073efc21f4f2d8cf0193052dcd19fed127.tar.bz2
gentoo-2-e916ee073efc21f4f2d8cf0193052dcd19fed127.zip
bump to 0.2.5 - * Fix unremovable files in trash (#523139). * Fix recursive copy of directories (#522933).
(Portage version: 2.2_rc1/cvs/Linux 2.6.24-gentoo-r8-mactel x86_64)
Diffstat (limited to 'gnome-base')
-rw-r--r--gnome-base/gvfs/ChangeLog9
-rw-r--r--gnome-base/gvfs/gvfs-0.2.5.ebuild62
2 files changed, 70 insertions, 1 deletions
diff --git a/gnome-base/gvfs/ChangeLog b/gnome-base/gvfs/ChangeLog
index 909712fe76f5..7e4759adc7c7 100644
--- a/gnome-base/gvfs/ChangeLog
+++ b/gnome-base/gvfs/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for gnome-base/gvfs
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-base/gvfs/ChangeLog,v 1.12 2008/06/01 10:59:14 nixnut Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnome-base/gvfs/ChangeLog,v 1.13 2008/06/30 22:07:24 eva Exp $
+
+*gvfs-0.2.5 (30 Jun 2008)
+
+ 30 Jun 2008; Gilles Dartiguelongue <eva@gentoo.org> +gvfs-0.2.5.ebuild:
+ bump to 0.2.5,
+ * Fix unremovable files in trash (#523139).
+ * Fix recursive copy of directories (#522933).
01 Jun 2008; nixnut <nixnut@gentoo.org> gvfs-0.2.3.ebuild:
Added ~ppc wrt bug 218794
diff --git a/gnome-base/gvfs/gvfs-0.2.5.ebuild b/gnome-base/gvfs/gvfs-0.2.5.ebuild
new file mode 100644
index 000000000000..f2dbfccb3ee7
--- /dev/null
+++ b/gnome-base/gvfs/gvfs-0.2.5.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/gnome-base/gvfs/gvfs-0.2.5.ebuild,v 1.1 2008/06/30 22:07:24 eva Exp $
+
+inherit gnome2 eutils
+
+DESCRIPTION="GNOME Virtual Filesystem Layer"
+HOMEPAGE="http://www.gnome.org"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc64 ~sparc ~x86"
+IUSE="avahi bluetooth cdda doc fuse gnome gphoto2 hal gnome-keyring samba"
+
+RDEPEND=">=dev-libs/glib-2.16
+ >=sys-apps/dbus-1.0
+ >=net-libs/libsoup-2.4
+ dev-libs/libxml2
+ net-misc/openssh
+ avahi? ( >=net-dns/avahi-0.6 )
+ cdda? (
+ >=sys-apps/hal-0.5.10
+ >=dev-libs/libcdio-0.78.2
+ )
+ fuse? ( sys-fs/fuse )
+ gnome? ( >=gnome-base/gconf-2.0 )
+ hal? ( >=sys-apps/hal-0.5.10 )
+ bluetooth? (
+ dev-libs/dbus-glib
+ >=net-wireless/bluez-libs-3.12
+ dev-libs/expat
+ )
+ gphoto2? ( >=media-libs/libgphoto2-2.4 )
+ gnome-keyring? ( >=gnome-base/gnome-keyring-1.0 )
+ samba? ( >=net-fs/samba-3 )"
+DEPEND="${RDEPEND}
+ >=dev-util/intltool-0.35
+ >=dev-util/pkgconfig-0.19
+ doc? ( >=dev-util/gtk-doc-1 )"
+
+DOCS="AUTHORS ChangeLog NEWS README TODO"
+
+pkg_setup() {
+ G2CONF="${G2CONF}
+ --enable-http
+ $(use_enable avahi)
+ $(use_enable bluetooth obexftp)
+ $(use_enable cdda)
+ $(use_enable fuse)
+ $(use_enable gnome gconf)
+ $(use_enable gphoto2)
+ $(use_enable hal)
+ $(use_enable gnome-keyring keyring)
+ $(use_enable samba)"
+
+ if use cdda && built_with_use dev-libs/libcdio minimal; then
+ ewarn
+ ewarn "CDDA support in gvfs requires dev-libs/libcdio to be built"
+ ewarn "without the minimal USE flag."
+ die "Please re-emerge dev-libs/libcdio without the minimal USE flag"
+ fi
+}