summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2008-11-29 12:31:42 +0000
committerGilles Dartiguelongue <eva@gentoo.org>2008-11-29 12:31:42 +0000
commite347b743cd9715e1af64de14622b3ce5a75aff7a (patch)
treef0038937c0d8beba522877e16aafdb4445e67bb9 /gnome-base
parentMove extutils-pkgconfig to DEPEND wrt #223075. Last one. (diff)
downloadgentoo-2-e347b743cd9715e1af64de14622b3ce5a75aff7a.tar.gz
gentoo-2-e347b743cd9715e1af64de14622b3ce5a75aff7a.tar.bz2
gentoo-2-e347b743cd9715e1af64de14622b3ce5a75aff7a.zip
Bump to 2.24.1. Bug fixes and translation updates.
(Portage version: 2.2_rc16/cvs/Linux 2.6.24-gentoo-r8-mactel x86_64)
Diffstat (limited to 'gnome-base')
-rw-r--r--gnome-base/gnome-settings-daemon/ChangeLog8
-rw-r--r--gnome-base/gnome-settings-daemon/gnome-settings-daemon-2.24.1.ebuild83
2 files changed, 90 insertions, 1 deletions
diff --git a/gnome-base/gnome-settings-daemon/ChangeLog b/gnome-base/gnome-settings-daemon/ChangeLog
index 2f32424221f3..5d1c77c8a291 100644
--- a/gnome-base/gnome-settings-daemon/ChangeLog
+++ b/gnome-base/gnome-settings-daemon/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for gnome-base/gnome-settings-daemon
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-base/gnome-settings-daemon/ChangeLog,v 1.17 2008/11/15 00:35:23 chainsaw Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnome-base/gnome-settings-daemon/ChangeLog,v 1.18 2008/11/29 12:31:42 eva Exp $
+
+*gnome-settings-daemon-2.24.1 (29 Nov 2008)
+
+ 29 Nov 2008; Gilles Dartiguelongue <eva@gentoo.org>
+ +gnome-settings-daemon-2.24.1.ebuild:
+ Bump to 2.24.1. Bug fixes and translation updates.
15 Nov 2008; <chainsaw@gentoo.org> gnome-settings-daemon-2.24.0.ebuild:
I added an explicit dependency on the fixed gnome-session ebuild. Circular
diff --git a/gnome-base/gnome-settings-daemon/gnome-settings-daemon-2.24.1.ebuild b/gnome-base/gnome-settings-daemon/gnome-settings-daemon-2.24.1.ebuild
new file mode 100644
index 000000000000..141e7bb39f91
--- /dev/null
+++ b/gnome-base/gnome-settings-daemon/gnome-settings-daemon-2.24.1.ebuild
@@ -0,0 +1,83 @@
+# Copyright 2008-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/gnome-base/gnome-settings-daemon/gnome-settings-daemon-2.24.1.ebuild,v 1.1 2008/11/29 12:31:42 eva Exp $
+
+inherit autotools eutils gnome2
+
+DESCRIPTION="Gnome Settings Daemon"
+HOMEPAGE="http://www.gnome.org"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="alsa debug esd gstreamer libnotify pulseaudio"
+
+RDEPEND=">=dev-libs/dbus-glib-0.74
+ >=dev-libs/glib-2.18.0
+ >=x11-libs/gtk+-2.10
+ >=gnome-base/gconf-2.6.1
+ >=gnome-base/libgnomekbd-2.21.4
+
+ >=gnome-base/libglade-2
+ >=gnome-base/libgnome-2
+ >=gnome-base/libgnomeui-2
+ >=gnome-base/gnome-desktop-2.23.90
+
+ libnotify? ( >=x11-libs/libnotify-0.4.3 )
+
+ x11-libs/libX11
+ x11-libs/libXi
+ x11-libs/libXrandr
+ x11-libs/libXext
+ x11-libs/libXxf86misc
+ >=x11-libs/libxklavier-3.3
+ media-libs/fontconfig
+
+ esd? ( >=media-sound/esound-0.2.28 )
+ gstreamer? (
+ >=media-libs/gstreamer-0.10.1.2
+ >=media-libs/gst-plugins-base-0.10.1.2 )
+ !gstreamer? (
+ alsa? ( >=media-libs/alsa-lib-0.99 ) )"
+# In configure: gstreamer wins over alsa
+
+DEPEND="${RDEPEND}
+ !<gnome-base/gnome-control-center-2.22
+ sys-devel/gettext
+ >=dev-util/intltool-0.40
+ >=dev-util/pkgconfig-0.19
+ x11-proto/inputproto
+ x11-proto/xproto"
+
+# FIXME: pulseaudio is used to detect if system should build
+# old sound preference capplet (some braindead logic in there)
+PDEPEND="pulseaudio? ( >=media-sound/pulseaudio-0.9.9 )"
+
+# README is empty
+DOCS="AUTHORS NEWS ChangeLog MAINTAINERS"
+
+pkg_setup() {
+ G2CONF="${G2CONF}
+ $(use_enable alsa)
+ $(use_enable debug)
+ $(use_enable esd)
+ $(use_enable gstreamer)
+ $(use_enable libnotify)
+ $(use_enable !pulseaudio legacy-sound-pref)"
+ # We use legacy-sound-pref instead of pulse because
+ # there is no gain in adding a build time dep on pulseaudio
+
+ if use esd && use pulseaudio; then
+ ewarn "You selected conflicting USE flags. Please note that USE=\"esd\""
+ ewarn "has no effect when USE=\"pulseaudio\" is selected."
+ fi
+}
+
+src_unpack() {
+ gnome2_src_unpack
+
+ # Fix libnotify & pulseaudio automagic dependencies
+ epatch "${FILESDIR}/${PN}-2.24.0-automagic.patch"
+
+ eautoreconf
+}