summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLeonardo Boshell <leonardop@gentoo.org>2004-04-08 10:50:48 +0000
committerLeonardo Boshell <leonardop@gentoo.org>2004-04-08 10:50:48 +0000
commitd038ad817234083aa80d0436bb4dc21edc10849d (patch)
tree2ff8f66cafd0669b42a3e9300d0bc86912f593cc /gnome-base
parentpdftops doesn't print pdf form elements properly, bug #46529 (Manifest recommit) (diff)
downloadgentoo-2-d038ad817234083aa80d0436bb4dc21edc10849d.tar.gz
gentoo-2-d038ad817234083aa80d0436bb4dc21edc10849d.tar.bz2
gentoo-2-d038ad817234083aa80d0436bb4dc21edc10849d.zip
Patch that fixes compilation under GCC 2. Misc cleanups.
Diffstat (limited to 'gnome-base')
-rw-r--r--gnome-base/librsvg/ChangeLog7
-rw-r--r--gnome-base/librsvg/files/librsvg-2.6.4-gcc2_fix.patch24
-rw-r--r--gnome-base/librsvg/librsvg-1.0.3.ebuild4
-rw-r--r--gnome-base/librsvg/librsvg-2.4.0.ebuild4
-rw-r--r--gnome-base/librsvg/librsvg-2.6.4.ebuild13
5 files changed, 44 insertions, 8 deletions
diff --git a/gnome-base/librsvg/ChangeLog b/gnome-base/librsvg/ChangeLog
index 387800fb9ed7..34e3cdea17bc 100644
--- a/gnome-base/librsvg/ChangeLog
+++ b/gnome-base/librsvg/ChangeLog
@@ -1,7 +1,12 @@
# ChangeLog for gnome-base/librsvg
# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-base/librsvg/ChangeLog,v 1.40 2004/03/31 22:27:28 foser Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnome-base/librsvg/ChangeLog,v 1.41 2004/04/08 10:50:48 leonardop Exp $
+ 08 Apr 2004; L. Boshell <leonardop@gentoo.org> librsvg-2.6.4.ebuild,
+ files/ librsvg-2.6.4-gcc2_fix.patch:
+ Added patch so it can compile using gcc-2. Replace the --enable-croco
+ flag with --with-croco.
+
*librsvg-2.6.4 (01 Apr 2004)
01 Apr 2004; foser <foser@gentoo.org> librsvg-2.6.4.ebuild :
diff --git a/gnome-base/librsvg/files/librsvg-2.6.4-gcc2_fix.patch b/gnome-base/librsvg/files/librsvg-2.6.4-gcc2_fix.patch
new file mode 100644
index 000000000000..cfcb0db49f95
--- /dev/null
+++ b/gnome-base/librsvg/files/librsvg-2.6.4-gcc2_fix.patch
@@ -0,0 +1,24 @@
+diff -NurdB librsvg-2.6.4-orig/rsvg-paint-server.c librsvg-2.6.4/rsvg-paint-server.c
+--- librsvg-2.6.4-orig/rsvg-paint-server.c 2004-04-08 05:25:24.000000000 -0500
++++ librsvg-2.6.4/rsvg-paint-server.c 2004-04-08 05:32:19.000000000 -0500
+@@ -149,6 +149,9 @@
+ double x1, y1, x2, y2;
+ double dx, dy, scale;
+ double affine[6];
++ float xchange, ychange, pointlen,unitlen;
++ float nx2, ny2;
++ float x0, y0;
+ int i;
+
+ agl = z->agl;
+@@ -180,10 +183,6 @@
+
+ art_affine_multiply(affine, rlg->affine, affine);
+
+- float xchange, ychange, pointlen,unitlen;
+- float nx2, ny2;
+- float x0, y0;
+-
+ xchange = rlg->x2 - rlg->x1;
+ ychange = rlg->y2 - rlg->y1;
+
diff --git a/gnome-base/librsvg/librsvg-1.0.3.ebuild b/gnome-base/librsvg/librsvg-1.0.3.ebuild
index 88a87ed0dffd..94c86102f744 100644
--- a/gnome-base/librsvg/librsvg-1.0.3.ebuild
+++ b/gnome-base/librsvg/librsvg-1.0.3.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-base/librsvg/librsvg-1.0.3.ebuild,v 1.11 2004/02/22 20:47:56 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnome-base/librsvg/librsvg-1.0.3.ebuild,v 1.12 2004/04/08 10:50:48 leonardop Exp $
S=${WORKDIR}/${P}
DESCRIPTION="librsvg"
diff --git a/gnome-base/librsvg/librsvg-2.4.0.ebuild b/gnome-base/librsvg/librsvg-2.4.0.ebuild
index 733853c9fc67..c09d2fe1a5d9 100644
--- a/gnome-base/librsvg/librsvg-2.4.0.ebuild
+++ b/gnome-base/librsvg/librsvg-2.4.0.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-base/librsvg/librsvg-2.4.0.ebuild,v 1.11 2003/12/13 22:22:27 foser Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnome-base/librsvg/librsvg-2.4.0.ebuild,v 1.12 2004/04/08 10:50:48 leonardop Exp $
inherit gnome2
diff --git a/gnome-base/librsvg/librsvg-2.6.4.ebuild b/gnome-base/librsvg/librsvg-2.6.4.ebuild
index 0c8f86412eb8..89dab01230bd 100644
--- a/gnome-base/librsvg/librsvg-2.6.4.ebuild
+++ b/gnome-base/librsvg/librsvg-2.6.4.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-base/librsvg/librsvg-2.6.4.ebuild,v 1.1 2004/03/31 22:27:28 foser Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnome-base/librsvg/librsvg-2.6.4.ebuild,v 1.2 2004/04/08 10:50:48 leonardop Exp $
-inherit gnome2
+inherit eutils gnome2
DESCRIPTION="Scalable Vector Graphics (SVG) rendering library"
HOMEPAGE="http://librsvg.sourceforge.net/"
@@ -27,12 +27,19 @@ DEPEND="${RDEPEND}
# FIXME : USEify croco support (?)
G2CONF="${G2CONF} $(use_with zlib svgz) \
- --enable-croco \
+ --with-croco \
--enable-pixbuf-loader \
--enable-gtk-theme"
DOCS="AUTHORS ChangeLog COPYIN* README INSTALL NEWS TODO"
+src_unpack () {
+ unpack ${A}
+ cd ${S}
+ # Make sure the source is proper ANSI C, so it compiles with gcc-2.
+ epatch ${FILESDIR}/${P}-gcc2_fix.patch
+}
+
pkg_postinst() {
gdk-pixbuf-query-loaders > /etc/gtk-2.0/gdk-pixbuf.loaders