summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Schlemmer <azarah@gentoo.org>2002-04-27 15:52:35 +0000
committerMartin Schlemmer <azarah@gentoo.org>2002-04-27 15:52:35 +0000
commitb8702f10d377dfef15922c92b34a5f71479ec43b (patch)
tree369f35d479afca860c2de04e9d5f9f87e0edfa90 /gnome-base
parentresolved sandbox violation (diff)
downloadgentoo-2-b8702f10d377dfef15922c92b34a5f71479ec43b.tar.gz
gentoo-2-b8702f10d377dfef15922c92b34a5f71479ec43b.tar.bz2
gentoo-2-b8702f10d377dfef15922c92b34a5f71479ec43b.zip
add missing macros
Diffstat (limited to 'gnome-base')
-rw-r--r--gnome-base/nautilus/ChangeLog8
-rw-r--r--gnome-base/nautilus/files/digest-nautilus-1.0.6-r51
-rw-r--r--gnome-base/nautilus/files/digest-nautilus-1.0.6-r61
-rw-r--r--gnome-base/nautilus/files/digest-nautilus-1.0.6-r8 (renamed from gnome-base/nautilus/files/digest-nautilus-1.0.6-r4)0
-rw-r--r--gnome-base/nautilus/files/macros/gnome.m4475
-rw-r--r--gnome-base/nautilus/files/macros/nautilus-macros.m4224
-rw-r--r--gnome-base/nautilus/nautilus-1.0.6-r4.ebuild91
-rw-r--r--gnome-base/nautilus/nautilus-1.0.6-r5.ebuild95
-rw-r--r--gnome-base/nautilus/nautilus-1.0.6-r8.ebuild (renamed from gnome-base/nautilus/nautilus-1.0.6-r6.ebuild)27
9 files changed, 728 insertions, 194 deletions
diff --git a/gnome-base/nautilus/ChangeLog b/gnome-base/nautilus/ChangeLog
index c3026c2881b6..7eb1a1fa287d 100644
--- a/gnome-base/nautilus/ChangeLog
+++ b/gnome-base/nautilus/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for gnome-base/nautilus
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/gnome-base/nautilus/ChangeLog,v 1.6 2002/04/25 06:08:40 mkennedy Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnome-base/nautilus/ChangeLog,v 1.7 2002/04/27 15:52:35 azarah Exp $
+
+*nautilus-1.0.6-r8 (27 Apr 2002)
+
+ 27 Apr 2002; M.Schlemmer <azarah@gentoo.org> :
+
+ Add missing macros, and po2tbl.sed.in.
*nautilus-1.0.6-r7 (24 Apr 2002)
diff --git a/gnome-base/nautilus/files/digest-nautilus-1.0.6-r5 b/gnome-base/nautilus/files/digest-nautilus-1.0.6-r5
deleted file mode 100644
index 618f369df464..000000000000
--- a/gnome-base/nautilus/files/digest-nautilus-1.0.6-r5
+++ /dev/null
@@ -1 +0,0 @@
-MD5 436283056c100bcbd14098a5342e2868 nautilus-1.0.6.tar.gz 11481232
diff --git a/gnome-base/nautilus/files/digest-nautilus-1.0.6-r6 b/gnome-base/nautilus/files/digest-nautilus-1.0.6-r6
deleted file mode 100644
index 618f369df464..000000000000
--- a/gnome-base/nautilus/files/digest-nautilus-1.0.6-r6
+++ /dev/null
@@ -1 +0,0 @@
-MD5 436283056c100bcbd14098a5342e2868 nautilus-1.0.6.tar.gz 11481232
diff --git a/gnome-base/nautilus/files/digest-nautilus-1.0.6-r4 b/gnome-base/nautilus/files/digest-nautilus-1.0.6-r8
index 618f369df464..618f369df464 100644
--- a/gnome-base/nautilus/files/digest-nautilus-1.0.6-r4
+++ b/gnome-base/nautilus/files/digest-nautilus-1.0.6-r8
diff --git a/gnome-base/nautilus/files/macros/gnome.m4 b/gnome-base/nautilus/files/macros/gnome.m4
new file mode 100644
index 000000000000..0b86621d17c8
--- /dev/null
+++ b/gnome-base/nautilus/files/macros/gnome.m4
@@ -0,0 +1,475 @@
+# Macro to add for using GNU gettext.
+# Ulrich Drepper <drepper@cygnus.com>, 1995.
+#
+# Modified to never use included libintl.
+# Owen Taylor <otaylor@redhat.com>, 12/15/1998
+#
+#
+# This file can be copied and used freely without restrictions. It can
+# be used in projects which are not available under the GNU Public License
+# but which still want to provide support for the GNU gettext functionality.
+# Please note that the actual code is *not* freely available.
+
+# serial 5
+
+AC_DEFUN(AM_GNOME_WITH_NLS,
+ [AC_MSG_CHECKING([whether NLS is requested])
+ dnl Default is enabled NLS
+ AC_ARG_ENABLE(nls,
+ [ --disable-nls do not use Native Language Support],
+ USE_NLS=$enableval, USE_NLS=yes)
+ AC_MSG_RESULT($USE_NLS)
+ AC_SUBST(USE_NLS)
+
+ USE_INCLUDED_LIBINTL=no
+
+ dnl If we use NLS figure out what method
+ if test "$USE_NLS" = "yes"; then
+ AC_DEFINE(ENABLE_NLS)
+# AC_MSG_CHECKING([whether included gettext is requested])
+# AC_ARG_WITH(included-gettext,
+# [ --with-included-gettext use the GNU gettext library included here],
+# nls_cv_force_use_gnu_gettext=$withval,
+# nls_cv_force_use_gnu_gettext=no)
+# AC_MSG_RESULT($nls_cv_force_use_gnu_gettext)
+ nls_cv_force_use_gnu_gettext="no"
+
+ nls_cv_use_gnu_gettext="$nls_cv_force_use_gnu_gettext"
+ if test "$nls_cv_force_use_gnu_gettext" != "yes"; then
+ dnl User does not insist on using GNU NLS library. Figure out what
+ dnl to use. If gettext or catgets are available (in this order) we
+ dnl use this. Else we have to fall back to GNU NLS library.
+ dnl catgets is only used if permitted by option --with-catgets.
+ nls_cv_header_intl=
+ nls_cv_header_libgt=
+ CATOBJEXT=NONE
+
+ AC_CHECK_HEADER(libintl.h,
+ [AC_CACHE_CHECK([for gettext in libc], gt_cv_func_gettext_libc,
+ [AC_TRY_LINK([#include <libintl.h>], [return (int) gettext ("")],
+ gt_cv_func_gettext_libc=yes, gt_cv_func_gettext_libc=no)])
+
+ if test "$gt_cv_func_gettext_libc" != "yes"; then
+ AC_CHECK_LIB(intl, bindtextdomain,
+ [AC_CACHE_CHECK([for gettext in libintl],
+ gt_cv_func_gettext_libintl,
+ [AC_CHECK_LIB(intl, gettext,
+ gt_cv_func_gettext_libintl=yes,
+ gt_cv_func_gettext_libintl=no)],
+ gt_cv_func_gettext_libintl=no)])
+ fi
+
+ if test "$gt_cv_func_gettext_libc" = "yes" \
+ || test "$gt_cv_func_gettext_libintl" = "yes"; then
+ AC_DEFINE(HAVE_GETTEXT)
+ AM_PATH_PROG_WITH_TEST(MSGFMT, msgfmt,
+ [test -z "`$ac_dir/$ac_word -h 2>&1 | grep 'dv '`"], no)dnl
+ if test "$MSGFMT" != "no"; then
+ AC_CHECK_FUNCS(dcgettext)
+ AC_PATH_PROG(GMSGFMT, gmsgfmt, $MSGFMT)
+ AM_PATH_PROG_WITH_TEST(XGETTEXT, xgettext,
+ [test -z "`$ac_dir/$ac_word -h 2>&1 | grep '(HELP)'`"], :)
+ AC_TRY_LINK(, [extern int _nl_msg_cat_cntr;
+ return _nl_msg_cat_cntr],
+ [CATOBJEXT=.gmo
+ DATADIRNAME=share],
+ [CATOBJEXT=.mo
+ DATADIRNAME=lib])
+ INSTOBJEXT=.mo
+ fi
+ fi
+
+ # Added by Martin Baulig 12/15/98 for libc5 systems
+ if test "$gt_cv_func_gettext_libc" != "yes" \
+ && test "$gt_cv_func_gettext_libintl" = "yes"; then
+ INTLLIBS=-lintl
+ LIBS=`echo $LIBS | sed -e 's/-lintl//'`
+ fi
+ ])
+
+ if test "$CATOBJEXT" = "NONE"; then
+ AC_MSG_CHECKING([whether catgets can be used])
+ AC_ARG_WITH(catgets,
+ [ --with-catgets use catgets functions if available],
+ nls_cv_use_catgets=$withval, nls_cv_use_catgets=no)
+ AC_MSG_RESULT($nls_cv_use_catgets)
+
+ if test "$nls_cv_use_catgets" = "yes"; then
+ dnl No gettext in C library. Try catgets next.
+ AC_CHECK_LIB(i, main)
+ AC_CHECK_FUNC(catgets,
+ [AC_DEFINE(HAVE_CATGETS)
+ INTLOBJS="\$(CATOBJS)"
+ AC_PATH_PROG(GENCAT, gencat, no)dnl
+# if test "$GENCAT" != "no"; then
+# AC_PATH_PROG(GMSGFMT, gmsgfmt, no)
+# if test "$GMSGFMT" = "no"; then
+# AM_PATH_PROG_WITH_TEST(GMSGFMT, msgfmt,
+# [test -z "`$ac_dir/$ac_word -h 2>&1 | grep 'dv '`"], no)
+# fi
+# AM_PATH_PROG_WITH_TEST(XGETTEXT, xgettext,
+# [test -z "`$ac_dir/$ac_word -h 2>&1 | grep '(HELP)'`"], :)
+# USE_INCLUDED_LIBINTL=yes
+# CATOBJEXT=.cat
+# INSTOBJEXT=.cat
+# DATADIRNAME=lib
+# INTLDEPS='$(top_builddir)/intl/libintl.a'
+# INTLLIBS=$INTLDEPS
+# LIBS=`echo $LIBS | sed -e 's/-lintl//'`
+# nls_cv_header_intl=intl/libintl.h
+# nls_cv_header_libgt=intl/libgettext.h
+# fi
+ ])
+ fi
+ fi
+
+ if test "$CATOBJEXT" = "NONE"; then
+ dnl Neither gettext nor catgets in included in the C library.
+ dnl Fall back on GNU gettext library.
+ nls_cv_use_gnu_gettext=yes
+ fi
+ fi
+
+ if test "$nls_cv_use_gnu_gettext" != "yes"; then
+ AC_DEFINE(ENABLE_NLS)
+ else
+ # Unset this variable since we use the non-zero value as a flag.
+ CATOBJEXT=
+# dnl Mark actions used to generate GNU NLS library.
+# INTLOBJS="\$(GETTOBJS)"
+# AM_PATH_PROG_WITH_TEST(MSGFMT, msgfmt,
+# [test -z "`$ac_dir/$ac_word -h 2>&1 | grep 'dv '`"], msgfmt)
+# AC_PATH_PROG(GMSGFMT, gmsgfmt, $MSGFMT)
+# AM_PATH_PROG_WITH_TEST(XGETTEXT, xgettext,
+# [test -z "`$ac_dir/$ac_word -h 2>&1 | grep '(HELP)'`"], :)
+# AC_SUBST(MSGFMT)
+# USE_INCLUDED_LIBINTL=yes
+# CATOBJEXT=.gmo
+# INSTOBJEXT=.mo
+# DATADIRNAME=share
+# INTLDEPS='$(top_builddir)/intl/libintl.a'
+# INTLLIBS=$INTLDEPS
+# LIBS=`echo $LIBS | sed -e 's/-lintl//'`
+# nls_cv_header_intl=intl/libintl.h
+# nls_cv_header_libgt=intl/libgettext.h
+ fi
+
+ dnl Test whether we really found GNU xgettext.
+ if test "$XGETTEXT" != ":"; then
+ dnl If it is no GNU xgettext we define it as : so that the
+ dnl Makefiles still can work.
+ if $XGETTEXT --omit-header /dev/null 2> /dev/null; then
+ : ;
+ else
+ AC_MSG_RESULT(
+ [found xgettext program is not GNU xgettext; ignore it])
+ XGETTEXT=":"
+ fi
+ fi
+
+ # We need to process the po/ directory.
+ POSUB=po
+ else
+ DATADIRNAME=share
+ nls_cv_header_intl=intl/libintl.h
+ nls_cv_header_libgt=intl/libgettext.h
+ fi
+ AC_LINK_FILES($nls_cv_header_libgt, $nls_cv_header_intl)
+ AC_OUTPUT_COMMANDS(
+ [case "$CONFIG_FILES" in *po/Makefile.in*)
+ sed -e "/POTFILES =/r po/POTFILES" po/Makefile.in > po/Makefile
+ esac])
+
+
+# # If this is used in GNU gettext we have to set USE_NLS to `yes'
+# # because some of the sources are only built for this goal.
+# if test "$PACKAGE" = gettext; then
+# USE_NLS=yes
+# USE_INCLUDED_LIBINTL=yes
+# fi
+
+ dnl These rules are solely for the distribution goal. While doing this
+ dnl we only have to keep exactly one list of the available catalogs
+ dnl in configure.in.
+ for lang in $ALL_LINGUAS; do
+ GMOFILES="$GMOFILES $lang.gmo"
+ POFILES="$POFILES $lang.po"
+ done
+
+ dnl Make all variables we use known to autoconf.
+ AC_SUBST(USE_INCLUDED_LIBINTL)
+ AC_SUBST(CATALOGS)
+ AC_SUBST(CATOBJEXT)
+ AC_SUBST(DATADIRNAME)
+ AC_SUBST(GMOFILES)
+ AC_SUBST(INSTOBJEXT)
+ AC_SUBST(INTLDEPS)
+ AC_SUBST(INTLLIBS)
+ AC_SUBST(INTLOBJS)
+ AC_SUBST(POFILES)
+ AC_SUBST(POSUB)
+ ])
+
+AC_DEFUN(AM_GNOME_GETTEXT,
+ [AC_REQUIRE([AC_PROG_MAKE_SET])dnl
+ AC_REQUIRE([AC_PROG_CC])dnl
+ AC_REQUIRE([AC_PROG_RANLIB])dnl
+ AC_REQUIRE([AC_ISC_POSIX])dnl
+ AC_REQUIRE([AC_HEADER_STDC])dnl
+ AC_REQUIRE([AC_C_CONST])dnl
+ AC_REQUIRE([AC_C_INLINE])dnl
+ AC_REQUIRE([AC_TYPE_OFF_T])dnl
+ AC_REQUIRE([AC_TYPE_SIZE_T])dnl
+ AC_REQUIRE([AC_FUNC_ALLOCA])dnl
+ AC_REQUIRE([AC_FUNC_MMAP])dnl
+
+ AC_CHECK_HEADERS([argz.h limits.h locale.h nl_types.h malloc.h string.h \
+unistd.h sys/param.h])
+ AC_CHECK_FUNCS([getcwd munmap putenv setenv setlocale strchr strcasecmp \
+strdup __argz_count __argz_stringify __argz_next])
+
+ if test "${ac_cv_func_stpcpy+set}" != "set"; then
+ AC_CHECK_FUNCS(stpcpy)
+ fi
+ if test "${ac_cv_func_stpcpy}" = "yes"; then
+ AC_DEFINE(HAVE_STPCPY)
+ fi
+
+ AM_LC_MESSAGES
+ AM_GNOME_WITH_NLS
+
+ if test "x$CATOBJEXT" != "x"; then
+ if test "x$ALL_LINGUAS" = "x"; then
+ LINGUAS=
+ else
+ AC_MSG_CHECKING(for catalogs to be installed)
+ NEW_LINGUAS=
+ if test "x$LINGUAS" = "x"; then
+ LINGUAS=$ALL_LINGUAS
+ fi
+ for lang in $LINGUAS; do
+ case "$ALL_LINGUAS" in
+ *$lang*) NEW_LINGUAS="$NEW_LINGUAS $lang" ;;
+ esac
+ done
+ LINGUAS=$NEW_LINGUAS
+ AC_MSG_RESULT($LINGUAS)
+ fi
+
+ dnl Construct list of names of catalog files to be constructed.
+ if test -n "$LINGUAS"; then
+ for lang in $LINGUAS; do CATALOGS="$CATALOGS $lang$CATOBJEXT"; done
+ fi
+ fi
+
+ dnl The reference to <locale.h> in the installed <libintl.h> file
+ dnl must be resolved because we cannot expect the users of this
+ dnl to define HAVE_LOCALE_H.
+ if test $ac_cv_header_locale_h = yes; then
+ INCLUDE_LOCALE_H="#include <locale.h>"
+ else
+ INCLUDE_LOCALE_H="\
+/* The system does not provide the header <locale.h>. Take care yourself. */"
+ fi
+ AC_SUBST(INCLUDE_LOCALE_H)
+
+ dnl Determine which catalog format we have (if any is needed)
+ dnl For now we know about two different formats:
+ dnl Linux libc-5 and the normal X/Open format
+ test -d intl || mkdir intl
+ if test "$CATOBJEXT" = ".cat"; then
+ AC_CHECK_HEADER(linux/version.h, msgformat=linux, msgformat=xopen)
+
+ dnl Transform the SED scripts while copying because some dumb SEDs
+ dnl cannot handle comments.
+ sed -e '/^#/d' $srcdir/intl/$msgformat-msg.sed > intl/po2msg.sed
+ fi
+ dnl po2tbl.sed is always needed.
+ sed -e '/^#.*[^\\]$/d' -e '/^#$/d' \
+ $srcdir/intl/po2tbl.sed.in > intl/po2tbl.sed
+
+ dnl In the intl/Makefile.in we have a special dependency which makes
+ dnl only sense for gettext. We comment this out for non-gettext
+ dnl packages.
+ if test "$PACKAGE" = "gettext"; then
+ GT_NO="#NO#"
+ GT_YES=
+ else
+ GT_NO=
+ GT_YES="#YES#"
+ fi
+ AC_SUBST(GT_NO)
+ AC_SUBST(GT_YES)
+
+ dnl If the AC_CONFIG_AUX_DIR macro for autoconf is used we possibly
+ dnl find the mkinstalldirs script in another subdir but ($top_srcdir).
+ dnl Try to locate is.
+ MKINSTALLDIRS=
+ if test -n "$ac_aux_dir"; then
+ MKINSTALLDIRS="$ac_aux_dir/mkinstalldirs"
+ fi
+ if test -z "$MKINSTALLDIRS"; then
+ MKINSTALLDIRS="\$(top_srcdir)/mkinstalldirs"
+ fi
+ AC_SUBST(MKINSTALLDIRS)
+
+ dnl *** For now the libtool support in intl/Makefile is not for real.
+ l=
+ AC_SUBST(l)
+
+ dnl Generate list of files to be processed by xgettext which will
+ dnl be included in po/Makefile.
+ test -d po || mkdir po
+ if test "x$srcdir" != "x."; then
+ if test "x`echo $srcdir | sed 's@/.*@@'`" = "x"; then
+ posrcprefix="$srcdir/"
+ else
+ posrcprefix="../$srcdir/"
+ fi
+ else
+ posrcprefix="../"
+ fi
+ rm -f po/POTFILES
+ sed -e "/^#/d" -e "/^\$/d" -e "s,.*, $posrcprefix& \\\\," -e "\$s/\(.*\) \\\\/\1/" \
+ < $srcdir/po/POTFILES.in > po/POTFILES
+ ])
+
+
+AC_DEFUN(AM_PATH_GNOME,
+[dnl
+dnl Get the cflags and libraries from the gnome-config script
+dnl
+AC_ARG_WITH(gnome-prefix,[ --with-gnome-prefix=PFX Prefix where GNOME is installed (optional)],
+ gnome_config_prefix="$withval", gnome_config_prefix="")
+AC_ARG_WITH(gnome-exec-prefix,[ --with-gnome-exec-prefix=PFX Exec prefix where GNOME is installed (optional)],
+ gnome_config_exec_prefix="$withval", gnome_config_exec_prefix="")
+AC_ARG_ENABLE(gnometest, [ --disable-gnometest Do not try to compile and run a test GNOME program],
+ , enable_gnometest=yes)
+
+ if test x$gnome_config_exec_prefix != x ; then
+ gnome_config_args="$gnome_config_args --exec-prefix=$gnome_config_exec_prefix"
+ if test x${GNOME_CONFIG+set} != xset ; then
+ GNOME_CONFIG=$gnome_config_exec_prefix/bin/gnome-config
+ fi
+ fi
+ if test x$gnome_config_prefix != x ; then
+ gnome_config_args="$gnome_config_args --prefix=$gnome_config_prefix"
+ if test x${GNOME_CONFIG+set} != xset ; then
+ GNOME_CONFIG=$gnome_config_prefix/bin/gnome-config
+ fi
+ fi
+
+ AC_PATH_PROG(GNOME_CONFIG, gnome-config, no)
+ min_gnome_version=ifelse([$1], , 1.1.0, $1)
+
+ AC_MSG_CHECKING(for GNOME - version >= $min_gnome_version)
+ no_gnome=""
+ if test "$GNOME_CONFIG" = "no" ; then
+ no_gnome=yes
+ else
+ GNOME_CFLAGS="`$GNOME_CONFIG $gnome_config_args --cflags gnome`"
+ GNOME_LIBS="`$GNOME_CONFIG $gnome_config_args --libs gnome`"
+ GNOMEUI_CFLAGS="`$GNOME_CONFIG $gnome_config_args --cflags gnomeui`"
+ GNOMEUI_LIBS="`$GNOME_CONFIG $gnome_config_args --libs gnomeui`"
+
+ gnome_config_major_version=`$GNOME_CONFIG $gnome_config_args --version | \
+ sed 's/[[^0-9]]*\([[0-9]]*\)\.\([[0-9]]*\)\.\([[0-9]]*\)\(\..\)/\1/'`
+ gnome_config_minor_version=`$GNOME_CONFIG $gnome_config_args --version | \
+ sed 's/[[^0-9]]*\([[0-9]]*\)\.\([[0-9]]*\)\.\([[0-9]]*\)\(\..\)/\2/'`
+ gnome_config_micro_version=`$GNOME_CONFIG $gnome_config_args --version | \
+ sed 's/[[^0-9]]*\([[0-9]]*\)\.\([[0-9]]*\)\.\([[0-9]]*\)\(\..\)/\3/'`
+ needed_major_version=`echo $min_gnome_version | \
+ sed 's/[[^0-9]]*\([[0-9]]*\)\.\([[0-9]]*\)\.\([[0-9]]*\)/\1/'`
+ needed_minor_version=`echo $min_gnome_version | \
+ sed 's/[[^0-9]]*\([[0-9]]*\)\.\([[0-9]]*\)\.\([[0-9]]*\)/\2/'`
+ needed_micro_version=`echo $min_gnome_version | \
+ sed 's/[[^0-9]]*\([[0-9]]*\)\.\([[0-9]]*\)\.\([[0-9]]*\)/\3/'`
+
+ if test $gnome_config_major_version -lt $needed_major_version; then
+ ifelse([$3], , :, [$3])
+ no_gnome=yes
+ elif test $gnome_config_major_version = $needed_major_version; then
+ if test -n "$needed_minor_version" -a $gnome_config_minor_version -lt $needed_minor_version; then
+ ifelse([$3], , :, [$3])
+ no_gnome=yes
+ elif test -n "$needed_minor_version" -a $gnome_config_minor_version = $needed_minor_version; then
+ if test -n "$needed_micro_version" -a $gnome_config_micro_version -lt $needed_micro_version; then
+ ifelse([$3], , :, [$3])
+ no_gnome=yes
+ fi
+ fi
+ fi
+ fi
+ AC_SUBST(GNOME_CFLAGS)
+ AC_SUBST(GNOME_LIBS)
+ AC_SUBST(GNOMEUI_CFLAGS)
+ AC_SUBST(GNOMEUI_LIBS)
+
+ if test "x$no_gnome" = x ; then
+ AC_MSG_RESULT(yes)
+ ifelse([$2], , :, [$2])
+ else
+ AC_MSG_RESULT(no)
+ if test "$GNOME_CONFIG" = "no" ; then
+ echo "*** The gnome-config script installed by GNOME could not be found"
+ echo "*** If GNOME was installed in PREFIX, make sure PREFIX/bin is in"
+ echo "*** your path, or set the GNOME_CONFIG environment variable to the"
+ echo "*** full path to gnome-config."
+ else
+ :
+ fi
+ GNOME_CFLAGS=""
+ GNOME_LIBS=""
+ ifelse([$3], , :, [$3])
+ fi
+
+ tmp_gnome_libdir=`$GNOME_CONFIG $gnome_config_args --libdir`
+ if test -n "$4"; then
+ AC_MSG_CHECKING([for additional GNOME modules])
+ fi
+ for module in $4 ""; do
+ gnome_m4_notfound=no
+ if test "$module" = zvt; then
+ ZVT_LIBS="`$GNOME_CONFIG $gnome_config_args --libs zvt`"
+ AC_SUBST(ZVT_LIBS)
+ elif test "$module" = gtk; then
+ GTK_CFLAGS="`$GNOME_CONFIG $gnome_config_args --cflags gtk`"
+ GTK_LIBS="`$GNOME_CONFIG $gnome_config_args --libs gtk`"
+ AC_SUBST(GTK_CFLAGS)
+ AC_SUBST(GTK_LIBS)
+ elif test "$module" = "glib"; then
+ GLIB_CFLAGS="`$GNOME_CONFIG $gnome_config_args --cflags glib`"
+ GLIB_LIBS="`$GNOME_CONFIG $gnome_config_args --libs glib`"
+ AC_SUBST(GLIB_CFLAGS)
+ AC_SUBST(GLIB_LIBS)
+ elif test "$module" = "oaf"; then
+ OAF_CFLAGS="`$GNOME_CONFIG $gnome_config_args --cflags oaf`"
+ OAF_LIBS="`$GNOME_CONFIG $gnome_config_args --libs oaf`"
+ AC_SUBST(OAF_CFLAGS)
+ AC_SUBST(OAF_LIBS)
+ elif test "$module" = "gnorba"; then
+ GNORBA_CFLAGS="`$GNOME_CONFIG $gnome_config_args --cflags gnorba`"
+ GNORBA_LIBS="`$GNOME_CONFIG $gnome_config_args --libs gnorba`"
+ AC_SUBST(GNORBA_CFLAGS)
+ AC_SUBST(GNORBA_LIBS)
+ elif test -n "$module"; then
+ if $GNOME_CONFIG $gnome_config_args --cflags $module >/dev/null 2>&1; then
+ tmp_bsnom=`echo $module | tr a-z A-Z`
+ eval $tmp_bsnom'_CFLAGS'=\"`$GNOME_CONFIG $gnome_config_args --cflags $module`\"
+ eval $tmp_bsnom'_LIBS'=\"`$GNOME_CONFIG $gnome_config_args --libs $module`\"
+ else
+ AC_MSG_RESULT([*** $module library is not installed])
+ ifelse([$3], , :, [$3])
+ gnome_m4_notfound=yes
+ fi
+ fi
+ if test "$gnome_m4_notfound" = no; then
+ echo $ac_n " $module" 1>&6
+ fi
+ done
+ if test -n "$4"; then
+ AC_MSG_RESULT([])
+ fi
+
+ rm -f conf.gnometest
+])
diff --git a/gnome-base/nautilus/files/macros/nautilus-macros.m4 b/gnome-base/nautilus/files/macros/nautilus-macros.m4
new file mode 100644
index 000000000000..96ac4ce7d33e
--- /dev/null
+++ b/gnome-base/nautilus/files/macros/nautilus-macros.m4
@@ -0,0 +1,224 @@
+dnl ===========================================================================
+
+dnl NAUTILUS_VERSION_CANON(version)
+dnl 1
+
+AC_DEFUN(NAUTILUS_VERSION_CANON, [`
+
+ dnl Assumes that there are no more than 999 revisions at a level,
+ dnl no more than three levels of revision.
+ dnl
+ dnl Any more than that, and test starts messing up the numeric
+ dnl comparisons because its integers overflow, and there's no
+ dnl way to do string comparisons in the shell. Grr.
+ dnl
+ dnl Must come up with some way to fix this.
+
+ echo "$1" |
+ tr . '\012' |
+ sed -e 's/^/000/' -e 's/^.*\(...\)/\1/' |
+ tr -d '\012' |
+ sed 's/$/000000000/
+ s/^\(.........\).*/\1/'
+`])
+
+dnl NAUTILUS_VERSION_INSIST(package, get-version-cmd, operator, want-version-var)
+dnl 1 2 3 4
+
+AC_DEFUN(NAUTILUS_VERSION_INSIST, [
+ ez_want_version=[$]$4
+
+ case "$3" in
+ ">") ez_operator=-gt ;;
+ ">=") ez_operator=-ge ;;
+ "<") ez_operator=-lt ;;
+ "<=") ez_operator=-le ;;
+ "=") ez_operator=-eq ;;
+ "!=") ez_operator=-ne ;;
+ *) AC_ERROR(Unknown operator $3 in configure script) ;;
+ esac
+
+ AC_MSG_CHECKING(for $1 $3 [$ez_want_version])
+
+ if ez_installed_version="`$2`"
+ then
+ AC_MSG_RESULT([$ez_installed_version])
+ else
+ AC_ERROR($2 failed)
+ fi
+
+ if test "NAUTILUS_VERSION_CANON([$ez_installed_version])" "$ez_operator" \
+ "NAUTILUS_VERSION_CANON([$ez_want_version])"
+ then
+ :
+ AC_SUBST($4)
+ else
+ AC_ERROR($1 version [$ez_want_version] is required.)
+ fi
+])
+
+dnl NAUTILUS_PATH_FREETYPE2([MINIMUM-VERSION, [ACTION-IF-FOUND [, ACTION-IF-NOT-FOUND]]])
+dnl Test for FreeType2, and define FREETYPE2_CFLAGS and FREETYPE2_LIBS
+dnl
+dnl Shamelessly cut-n-pasted from libart
+dnl
+AC_DEFUN(NAUTILUS_PATH_FREETYPE2,
+[dnl
+dnl Get the cflags and libraries from the freetype-config script
+dnl
+AC_ARG_WITH(freetype2-prefix,[ --with-freetype2-prefix=PFX Prefix where FREETYPE2 is installed (optional)],
+ freetype2_prefix="$withval", freetype2_prefix="")
+AC_ARG_WITH(freetype2-exec-prefix,[ --with-freetype2-exec-prefix=PFX Exec prefix where FREETYPE2 is installed (optional)],
+ freetype2_exec_prefix="$withval", freetype2_exec_prefix="")
+AC_ARG_ENABLE(freetype2test, [ --disable-freetype2test Do not try to compile and run a test FREETYPE2 program],
+ , enable_freetype2test=yes)
+
+ if test x$freetype2_exec_prefix != x ; then
+ freetype2_args="$freetype2_args --exec-prefix=$freetype2_exec_prefix"
+ if test x${FREETYPE2_CONFIG+set} != xset ; then
+ FREETYPE2_CONFIG=$freetype2_exec_prefix/bin/freetype-config
+ fi
+ fi
+ if test x$freetype2_prefix != x ; then
+ freetype2_args="$freetype2_args --prefix=$freetype2_prefix"
+ if test x${FREETYPE2_CONFIG+set} != xset ; then
+ FREETYPE2_CONFIG=$freetype2_prefix/bin/freetype-config
+ fi
+ fi
+
+ AC_PATH_PROG(FREETYPE2_CONFIG, freetype-config, no)
+ min_freetype2_version=ifelse([$1], ,0.2.5,$1)
+ AC_MSG_CHECKING(for FREETYPE2 - version >= $min_freetype2_version)
+ no_freetype2=""
+ if test "$FREETYPE2_CONFIG" = "no" ; then
+ no_freetype2=yes
+ else
+ FREETYPE2_CFLAGS=`$FREETYPE2_CONFIG $freetype2conf_args --cflags`
+ FREETYPE2_LIBS=`$FREETYPE2_CONFIG $freetype2conf_args --libs`
+
+ freetype2_major_version=`$FREETYPE2_CONFIG $freetype2_args --version | \
+ sed 's/\([[0-9]]*\)[[:.]]\([[0-9]]*\)[[:.]]\([[0-9]]*\)/\1/'`
+ freetype2_minor_version=`$FREETYPE2_CONFIG $freetype2_args --version | \
+ sed 's/\([[0-9]]*\)[[:.]]\([[0-9]]*\)[[:.]]\([[0-9]]*\)/\2/'`
+ freetype2_micro_version=`$FREETYPE2_CONFIG $freetype2_args --version | \
+ sed 's/\([[0-9]]*\)[[:.]]\([[0-9]]*\)[[:.]]\([[0-9]]*\)/\3/'`
+
+ if test "x$enable_freetype2test" = "xyes" ; then
+ ac_save_CFLAGS="$CFLAGS"
+ ac_save_LIBS="$LIBS"
+ CFLAGS="$CFLAGS $FREETYPE2_CFLAGS"
+ LIBS="$LIBS $FREETYPE2_LIBS"
+dnl
+dnl Now check if the installed FREETYPE2 is sufficiently new. (Also sanity
+dnl checks the results of freetype-config to some extent
+dnl
+ rm -f conf.freetype2test
+ AC_TRY_RUN([
+#include <stdio.h>
+#include <stdlib.h>
+#include <string.h>
+#include <freetype/freetype.h>
+
+char*
+my_strdup (char *str)
+{
+ char *new_str;
+
+ if (str)
+ {
+ new_str = malloc ((strlen (str) + 1) * sizeof(char));
+ strcpy (new_str, str);
+ }
+ else
+ new_str = NULL;
+
+ return new_str;
+}
+
+int main ()
+{
+ int major, minor, micro;
+ char *tmp_version;
+
+ system ("touch conf.freetype2test");
+
+ /* HP/UX 9 (%@#!) writes to sscanf strings */
+ tmp_version = my_strdup("$min_freetype2_version");
+ if (sscanf(tmp_version, "%d.%d.%d", &major, &minor, &micro) != 3) {
+ printf("%s, bad version string\n", "$min_freetype2_version");
+ exit(1);
+ }
+
+ if (($freetype2_major_version > major) ||
+ (($freetype2_major_version == major) && ($freetype2_minor_version > minor)) ||
+ (($freetype2_major_version == major) && ($freetype2_minor_version == minor) && ($freetype2_micro_version >= micro)))
+ {
+ return 0;
+ }
+ else
+ {
+ printf("\n");
+ printf("*** \n");
+ printf("*** 'freetype-config --version' returned %d.%d.%d, but the minimum version\n", $freetype2_major_version, $freetype2_minor_version, $freetype2_micro_version);
+ printf("*** of FREETYPE2 required is %d.%d.%d. If freetype-config is correct, then it is\n", major, minor, micro);
+ printf("*** best to upgrade to the required version.\n");
+ printf("*** If freetype-config was wrong, set the environment variable FREETYPE2_CONFIG\n");
+ printf("*** to point to the correct copy of freetype-config, and remove the file\n");
+ printf("*** config.cache before re-running configure\n");
+ printf("*** \n");
+
+ return 1;
+ }
+}
+
+],, no_freetype2=yes,[echo $ac_n "cross compiling; assumed OK... $ac_c"])
+ CFLAGS="$ac_save_CFLAGS"
+ LIBS="$ac_save_LIBS"
+ fi
+ fi
+ if test "x$no_freetype2" = x ; then
+ AC_MSG_RESULT(yes)
+ ifelse([$2], , :, [$2])
+ else
+ AC_MSG_RESULT(no)
+ if test "$FREETYPE2_CONFIG" = "no" ; then
+ echo "*** The freetype-config script installed by FREETYPE2 could not be found"
+ echo "*** If FREETYPE2 was installed in PREFIX, make sure PREFIX/bin is in"
+ echo "*** your path, or set the FREETYPE2_CONFIG environment variable to the"
+ echo "*** full path to freetype-config."
+ else
+ if test -f conf.freetype2test ; then
+ :
+ else
+ echo "*** Could not run FREETYPE2 test program, checking why..."
+ CFLAGS="$CFLAGS $FREETYPE2_CFLAGS"
+ LIBS="$LIBS $FREETYPE2_LIBS"
+ AC_TRY_LINK([
+#include <stdio.h>
+#include <freetype/freetype.h>
+], [ return 0; ],
+ [ echo "*** The test program compiled, but did not run. This usually means"
+ echo "*** that the run-time linker is not finding FREETYPE2 or finding the wrong"
+ echo "*** version of FREETYPE2. If it is not finding FREETYPE2, you'll need to set your"
+ echo "*** LD_LIBRARY_PATH environment variable, or edit /etc/ld.so.conf to point"
+ echo "*** to the installed location Also, make sure you have run ldconfig if that"
+ echo "*** is required on your system"
+ echo "***"
+ echo "*** If you have an old version installed, it is best to remove it, although"
+ echo "*** you may also be able to get things to work by modifying LD_LIBRARY_PATH"],
+ [ echo "*** The test program failed to compile or link. See the file config.log for the"
+ echo "*** exact error that occured. This usually means FREETYPE2 was incorrectly installed"
+ echo "*** or that you have moved FREETYPE2 since it was installed. In the latter case, you"
+ echo "*** may want to edit the freetype-config script: $FREETYPE2_CONFIG" ])
+ CFLAGS="$ac_save_CFLAGS"
+ LIBS="$ac_save_LIBS"
+ fi
+ fi
+ FREETYPE2_CFLAGS=""
+ FREETYPE2_LIBS=""
+ ifelse([$3], , :, [$3])
+ fi
+ AC_SUBST(FREETYPE2_CFLAGS)
+ AC_SUBST(FREETYPE2_LIBS)
+ rm -f conf.freetype2test
+])
diff --git a/gnome-base/nautilus/nautilus-1.0.6-r4.ebuild b/gnome-base/nautilus/nautilus-1.0.6-r4.ebuild
deleted file mode 100644
index ff485bd2f8d4..000000000000
--- a/gnome-base/nautilus/nautilus-1.0.6-r4.ebuild
+++ /dev/null
@@ -1,91 +0,0 @@
-# Copyright 1999-2000 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License, v2 or later
-# Author Achim Gottinger <achim@gentoo.org>
-# Updated by Sebastian Werner <sebastian@werner-productions.de>
-# $Header: /var/cvsroot/gentoo-x86/gnome-base/nautilus/nautilus-1.0.6-r4.ebuild,v 1.1 2002/03/10 09:44:17 blocke Exp $
-
-
-S=${WORKDIR}/${P}
-DESCRIPTION="nautilus"
-SRC_URI="ftp://ftp.gnome.org/pub/GNOME/stable/sources/${PN}/${P}.tar.gz"
-
-HOMEPAGE="http://www.gnome.org/"
-
-RDEPEND="mozilla? ( >=net-www/mozilla-0.9.5 )
- >=app-admin/fam-oss-2.6.4
- >=media-sound/cdparanoia-3.9.8
- >=gnome-base/bonobo-1.0.9-r1
- >=gnome-base/gnome-core-1.4.0.4-r1
- >=gnome-base/libghttp-1.0.9-r1
- >=gnome-base/gnome-vfs-1.0.3
- >=gnome-base/librsvg-1.0.1
- >=gnome-base/eel-1.0.2
- >=gnome-extra/medusa-0.5.1-r1"
-
-DEPEND="${RDEPEND}
- nls? ( sys-devel/gettext )
- >=app-text/scrollkeeper-0.2
- >=dev-util/intltool-0.11"
-
-src_unpack() {
-
- unpack ${P}.tar.gz
-
- # The following is a temporary patch contributed by Naresh Donti
- # to fix the 50 defunct copies of sh caused by hyperbola. This patch
- # will no longer be needed with a future version of scrollkeeper.
- # see bug #566 for more information
-
- patch -p0 < ${FILESDIR}/nautilus-1.0.6-hyperbola.diff
-
-}
-
-src_compile() {
- local myconf
-
- if [ -z "`use nls`" ]
- then
- myconf="${myconf} --disable-nls"
- mkdir intl
- touch intl/libgettext.h
- fi
-
- if [ "`use mozilla`" ]
- then
- MOZILLA=${MOZILLA_FIVE_HOME}
- myconf="${myconf} --with-mozilla-lib-place=$MOZILLA \
- --with-mozilla-include-place=$MOZILLA/include"
-
- export MOZILLA_FIVE_HOME=$MOZILLA
- export LD_LIBRARY_PATH=$MOZILLA_FIVE_HOME
- else
- myconf="${myconf} --disable-mozilla-component"
- fi
-
- CFLAGS="${CFLAGS} `gnome-config --cflags gdk_pixbuf`"
-
- ./configure --host=${CHOST} \
- --prefix=/usr \
- --sysconfdir=/etc \
- --localstatedir=/var/lib \
- --enable-eazel-services=0 \
- ${myconf} || die
-
- emake || die
-}
-
-src_install() {
- make prefix=${D}/usr \
- sysconfdir=${D}/etc \
- localstatedir=${D}/var/lib \
- install || die
-
- # Fix missing icon in Gnome Spash
- insinto /usr/share/pixmaps
- newins nautilus-launch-icon.png gnome-launch-icon.png
-
- dodoc AUTHORS COPYING* ChangeLog* NEWS TODO
-
- # Fix permissions in order to resolve the mozilla-view issue
- chmod -R g+r,o+r ${D}/*
-}
diff --git a/gnome-base/nautilus/nautilus-1.0.6-r5.ebuild b/gnome-base/nautilus/nautilus-1.0.6-r5.ebuild
deleted file mode 100644
index b36dcfdbb347..000000000000
--- a/gnome-base/nautilus/nautilus-1.0.6-r5.ebuild
+++ /dev/null
@@ -1,95 +0,0 @@
-# Copyright 1999-2000 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License, v2 or later
-# Author Achim Gottinger <achim@gentoo.org>
-# Updated by Sebastian Werner <sebastian@werner-productions.de>
-# $Header: /var/cvsroot/gentoo-x86/gnome-base/nautilus/nautilus-1.0.6-r5.ebuild,v 1.1 2002/03/21 07:13:57 azarah Exp $
-
-
-S=${WORKDIR}/${P}
-DESCRIPTION="nautilus"
-SRC_URI="ftp://ftp.gnome.org/pub/GNOME/stable/sources/${PN}/${P}.tar.gz"
-
-HOMEPAGE="http://www.gnome.org/"
-
-RDEPEND="mozilla? ( >=net-www/mozilla-0.9.5 )
- >=app-admin/fam-oss-2.6.4
- >=media-sound/cdparanoia-3.9.8
- >=gnome-base/bonobo-1.0.9-r1
- >=gnome-base/gnome-core-1.4.0.4-r1
- >=gnome-base/libghttp-1.0.9-r1
- >=gnome-base/gnome-vfs-1.0.3
- >=gnome-base/librsvg-1.0.1
- >=gnome-base/eel-1.0.2
- >=gnome-extra/medusa-0.5.1-r1"
-
-DEPEND="${RDEPEND}
- nls? ( sys-devel/gettext )
- >=app-text/scrollkeeper-0.2
- >=dev-util/intltool-0.11"
-
-src_unpack() {
-
- unpack ${P}.tar.gz
-
- # The following is a temporary patch contributed by Naresh Donti
- # to fix the 50 defunct copies of sh caused by hyperbola. This patch
- # will no longer be needed with a future version of scrollkeeper.
- # see bug #566 for more information
-
- patch -p0 < ${FILESDIR}/nautilus-1.0.6-hyperbola.diff
-}
-
-src_compile() {
- local myconf
-
- if [ -z "`use nls`" ]
- then
- myconf="${myconf} --disable-nls"
- mkdir intl
- touch intl/libgettext.h
- fi
-
- if [ "`use mozilla`" ]
- then
- MOZILLA=${MOZILLA_FIVE_HOME}
- myconf="${myconf} --with-mozilla-lib-place=$MOZILLA \
- --with-mozilla-include-place=$MOZILLA/include"
-
- export MOZILLA_FIVE_HOME=$MOZILLA
- export LD_LIBRARY_PATH=$MOZILLA_FIVE_HOME
- else
- myconf="${myconf} --disable-mozilla-component"
- fi
-
- libtoolize --copy --force
- aclocal
- autoconf
-
- CFLAGS="${CFLAGS} `gnome-config --cflags gdk_pixbuf`"
-
- ./configure --host=${CHOST} \
- --prefix=/usr \
- --sysconfdir=/etc \
- --localstatedir=/var/lib \
- --enable-eazel-services=0 \
- ${myconf} || die
-
- emake || die
-}
-
-src_install() {
- make prefix=${D}/usr \
- sysconfdir=${D}/etc \
- localstatedir=${D}/var/lib \
- install || die
-
- # Fix missing icon in Gnome Spash
- insinto /usr/share/pixmaps
- newins nautilus-launch-icon.png gnome-launch-icon.png
-
- dodoc AUTHORS COPYING* ChangeLog* NEWS TODO
-
- # Fix permissions in order to resolve the mozilla-view issue
- chmod -R g+r,o+r ${D}/*
-}
-
diff --git a/gnome-base/nautilus/nautilus-1.0.6-r6.ebuild b/gnome-base/nautilus/nautilus-1.0.6-r8.ebuild
index 2a47bd26bb37..de3d6c62a7ff 100644
--- a/gnome-base/nautilus/nautilus-1.0.6-r6.ebuild
+++ b/gnome-base/nautilus/nautilus-1.0.6-r8.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License, v2 or later
# Author Achim Gottinger <achim@gentoo.org>
# Updated by Sebastian Werner <sebastian@werner-productions.de>
-# $Header: /var/cvsroot/gentoo-x86/gnome-base/nautilus/nautilus-1.0.6-r6.ebuild,v 1.1 2002/03/24 08:10:26 seemant Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnome-base/nautilus/nautilus-1.0.6-r8.ebuild,v 1.1 2002/04/27 15:52:35 azarah Exp $
S=${WORKDIR}/${P}
@@ -37,6 +37,27 @@ src_unpack() {
# see bug #566 for more information
patch -p0 < ${FILESDIR}/nautilus-1.0.6-hyperbola.diff
+
+ # This patch to fix http://bugs.gentoo.org/show_bug.cgi?id=2082
+ # (taken from
+ # http://lists.eazel.com/pipermail/nautilus-list/2002-April/008473.html)
+ # Credit to Kaoru Fukui <k_fukui@highway.ne.jp>. This is probably
+ # a temporary patch until the next nautilus.
+
+ cd ${S} ; patch -p1 < ${FILESDIR}/nautilus-1.0.6-mozilla-1.0_rc1.diff
+
+ # Add missing files
+ mkdir -p ${S}/intl
+ touch ${S}/intl/po2tbl.sed.in
+
+ # Libtoolize to fix .la files, and reconf automake stuff
+ cd ${S}
+ mkdir macros
+ cp ${FILESDIR}/macros/* macros
+ libtoolize --copy --force
+ aclocal -I macros
+ automake --add-missing
+ autoconf &>${S}/foo
}
src_compile() {
@@ -61,10 +82,6 @@ src_compile() {
myconf="${myconf} --disable-mozilla-component"
fi
- libtoolize --copy --force
- aclocal
- autoconf
-
CFLAGS="${CFLAGS} `gnome-config --cflags gdk_pixbuf`"
./configure --host=${CHOST} \