summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarinus Schraal <foser@gentoo.org>2004-04-30 13:25:43 +0000
committerMarinus Schraal <foser@gentoo.org>2004-04-30 13:25:43 +0000
commitb03dfefc531b0670472fe066b7b79968a460e39a (patch)
treed149550674cbbd6b66d9a73b88c95cae2dadb901 /gnome-base
parentAdded to ~ppc (Manifest recommit) (diff)
downloadgentoo-2-b03dfefc531b0670472fe066b7b79968a460e39a.tar.gz
gentoo-2-b03dfefc531b0670472fe066b7b79968a460e39a.tar.bz2
gentoo-2-b03dfefc531b0670472fe066b7b79968a460e39a.zip
fix building with new freetype
Diffstat (limited to 'gnome-base')
-rw-r--r--gnome-base/gnome-print/ChangeLog5
-rw-r--r--gnome-base/gnome-print/files/gnome-print-0.37-freetype_new_include.patch95
-rw-r--r--gnome-base/gnome-print/gnome-print-0.37.ebuild8
3 files changed, 105 insertions, 3 deletions
diff --git a/gnome-base/gnome-print/ChangeLog b/gnome-base/gnome-print/ChangeLog
index 84e687807aee..8ce76f2ca678 100644
--- a/gnome-base/gnome-print/ChangeLog
+++ b/gnome-base/gnome-print/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for gnome-base/gnome-print
# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-base/gnome-print/ChangeLog,v 1.20 2004/01/10 14:37:08 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnome-base/gnome-print/ChangeLog,v 1.21 2004/04/30 13:25:43 foser Exp $
+
+ 30 Apr 2004; foser <foser@gentoo.org> gnome-print-0.37.ebuild :
+ Add patch to fix build with >=freetype-2.1.7, patch provided by Benoit <b.boissinot@ifrance.com> in #44114
10 Jan 2004; <agriffis@gentoo.org> gnome-print-0.37.ebuild:
stable on alpha and ia64
diff --git a/gnome-base/gnome-print/files/gnome-print-0.37-freetype_new_include.patch b/gnome-base/gnome-print/files/gnome-print-0.37-freetype_new_include.patch
new file mode 100644
index 000000000000..36cf61d612cb
--- /dev/null
+++ b/gnome-base/gnome-print/files/gnome-print-0.37-freetype_new_include.patch
@@ -0,0 +1,95 @@
+diff -Naur gnome-print-0.37.origin/installer/gf-pfb.c gnome-print-0.37/installer/gf-pfb.c
+--- gnome-print-0.37.origin/installer/gf-pfb.c 2002-01-19 01:23:00.000000000 +0100
++++ gnome-print-0.37/installer/gf-pfb.c 2004-03-08 19:40:35.861812512 +0100
+@@ -12,7 +12,8 @@
+ #include <fcntl.h>
+ #include <string.h>
+ #include <ctype.h>
+-#include <freetype/freetype.h>
++#include <ft2build.h>
++#include FT_FREETYPE_H
+ #include "gf-pfb.h"
+
+ #define noVERBOSE
+diff -Naur gnome-print-0.37.origin/installer/gf-ttf.c gnome-print-0.37/installer/gf-ttf.c
+--- gnome-print-0.37.origin/installer/gf-ttf.c 2001-11-05 15:07:28.000000000 +0100
++++ gnome-print-0.37/installer/gf-ttf.c 2004-03-08 19:42:51.483194928 +0100
+@@ -32,7 +32,8 @@
+ #include <fcntl.h>
+ #include <string.h>
+ #include <ctype.h>
+-#include <freetype/freetype.h>
++#include <ft2build.h>
++#include FT_FREETYPE_H
+
+ #include "gf-ttf.h"
+
+diff -Naur gnome-print-0.37.origin/installer/gnome-font-install.c gnome-print-0.37/installer/gnome-font-install.c
+--- gnome-print-0.37.origin/installer/gnome-font-install.c 2002-01-22 22:44:55.000000000 +0100
++++ gnome-print-0.37/installer/gnome-font-install.c 2004-03-08 19:43:31.858057016 +0100
+@@ -26,7 +26,8 @@
+ #include <parser.h>
+ #include <xmlmemory.h>
+ /* End of ugly thing */
+-#include <freetype/freetype.h>
++#include <ft2build.h>
++#include FT_FREETYPE_H
+ #include <libgnome/gnome-defs.h>
+ #include <libgnome/gnome-util.h>
+ #include <libgnome/gnome-i18n.h>
+diff -Naur gnome-print-0.37.origin/libgnomeprint/gnome-font-face.c gnome-print-0.37/libgnomeprint/gnome-font-face.c
+--- gnome-print-0.37.origin/libgnomeprint/gnome-font-face.c 2002-09-15 22:49:12.000000000 +0200
++++ gnome-print-0.37/libgnomeprint/gnome-font-face.c 2004-03-08 19:46:11.832737168 +0100
+@@ -10,7 +10,8 @@
+ #include <fcntl.h>
+ #include <stdio.h>
+ #include <ctype.h>
+-#include <freetype/ftoutln.h>
++#include <ft2build.h>
++#include FT_OUTLINE_H
+ #include <locale.h>
+
+ #include <libgnomeprint/gnome-print-i18n.h>
+diff -Naur gnome-print-0.37.origin/libgnomeprint/gnome-font-private.h gnome-print-0.37/libgnomeprint/gnome-font-private.h
+--- gnome-print-0.37.origin/libgnomeprint/gnome-font-private.h 2001-12-05 23:07:58.000000000 +0100
++++ gnome-print-0.37/libgnomeprint/gnome-font-private.h 2004-03-08 19:46:47.087377648 +0100
+@@ -22,7 +22,8 @@
+
+ BEGIN_GNOME_DECLS
+
+-#include <freetype/freetype.h>
++#include <ft2build.h>
++#include FT_FREETYPE_H
+ #include <libgnomeprint/gp-character-block.h>
+ #include <libgnomeprint/gp-fontmap.h>
+ #include <libgnomeprint/gnome-font.h>
+diff -Naur gnome-print-0.37.origin/libgnomeprint/parseTT.c gnome-print-0.37/libgnomeprint/parseTT.c
+--- gnome-print-0.37.origin/libgnomeprint/parseTT.c 2002-08-27 20:46:20.000000000 +0200
++++ gnome-print-0.37/libgnomeprint/parseTT.c 2004-03-08 19:45:02.876220152 +0100
+@@ -107,9 +107,10 @@
+ #include <config.h>
+
+ #include <parseTT.h>
+-#include <freetype/freetype.h>
+-#include <freetype/ftglyph.h>
+-#include <freetype/ftoutln.h>
++#include <ft2build.h>
++#include FT_FREETYPE_H
++#include FT_GLYPH_H
++#include FT_OUTLINE_H
+ #include <stdio.h>
+ #include <stdlib.h>
+ #include <math.h>
+diff -Naur gnome-print-0.37.origin/libgnomeprint/parseTT.h gnome-print-0.37/libgnomeprint/parseTT.h
+--- gnome-print-0.37.origin/libgnomeprint/parseTT.h 2001-11-05 20:27:09.000000000 +0100
++++ gnome-print-0.37/libgnomeprint/parseTT.h 2004-03-08 19:45:32.614699216 +0100
+@@ -22,7 +22,8 @@
+ BEGIN_GNOME_DECLS
+
+ #include <glib.h>
+-#include <freetype/freetype.h>
++#include <ft2build.h>
++#include FT_FREETYPE_H
+
+ /*
+ * Convert loaded Freetype TTF face to Type1
diff --git a/gnome-base/gnome-print/gnome-print-0.37.ebuild b/gnome-base/gnome-print/gnome-print-0.37.ebuild
index 8dd2377281c1..82339f107d7e 100644
--- a/gnome-base/gnome-print/gnome-print-0.37.ebuild
+++ b/gnome-base/gnome-print/gnome-print-0.37.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-base/gnome-print/gnome-print-0.37.ebuild,v 1.4 2004/01/10 14:37:08 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnome-base/gnome-print/gnome-print-0.37.ebuild,v 1.5 2004/04/30 13:25:43 foser Exp $
inherit gnome.org libtool
@@ -8,7 +8,7 @@ IUSE="nls"
DESCRIPTION="GNOME printing library"
HOMEPAGE="http://www.gnome.org/"
-KEYWORDS="~x86 ~ppc ~sparc alpha hppa ia64"
+KEYWORDS="x86 ~ppc ~sparc alpha hppa ia64"
SLOT="0"
LICENSE="GPL-2"
@@ -28,6 +28,10 @@ src_unpack() {
cp ${S}/installer/Makefile.in ${S}/installer/Makefile.in.orig
sed -e 's:$(PERL) \($(top_srcdir)/run-gnome-font-install\):echo \1:' \
${S}/installer/Makefile.in.orig > ${S}/installer/Makefile.in
+
+ # fix build with freetype 2.1.7 and up (#44114)
+ epatch ${FILESDIR}/${P}-freetype_new_include.patch
+
}
src_compile() {