summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2007-10-17 23:03:17 +0000
committerGilles Dartiguelongue <eva@gentoo.org>2007-10-17 23:03:17 +0000
commit94d8f93375e32efa934986c868fca59f3e7ec854 (patch)
tree20f708bf0fdcea24eb09eef16bc23df44f493587 /gnome-base
parentbump to 0.8.1 (diff)
downloadgentoo-2-94d8f93375e32efa934986c868fca59f3e7ec854.tar.gz
gentoo-2-94d8f93375e32efa934986c868fca59f3e7ec854.tar.bz2
gentoo-2-94d8f93375e32efa934986c868fca59f3e7ec854.zip
bump to 2.20.1
(Portage version: 2.1.3.13)
Diffstat (limited to 'gnome-base')
-rw-r--r--gnome-base/gconf/ChangeLog7
-rw-r--r--gnome-base/gconf/files/digest-gconf-2.20.13
-rw-r--r--gnome-base/gconf/gconf-2.20.1.ebuild85
3 files changed, 94 insertions, 1 deletions
diff --git a/gnome-base/gconf/ChangeLog b/gnome-base/gconf/ChangeLog
index fa8a8ace8414..9b4c84dd5f14 100644
--- a/gnome-base/gconf/ChangeLog
+++ b/gnome-base/gconf/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for gnome-base/gconf
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-base/gconf/ChangeLog,v 1.171 2007/09/25 18:29:55 dang Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnome-base/gconf/ChangeLog,v 1.172 2007/10/17 23:03:16 eva Exp $
+
+*gconf-2.20.1 (17 Oct 2007)
+
+ 17 Oct 2007; Gilles Dartiguelongue <eva@gentoo.org> +gconf-2.20.1.ebuild:
+ bump to 2.20.1
25 Sep 2007; Daniel Gryniewicz <dang@gentoo.org> ChangeLog:
New series for Gnome 2.20
diff --git a/gnome-base/gconf/files/digest-gconf-2.20.1 b/gnome-base/gconf/files/digest-gconf-2.20.1
new file mode 100644
index 000000000000..4b902210b04c
--- /dev/null
+++ b/gnome-base/gconf/files/digest-gconf-2.20.1
@@ -0,0 +1,3 @@
+MD5 646fc896c6282a8f103365af0fa2e303 GConf-2.20.1.tar.bz2 1404919
+RMD160 743bee341731402e5d4938ee030adf4f463d9a52 GConf-2.20.1.tar.bz2 1404919
+SHA256 0fb446b87e71fe1089f43e671b5b7689ec91d781b5b2e8f0fc72d4a83a014838 GConf-2.20.1.tar.bz2 1404919
diff --git a/gnome-base/gconf/gconf-2.20.1.ebuild b/gnome-base/gconf/gconf-2.20.1.ebuild
new file mode 100644
index 000000000000..c5f9d9b6c442
--- /dev/null
+++ b/gnome-base/gconf/gconf-2.20.1.ebuild
@@ -0,0 +1,85 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/gnome-base/gconf/gconf-2.20.1.ebuild,v 1.1 2007/10/17 23:03:16 eva Exp $
+
+inherit gnome2
+
+MY_PN=GConf
+MY_P=${MY_PN}-${PV}
+PVP=(${PV//[-\._]/ })
+
+DESCRIPTION="Gnome Configuration System and Daemon"
+HOMEPAGE="http://www.gnome.org/"
+SRC_URI="mirror://gnome/sources/${MY_PN}/${PVP[0]}.${PVP[1]}/${MY_P}.tar.bz2"
+
+LICENSE="LGPL-2"
+SLOT="2"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="debug doc"
+
+RDEPEND=">=dev-libs/glib-2.10
+ >=x11-libs/gtk+-2.8.16
+ >=gnome-base/orbit-2.4
+ >=dev-libs/libxml2-2"
+DEPEND="${RDEPEND}
+ >=dev-util/intltool-0.35
+ >=dev-util/pkgconfig-0.9
+ doc? ( >=dev-util/gtk-doc-1 )"
+
+# FIXME : consider merging the tree (?)
+DOCS="AUTHORS ChangeLog NEWS README TODO"
+
+S="${WORKDIR}/${MY_P}"
+
+pkg_setup() {
+ G2CONF="${G2CONF} --enable-gtk $(use_enable debug)"
+ kill_gconf
+}
+
+src_install() {
+ gnome2_src_install
+
+ # hack hack
+ dodir /etc/gconf/gconf.xml.mandatory
+ dodir /etc/gconf/gconf.xml.defaults
+ touch "${D}"/etc/gconf/gconf.xml.mandatory/.keep${SLOT}
+ touch "${D}"/etc/gconf/gconf.xml.defaults/.keep${SLOT}
+
+ echo 'CONFIG_PROTECT_MASK="/etc/gconf"' > 50gconf
+ doenvd 50gconf || die
+ dodir /root/.gconfd
+}
+
+pkg_preinst() {
+ kill_gconf
+}
+
+pkg_postinst() {
+ kill_gconf
+
+ #change the permissions to avoid some gconf bugs
+ einfo "changing permissions for gconf dirs"
+ find /etc/gconf/ -type d -exec chmod ugo+rx "{}" \;
+
+ einfo "changing permissions for gconf files"
+ find /etc/gconf/ -type f -exec chmod ugo+r "{}" \;
+}
+
+kill_gconf() {
+ # this function will kill all running gconfd that could be causing troubles
+ if [ -x /usr/bin/gconftool ]
+ then
+ /usr/bin/gconftool --shutdown
+ fi
+ if [ -x /usr/bin/gconftool-1 ]
+ then
+ /usr/bin/gconftool-1 --shutdown
+ fi
+
+ # and for gconf 2
+ if [ -x /usr/bin/gconftool-2 ]
+ then
+ /usr/bin/gconftool-2 --shutdown
+ fi
+ return 0
+}