summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2010-07-13 09:16:52 +0000
committerPacho Ramos <pacho@gentoo.org>2010-07-13 09:16:52 +0000
commit245806f3c104cc4cf7fd580bacb30883c5b3a6c3 (patch)
treee41d30d1bbacc74e9f9d1c0e47806f2586dd3e22 /gnome-base
parentadded missing profile descriptions for prefix interix/winnt 6.1 profiles. (diff)
downloadgentoo-2-245806f3c104cc4cf7fd580bacb30883c5b3a6c3.tar.gz
gentoo-2-245806f3c104cc4cf7fd580bacb30883c5b3a6c3.tar.bz2
gentoo-2-245806f3c104cc4cf7fd580bacb30883c5b3a6c3.zip
Revision bump including latest gstreamer volume control support patch by Brian Cameron, it fixes volume update issue reported in bug #327609 by Morse.
(Portage version: 2.1.8.3/cvs/Linux x86_64)
Diffstat (limited to 'gnome-base')
-rw-r--r--gnome-base/gnome-settings-daemon/ChangeLog10
-rw-r--r--gnome-base/gnome-settings-daemon/gnome-settings-daemon-2.30.2-r1.ebuild85
2 files changed, 94 insertions, 1 deletions
diff --git a/gnome-base/gnome-settings-daemon/ChangeLog b/gnome-base/gnome-settings-daemon/ChangeLog
index 8cb4ce8dfdec..41612a064625 100644
--- a/gnome-base/gnome-settings-daemon/ChangeLog
+++ b/gnome-base/gnome-settings-daemon/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for gnome-base/gnome-settings-daemon
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-base/gnome-settings-daemon/ChangeLog,v 1.49 2010/06/23 11:28:08 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnome-base/gnome-settings-daemon/ChangeLog,v 1.50 2010/07/13 09:16:52 pacho Exp $
+
+*gnome-settings-daemon-2.30.2-r1 (13 Jul 2010)
+
+ 13 Jul 2010; Pacho Ramos <pacho@gentoo.org>
+ +gnome-settings-daemon-2.30.2-r1.ebuild:
+ Revision bump including latest gstreamer volume control support patch by
+ Brian Cameron, it fixes volume update issue reported in bug #327609 by
+ Morse.
*gnome-settings-daemon-2.30.2 (23 Jun 2010)
diff --git a/gnome-base/gnome-settings-daemon/gnome-settings-daemon-2.30.2-r1.ebuild b/gnome-base/gnome-settings-daemon/gnome-settings-daemon-2.30.2-r1.ebuild
new file mode 100644
index 000000000000..bc80cd7eefc4
--- /dev/null
+++ b/gnome-base/gnome-settings-daemon/gnome-settings-daemon-2.30.2-r1.ebuild
@@ -0,0 +1,85 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/gnome-base/gnome-settings-daemon/gnome-settings-daemon-2.30.2-r1.ebuild,v 1.1 2010/07/13 09:16:52 pacho Exp $
+
+EAPI="2"
+
+inherit autotools eutils gnome2
+
+DESCRIPTION="Gnome Settings Daemon"
+HOMEPAGE="http://www.gnome.org"
+SRC_URI="${SRC_URI}
+ mirror://gentoo/${PN}-2.30.2-gst-vol-control-support.patch.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~x86-solaris"
+IUSE="debug libnotify pulseaudio"
+
+RDEPEND=">=dev-libs/dbus-glib-0.74
+ >=dev-libs/glib-2.18.0
+ >=x11-libs/gtk+-2.16
+ >=gnome-base/gconf-2.6.1
+ >=gnome-base/libgnomekbd-2.29.5
+ >=gnome-base/gnome-desktop-2.29.92
+
+ x11-libs/libX11
+ x11-libs/libXi
+ x11-libs/libXrandr
+ x11-libs/libXext
+ x11-libs/libXxf86misc
+ >=x11-libs/libxklavier-5.0
+ media-libs/fontconfig
+
+ libnotify? ( >=x11-libs/libnotify-0.4.3 )
+ pulseaudio? (
+ >=media-sound/pulseaudio-0.9.15
+ media-libs/libcanberra[gtk] )
+ !pulseaudio? (
+ >=media-libs/gstreamer-0.10.1.2
+ >=media-libs/gst-plugins-base-0.10.1.2 )"
+DEPEND="${RDEPEND}
+ !<gnome-base/gnome-control-center-2.22
+ sys-devel/gettext
+ >=dev-util/intltool-0.40
+ >=dev-util/pkgconfig-0.19
+ x11-proto/inputproto
+ x11-proto/xproto"
+
+# README is empty
+DOCS="AUTHORS NEWS ChangeLog MAINTAINERS"
+
+pkg_setup() {
+ G2CONF="${G2CONF}
+ --disable-static
+ $(use_enable debug)
+ $(use_with libnotify)
+ $(use_enable pulseaudio pulse)
+ $(use_enable !pulseaudio gstreamer)"
+
+ if use pulseaudio; then
+ elog "Building volume media keys using Pulseaudio"
+ else
+ elog "Building volume media keys using GStreamer"
+ fi
+}
+
+src_prepare() {
+ gnome2_src_prepare
+
+ # Restore gstreamer volume control support, upstream bug #571145
+ epatch "${WORKDIR}/${PN}-2.30.2-gst-vol-control-support.patch"
+ echo "plugins/media-keys/cut-n-paste/gvc-gstreamer-acme-vol.c" >> po/POTFILES.in
+
+ intltoolize --force --copy --automake || die "intltoolize failed"
+ eautoreconf
+}
+
+pkg_postinst() {
+ gnome2_pkg_postinst
+
+ if ! use pulseaudio; then
+ elog "GStreamer volume control support is a feature powered by Gentoo GNOME Team"
+ elog "PLEASE DO NOT report bugs upstream, report on https://bugs.gentoo.org instead"
+ fi
+}