summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2014-06-29 09:45:10 +0000
committerMichał Górny <mgorny@gentoo.org>2014-06-29 09:45:10 +0000
commit0e8a5c81a64523341df33cb148e6f89c12728529 (patch)
tree94b0bdb3a77912ccf151d0784ddb50ff56f0bb8c /gnome-base
parentEnable multilib support, required for gnome-base/libgnomeprint. (diff)
downloadgentoo-2-0e8a5c81a64523341df33cb148e6f89c12728529.tar.gz
gentoo-2-0e8a5c81a64523341df33cb148e6f89c12728529.tar.bz2
gentoo-2-0e8a5c81a64523341df33cb148e6f89c12728529.zip
Enable multilib support, required for gnome-base/libgnomeprintui. Bug #515652.
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key EFB4464E!)
Diffstat (limited to 'gnome-base')
-rw-r--r--gnome-base/libgnomeprint/ChangeLog9
-rw-r--r--gnome-base/libgnomeprint/files/libgnomeprint-2.18.8-cups-config.patch39
-rw-r--r--gnome-base/libgnomeprint/libgnomeprint-2.18.8-r1.ebuild73
3 files changed, 120 insertions, 1 deletions
diff --git a/gnome-base/libgnomeprint/ChangeLog b/gnome-base/libgnomeprint/ChangeLog
index d4dc5c992b12..0f7db21fae30 100644
--- a/gnome-base/libgnomeprint/ChangeLog
+++ b/gnome-base/libgnomeprint/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for gnome-base/libgnomeprint
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-base/libgnomeprint/ChangeLog,v 1.197 2014/04/29 11:47:51 polynomial-c Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnome-base/libgnomeprint/ChangeLog,v 1.198 2014/06/29 09:45:10 mgorny Exp $
+
+*libgnomeprint-2.18.8-r1 (29 Jun 2014)
+
+ 29 Jun 2014; Michał Górny <mgorny@gentoo.org>
+ +files/libgnomeprint-2.18.8-cups-config.patch,
+ +libgnomeprint-2.18.8-r1.ebuild:
+ Enable multilib support, required for gnome-base/libgnomeprintui. Bug #515652.
29 Apr 2014; Lars Wendler <polynomial-c@gentoo.org>
libgnomeprint-2.18.8.ebuild, +files/libgnomeprint-2.18.8-bison3.patch:
diff --git a/gnome-base/libgnomeprint/files/libgnomeprint-2.18.8-cups-config.patch b/gnome-base/libgnomeprint/files/libgnomeprint-2.18.8-cups-config.patch
new file mode 100644
index 000000000000..d44b76b5dcbc
--- /dev/null
+++ b/gnome-base/libgnomeprint/files/libgnomeprint-2.18.8-cups-config.patch
@@ -0,0 +1,39 @@
+From ffbc68cc8518c7e7263a42d4284b749b40c5e871 Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Micha=C5=82=20G=C3=B3rny?= <mgorny@gentoo.org>
+Date: Sun, 29 Jun 2014 10:47:41 +0200
+Subject: [PATCH] Use AC_PATH_TOOL to find proper cups-config.
+
+---
+ configure.in | 9 +++++----
+ 1 file changed, 5 insertions(+), 4 deletions(-)
+
+diff --git a/configure.in b/configure.in
+index 729278d..186fabf 100644
+--- a/configure.in
++++ b/configure.in
+@@ -223,17 +223,18 @@ AC_ARG_WITH(cups,
+ )
+ if test "x$try_cups" = "xyes"; then
+ PKG_CHECK_MODULES(CUPS, "gmodule-2.0")
++ AC_PATH_TOOL(CUPS_CONFIG, cups-config)
+ AC_MSG_CHECKING(for CUPS libraries version >= 1.1.20)
+- if cups-config --version --libs > /dev/null 2>&1; then
+- verstxt=`cups-config --version`
++ if $CUPS_CONFIG --version --libs > /dev/null 2>&1; then
++ verstxt=`$CUPS_CONFIG --version`
+ vers=`echo "$verstxt" | \
+ awk -F. '{ printf "%d", ($1 * 1000 + $2) * 1000 + $3;}'`
+ if test "$vers" -lt 1001020; then
+ AC_MSG_RESULT(Cups found but the version found is less than 1.1.20)
+ cups_msg="Version requirement not satisfied"
+ else
+- CUPS_LIBS="$CUPS_LIBS `cups-config --ldflags` `cups-config --libs`"
+- CUPS_CFLAGS="$CUPS_CFLAGS `cups-config --cflags`"
++ CUPS_LIBS="$CUPS_LIBS `$CUPS_CONFIG --ldflags` `cups-config --libs`"
++ CUPS_CFLAGS="$CUPS_CFLAGS `$CUPS_CONFIG --cflags`"
+ AC_MSG_RESULT(Found version $verstxt)
+ fi
+
+--
+2.0.0
+
diff --git a/gnome-base/libgnomeprint/libgnomeprint-2.18.8-r1.ebuild b/gnome-base/libgnomeprint/libgnomeprint-2.18.8-r1.ebuild
new file mode 100644
index 000000000000..c1f7c325e04c
--- /dev/null
+++ b/gnome-base/libgnomeprint/libgnomeprint-2.18.8-r1.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/gnome-base/libgnomeprint/libgnomeprint-2.18.8-r1.ebuild,v 1.1 2014/06/29 09:45:10 mgorny Exp $
+
+EAPI="5"
+GCONF_DEBUG="no"
+GNOME_TARBALL_SUFFIX="bz2"
+
+inherit autotools eutils gnome2 multilib-minimal
+
+DESCRIPTION="Printer handling for Gnome"
+HOMEPAGE="http://www.gnome.org/"
+
+LICENSE="GPL-2 LGPL-2.1"
+SLOT="2.2"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~x86-linux ~x64-solaris ~x86-solaris"
+IUSE="cups doc"
+
+RDEPEND=">=dev-libs/glib-2.34.3[${MULTILIB_USEDEP}]
+ >=media-libs/libart_lgpl-2.3.21-r2[${MULTILIB_USEDEP}]
+ >=x11-libs/pango-1.36.3[${MULTILIB_USEDEP}]
+ >=dev-libs/libxml2-2.9.1-r4[${MULTILIB_USEDEP}]
+ >=media-libs/fontconfig-2.10.92[${MULTILIB_USEDEP}]
+ >=media-libs/freetype-2.5.0.1[${MULTILIB_USEDEP}]
+ >=sys-libs/zlib-1.2.8-r1[${MULTILIB_USEDEP}]
+ cups? (
+ >=net-print/cups-1.7.1-r1[${MULTILIB_USEDEP}]
+ >=net-print/libgnomecups-0.2.3-r3[${MULTILIB_USEDEP}] )"
+DEPEND="${RDEPEND}
+ sys-devel/gettext
+ >=dev-util/intltool-0.35
+ >=virtual/pkgconfig-0-r1[${MULTILIB_USEDEP}]
+ sys-devel/flex
+ sys-devel/bison
+ doc? (
+ ~app-text/docbook-xml-dtd-4.1.2
+ >=dev-util/gtk-doc-0.9 )"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-stdio-include.patch \
+ "${FILESDIR}"/${P}-freetype-2.5.1.patch \
+ "${FILESDIR}"/${P}-bison3.patch \
+ "${FILESDIR}"/${P}-cups-config.patch
+ eautoreconf
+ gnome2_src_prepare
+
+ # Drop DEPRECATED flags, bug #384807
+ sed -i -e 's:-D[A-Z_]*DISABLE_DEPRECATED::g' \
+ configure.in configure || die
+ sed -i -e 's:-D[A-Z_]*DISABLE_DEPRECATED:$(NULL):g' \
+ libgnomeprint/ttsubset/Makefile.am \
+ libgnomeprint/ttsubset/Makefile.in || die
+}
+
+multilib_src_configure() {
+ # Disable papi support until papi is in portage; avoids automagic
+ # dependencies on an untracked library.
+
+ ECONF_SOURCE=${S} \
+ gnome2_src_configure \
+ $(use_with cups) \
+ --without-papi \
+ --disable-static
+}
+
+multilib_src_install() {
+ gnome2_src_install
+}
+
+multilib_src_install_all() {
+ DOCS="AUTHORS BUGS ChangeLog* NEWS README"
+ einstalldocs
+}