summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNirbheek Chauhan <nirbheek@gentoo.org>2010-09-26 17:10:20 +0000
committerNirbheek Chauhan <nirbheek@gentoo.org>2010-09-26 17:10:20 +0000
commit0416b72a694aef820a66b72fb6fc2a964eee7df0 (patch)
tree90cec79718f4ad220d1469545f67597828092e5e /gnome-base
parentVersion bump (diff)
downloadgentoo-2-0416b72a694aef820a66b72fb6fc2a964eee7df0.tar.gz
gentoo-2-0416b72a694aef820a66b72fb6fc2a964eee7df0.tar.bz2
gentoo-2-0416b72a694aef820a66b72fb6fc2a964eee7df0.zip
Fix compilation against gtk+-2.22 by replacing eel_gdk_window_focus() with gdk_window_focus()
(Portage version: 2.1.9.10/cvs/Linux x86_64)
Diffstat (limited to 'gnome-base')
-rw-r--r--gnome-base/nautilus/ChangeLog9
-rw-r--r--gnome-base/nautilus/files/nautilus-2.30.1-remove-eel-gdk-window-focus.patch62
-rw-r--r--gnome-base/nautilus/nautilus-2.30.1-r2.ebuild89
3 files changed, 159 insertions, 1 deletions
diff --git a/gnome-base/nautilus/ChangeLog b/gnome-base/nautilus/ChangeLog
index a1d80b87ce7c..128f8b3ef8b2 100644
--- a/gnome-base/nautilus/ChangeLog
+++ b/gnome-base/nautilus/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for gnome-base/nautilus
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-base/nautilus/ChangeLog,v 1.355 2010/09/11 18:43:02 josejx Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnome-base/nautilus/ChangeLog,v 1.356 2010/09/26 17:10:20 nirbheek Exp $
+
+*nautilus-2.30.1-r2 (26 Sep 2010)
+
+ 26 Sep 2010; <nirbheek@gentoo.org> +nautilus-2.30.1-r2.ebuild,
+ +files/nautilus-2.30.1-remove-eel-gdk-window-focus.patch:
+ Fix compilation against gtk+-2.22 by replacing eel_gdk_window_focus() with
+ gdk_window_focus()
11 Sep 2010; Joseph Jezak <josejx@gentoo.org> nautilus-2.30.1-r1.ebuild:
Marked ppc for bug #324077.
diff --git a/gnome-base/nautilus/files/nautilus-2.30.1-remove-eel-gdk-window-focus.patch b/gnome-base/nautilus/files/nautilus-2.30.1-remove-eel-gdk-window-focus.patch
new file mode 100644
index 000000000000..969d38b96f9b
--- /dev/null
+++ b/gnome-base/nautilus/files/nautilus-2.30.1-remove-eel-gdk-window-focus.patch
@@ -0,0 +1,62 @@
+Fix compile failure with gtk+-2.22 by removing eel_gdk_window_focus.
+ * Patches **ported** from master repository, not needed 2.90 onwards
+ * Might be needed in 2.32
+
+--
+From 7e8d1dfa6a17fe9189bf2489b735cd6462f03571 Mon Sep 17 00:00:00 2001
+From: Cosimo Cecchi <cosimoc@gnome.org>
+Date: Sat, 21 Aug 2010 16:57:15 +0000
+Subject: [eel] remove eel_gdk_window_focus
+
+---
+From 6b06e0e27ca1cf29afd4fac716c58e15928a8ff8 Mon Sep 17 00:00:00 2001
+From: Cosimo Cecchi <cosimoc@gnome.org>
+Date: Sat, 21 Aug 2010 16:56:57 +0000
+Subject: icon-container: use gdk_window_focus
+
+---
+--- eel/eel-gdk-extensions.c
++++ eel/eel-gdk-extensions.c
+@@ -585,19 +585,7 @@
+ * the focus at this point. Do a little X trickery to
+ * ensure it is focused.
+ */
+- eel_gdk_window_focus (window, GDK_CURRENT_TIME);
+-}
+-
+-void
+-eel_gdk_window_focus (GdkWindow *window, guint32 timestamp)
+-{
+- gdk_error_trap_push ();
+- XSetInputFocus (GDK_DISPLAY (),
+- GDK_WINDOW_XWINDOW (window),
+- RevertToParent,
+- timestamp);
+- gdk_flush();
+- gdk_error_trap_pop ();
++ gdk_window_focus (window, GDK_CURRENT_TIME);
+ }
+
+ void
+--- eel/eel-gdk-extensions.h
++++ eel/eel-gdk-extensions.h
+@@ -137,8 +137,6 @@
+ /* Misc GdkWindow helper functions */
+ void eel_gdk_window_bring_to_front (GdkWindow *window);
+ void eel_gdk_window_set_invisible_cursor (GdkWindow *window);
+-void eel_gdk_window_focus (GdkWindow *window,
+- guint32 timestamp);
+ void eel_gdk_window_set_wm_protocols (GdkWindow *window,
+ GdkAtom *protocols,
+ int nprotocols);
+--- libnautilus-private/nautilus-icon-container.c
++++ libnautilus-private/nautilus-icon-container.c
+@@ -4475,7 +4475,7 @@
+ /* Ensure the window itself is focused.. */
+ toplevel = gtk_widget_get_toplevel (GTK_WIDGET (container));
+ if (toplevel != NULL && gtk_widget_get_realized (toplevel)) {
+- eel_gdk_window_focus (toplevel->window, GDK_CURRENT_TIME);
++ gdk_window_focus (toplevel->window, GDK_CURRENT_TIME);
+ }
+
+ return TRUE;
diff --git a/gnome-base/nautilus/nautilus-2.30.1-r2.ebuild b/gnome-base/nautilus/nautilus-2.30.1-r2.ebuild
new file mode 100644
index 000000000000..0cfeb7525175
--- /dev/null
+++ b/gnome-base/nautilus/nautilus-2.30.1-r2.ebuild
@@ -0,0 +1,89 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/gnome-base/nautilus/nautilus-2.30.1-r2.ebuild,v 1.1 2010/09/26 17:10:20 nirbheek Exp $
+
+EAPI="2"
+GCONF_DEBUG="no"
+
+inherit eutils gnome2 virtualx
+
+DESCRIPTION="A file manager for the GNOME desktop"
+HOMEPAGE="http://www.gnome.org/projects/nautilus/"
+
+LICENSE="GPL-2 LGPL-2 FDL-1.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd ~x86-interix ~amd64-linux ~x86-linux"
+IUSE="doc gnome xmp"
+
+RDEPEND=">=dev-libs/glib-2.24.0
+ >=gnome-base/gnome-desktop-2.29.91
+ >=x11-libs/pango-1.1.2
+ >=x11-libs/gtk+-2.20.0
+ >=dev-libs/libxml2-2.4.7
+ >=media-libs/libexif-0.5.12
+ >=gnome-base/gconf-2.0
+ dev-libs/libunique
+ dev-libs/dbus-glib
+ x11-libs/libXft
+ x11-libs/libXrender
+ xmp? ( >=media-libs/exempi-2 )"
+
+DEPEND="${RDEPEND}
+ >=dev-lang/perl-5
+ sys-devel/gettext
+ >=dev-util/pkgconfig-0.9
+ >=dev-util/intltool-0.40.1
+ doc? ( >=dev-util/gtk-doc-1.4 )"
+# For eautoreconf
+# gnome-base/gnome-common
+# dev-util/gtk-doc-am"
+
+PDEPEND="gnome? ( >=x11-themes/gnome-icon-theme-1.1.91 )
+ >=gnome-base/gvfs-0.1.2"
+
+DOCS="AUTHORS ChangeLog* HACKING MAINTAINERS NEWS README THANKS TODO"
+
+pkg_setup() {
+ G2CONF="${G2CONF}
+ --disable-update-mimedb
+ --disable-packagekit
+ $(use_enable xmp)"
+}
+
+src_prepare() {
+ gnome2_src_prepare
+
+ # Remove crazy CFLAGS
+ sed 's:-DG.*DISABLE_DEPRECATED::g' -i configure.in configure \
+ || die "sed 4 failed"
+
+ # Fix nautilus flipping-out with --no-desktop -- bug 266398
+ epatch "${FILESDIR}/${PN}-2.27.4-change-reg-desktop-file-with-no-desktop.patch"
+
+ # Do not show Unmount when showing Eject/Safe removal
+ epatch "${FILESDIR}/${P}-unmount-entries.patch"
+
+ # Fixes compilation with gtk+-2.22
+ epatch "${FILESDIR}/${PN}-2.30.1-remove-eel-gdk-window-focus.patch"
+}
+
+src_test() {
+ addwrite "/root/.gnome2_private"
+ unset SESSION_MANAGER
+ unset ORBIT_SOCKETDIR
+ unset DBUS_SESSION_BUS_ADDRESS
+ Xemake check || die "Test phase failed"
+}
+
+src_install() {
+ gnome2_src_install
+ find "${D}" -name "*.la" -delete || die "remove of la files failed"
+}
+
+pkg_postinst() {
+ gnome2_pkg_postinst
+
+ elog "nautilus can use gstreamer to preview audio files. Just make sure"
+ elog "to have the necessary plugins available to play the media type you"
+ elog "want to preview"
+}