summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2007-10-17 22:37:58 +0000
committerGilles Dartiguelongue <eva@gentoo.org>2007-10-17 22:37:58 +0000
commita836a432acad3318f2b8e9c963c864380b98dec7 (patch)
treed575333441940ae6d3e403a6c3fad0e4090df287 /gnome-base/orbit
parentbump to 2.20.1 (diff)
downloadgentoo-2-a836a432acad3318f2b8e9c963c864380b98dec7.tar.gz
gentoo-2-a836a432acad3318f2b8e9c963c864380b98dec7.tar.bz2
gentoo-2-a836a432acad3318f2b8e9c963c864380b98dec7.zip
bump to 2.14.10
(Portage version: 2.1.3.13)
Diffstat (limited to 'gnome-base/orbit')
-rw-r--r--gnome-base/orbit/ChangeLog7
-rw-r--r--gnome-base/orbit/files/digest-orbit-2.14.103
-rw-r--r--gnome-base/orbit/orbit-2.14.10.ebuild38
3 files changed, 47 insertions, 1 deletions
diff --git a/gnome-base/orbit/ChangeLog b/gnome-base/orbit/ChangeLog
index c7059ddd4b6f..4c4c41ca3a30 100644
--- a/gnome-base/orbit/ChangeLog
+++ b/gnome-base/orbit/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for gnome-base/orbit
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-base/orbit/ChangeLog,v 1.110 2007/09/27 11:26:04 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnome-base/orbit/ChangeLog,v 1.111 2007/10/17 22:37:57 eva Exp $
+
+*orbit-2.14.10 (17 Oct 2007)
+
+ 17 Oct 2007; Gilles Dartiguelongue <eva@gentoo.org> +orbit-2.14.10.ebuild:
+ bump to 2.14.10
27 Sep 2007; Raúl Porcel <armin76@gentoo.org> orbit-2.14.8-r3.ebuild:
alpha/ia64 stable wrt #193339
diff --git a/gnome-base/orbit/files/digest-orbit-2.14.10 b/gnome-base/orbit/files/digest-orbit-2.14.10
new file mode 100644
index 000000000000..74ddbc5598ab
--- /dev/null
+++ b/gnome-base/orbit/files/digest-orbit-2.14.10
@@ -0,0 +1,3 @@
+MD5 180f486f07d6db84aca0f71f68e54618 ORBit2-2.14.10.tar.bz2 734630
+RMD160 f6df0bf38218ba0d02e2e332d570cf3e1831ec53 ORBit2-2.14.10.tar.bz2 734630
+SHA256 d4cdd180a4f6b8a740d36b8eb6c5140bad31247484485a8d34c99132c9c406ef ORBit2-2.14.10.tar.bz2 734630
diff --git a/gnome-base/orbit/orbit-2.14.10.ebuild b/gnome-base/orbit/orbit-2.14.10.ebuild
new file mode 100644
index 000000000000..704c0f960dc0
--- /dev/null
+++ b/gnome-base/orbit/orbit-2.14.10.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/gnome-base/orbit/orbit-2.14.10.ebuild,v 1.1 2007/10/17 22:37:57 eva Exp $
+
+inherit gnome2 eutils
+
+MY_P="ORBit2-${PV}"
+PVP=(${PV//[-\._]/ })
+S=${WORKDIR}/${MY_P}
+
+DESCRIPTION="ORBit2 is a high-performance CORBA ORB"
+HOMEPAGE="http://www.gnome.org/"
+SRC_URI="mirror://gnome/sources/ORBit2/${PVP[0]}.${PVP[1]}/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2 LGPL-2"
+SLOT="2"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="doc"
+
+RDEPEND=">=dev-libs/glib-2.8
+ >=dev-libs/libIDL-0.8.2"
+
+DEPEND="${RDEPEND}
+ >=dev-util/pkgconfig-0.18
+ doc? ( >=dev-util/gtk-doc-1 )"
+
+MAKEOPTS="${MAKEOPTS} -j1"
+
+DOCS="AUTHORS ChangeLog HACKING MAINTAINERS NEWS README* TODO"
+
+src_compile() {
+ # We need to unset IDL_DIR, which is set by RSI's IDL. This causes certain
+ # files to be not found by autotools when compiling ORBit. See bug #58540
+ # for more information. Please don't remove -- 8/18/06
+ unset IDL_DIR
+
+ gnome2_src_compile
+}