summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2008-08-25 21:05:14 +0000
committerGilles Dartiguelongue <eva@gentoo.org>2008-08-25 21:05:14 +0000
commit624416521b6d6c164ca1a56775a836103c6992db (patch)
tree0a264bbdd274ff96655057a4bd24dfa44f6ab8c4 /gnome-base/orbit
parentVersion bump, #234741 (diff)
downloadgentoo-2-624416521b6d6c164ca1a56775a836103c6992db.tar.gz
gentoo-2-624416521b6d6c164ca1a56775a836103c6992db.tar.bz2
gentoo-2-624416521b6d6c164ca1a56775a836103c6992db.zip
bump to 2.14.14, portability fixes, optimization and fixes.
(Portage version: 2.2_rc8/cvs/Linux 2.6.24-gentoo-r8-mactel x86_64)
Diffstat (limited to 'gnome-base/orbit')
-rw-r--r--gnome-base/orbit/ChangeLog7
-rw-r--r--gnome-base/orbit/orbit-2.14.14.ebuild49
2 files changed, 55 insertions, 1 deletions
diff --git a/gnome-base/orbit/ChangeLog b/gnome-base/orbit/ChangeLog
index 28c63ba66b30..f25bc0fd0edf 100644
--- a/gnome-base/orbit/ChangeLog
+++ b/gnome-base/orbit/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for gnome-base/orbit
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-base/orbit/ChangeLog,v 1.132 2008/08/12 13:30:07 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnome-base/orbit/ChangeLog,v 1.133 2008/08/25 21:05:14 eva Exp $
+
+*orbit-2.14.14 (25 Aug 2008)
+
+ 25 Aug 2008; Gilles Dartiguelongue <eva@gentoo.org> +orbit-2.14.14.ebuild:
+ bump to 2.14.14, portability fixes, optimization and fixes.
12 Aug 2008; Raúl Porcel <armin76@gentoo.org> orbit-2.14.13.ebuild:
alpha/ia64/sparc stable wrt #229709
diff --git a/gnome-base/orbit/orbit-2.14.14.ebuild b/gnome-base/orbit/orbit-2.14.14.ebuild
new file mode 100644
index 000000000000..efb59620f71a
--- /dev/null
+++ b/gnome-base/orbit/orbit-2.14.14.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/gnome-base/orbit/orbit-2.14.14.ebuild,v 1.1 2008/08/25 21:05:14 eva Exp $
+
+inherit gnome2 eutils
+
+MY_P="ORBit2-${PV}"
+PVP=(${PV//[-\._]/ })
+S=${WORKDIR}/${MY_P}
+
+DESCRIPTION="ORBit2 is a high-performance CORBA ORB"
+HOMEPAGE="http://www.gnome.org/"
+SRC_URI="mirror://gnome/sources/ORBit2/${PVP[0]}.${PVP[1]}/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2 LGPL-2"
+SLOT="2"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="doc"
+
+RDEPEND=">=dev-libs/glib-2.8
+ >=dev-libs/libIDL-0.8.2"
+
+DEPEND="${RDEPEND}
+ >=dev-util/pkgconfig-0.18
+ doc? ( >=dev-util/gtk-doc-1 )"
+
+MAKEOPTS="${MAKEOPTS} -j1"
+
+DOCS="AUTHORS ChangeLog HACKING MAINTAINERS NEWS README* TODO"
+
+src_unpack() {
+ gnome2_src_unpack
+
+ # Filter out G_DISABLE_DEPRECATED to be future-proof, related to bug 213434
+ sed -i -e '/DISABLE_DEPRECATED/d' \
+ "${S}/linc2/src/Makefile.am" "${S}/linc2/src/Makefile.in"
+
+ sed -i -e 's:-DG_DISABLE_DEPRECATED::g' \
+ "${S}/configure.in" "${S}/configure"
+}
+
+src_compile() {
+ # We need to unset IDL_DIR, which is set by RSI's IDL. This causes certain
+ # files to be not found by autotools when compiling ORBit. See bug #58540
+ # for more information. Please don't remove -- 8/18/06
+ unset IDL_DIR
+
+ gnome2_src_compile
+}