summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2007-09-17 20:32:32 +0000
committerGilles Dartiguelongue <eva@gentoo.org>2007-09-17 20:32:32 +0000
commit48d25e0d7cff6b203d108656da9ea27ac1abe22a (patch)
tree86a0a15c3aa8ca33c1234f937bf7286ccb78de0b /gnome-base/orbit
parentRemoving citizen428 from metadata.xml (see #56803 for reference). (diff)
downloadgentoo-2-48d25e0d7cff6b203d108656da9ea27ac1abe22a.tar.gz
gentoo-2-48d25e0d7cff6b203d108656da9ea27ac1abe22a.tar.bz2
gentoo-2-48d25e0d7cff6b203d108656da9ea27ac1abe22a.zip
bump to 2.14.9
(Portage version: 2.1.3.9)
Diffstat (limited to 'gnome-base/orbit')
-rw-r--r--gnome-base/orbit/ChangeLog9
-rw-r--r--gnome-base/orbit/files/digest-orbit-2.14.93
-rw-r--r--gnome-base/orbit/orbit-2.14.9.ebuild38
3 files changed, 49 insertions, 1 deletions
diff --git a/gnome-base/orbit/ChangeLog b/gnome-base/orbit/ChangeLog
index 1eb146c704cd..d0f6e2ad164d 100644
--- a/gnome-base/orbit/ChangeLog
+++ b/gnome-base/orbit/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for gnome-base/orbit
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-base/orbit/ChangeLog,v 1.103 2007/08/24 21:46:10 dang Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnome-base/orbit/ChangeLog,v 1.104 2007/09/17 20:32:31 eva Exp $
+
+*orbit-2.14.9 (17 Sep 2007)
+
+ 17 Sep 2007; Gilles Dartiguelongue <eva@gentoo.org> +orbit-2.14.9.ebuild:
+ bump to 2.14.9
+ + Portability fix (Tor Lillqvist)
+ + Various fixes in GIOP and linc (Jules Colding)
*orbit-2.14.8-r3 (24 Aug 2007)
diff --git a/gnome-base/orbit/files/digest-orbit-2.14.9 b/gnome-base/orbit/files/digest-orbit-2.14.9
new file mode 100644
index 000000000000..00a503503b8b
--- /dev/null
+++ b/gnome-base/orbit/files/digest-orbit-2.14.9
@@ -0,0 +1,3 @@
+MD5 c7e7080ef27aca22f26ac21fcb5613a5 ORBit2-2.14.9.tar.bz2 732946
+RMD160 e165d38a0f83e94efa4d9d7b39a5ae42f6431eb5 ORBit2-2.14.9.tar.bz2 732946
+SHA256 f2b05dc6de9342d2206d5f6eada831a333781a644b6bfd476096b0f982f0acba ORBit2-2.14.9.tar.bz2 732946
diff --git a/gnome-base/orbit/orbit-2.14.9.ebuild b/gnome-base/orbit/orbit-2.14.9.ebuild
new file mode 100644
index 000000000000..4d8e06d3a7f0
--- /dev/null
+++ b/gnome-base/orbit/orbit-2.14.9.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/gnome-base/orbit/orbit-2.14.9.ebuild,v 1.1 2007/09/17 20:32:31 eva Exp $
+
+inherit gnome2 eutils
+
+MY_P="ORBit2-${PV}"
+PVP=(${PV//[-\._]/ })
+S=${WORKDIR}/${MY_P}
+
+DESCRIPTION="ORBit2 is a high-performance CORBA ORB"
+HOMEPAGE="http://www.gnome.org/"
+SRC_URI="mirror://gnome/sources/ORBit2/${PVP[0]}.${PVP[1]}/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2 LGPL-2"
+SLOT="2"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="doc"
+
+RDEPEND=">=dev-libs/glib-2.8
+ >=dev-libs/libIDL-0.8.2"
+
+DEPEND="${RDEPEND}
+ >=dev-util/pkgconfig-0.18
+ doc? ( >=dev-util/gtk-doc-1 )"
+
+MAKEOPTS="${MAKEOPTS} -j1"
+
+DOCS="AUTHORS ChangeLog HACKING MAINTAINERS NEWS README* TODO"
+
+src_compile() {
+ # We need to unset IDL_DIR, which is set by RSI's IDL. This causes certain
+ # files to be not found by autotools when compiling ORBit. See bug #58540
+ # for more information. Please don't remove -- 8/18/06
+ unset IDL_DIR
+
+ gnome2_src_compile
+}