summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Schlemmer <azarah@gentoo.org>2001-10-28 14:12:52 +0000
committerMartin Schlemmer <azarah@gentoo.org>2001-10-28 14:12:52 +0000
commit80b02321e39f180108980eb73535cb5c29f42f67 (patch)
treea879b91c113225fa384ef9f7a250b4269aaae447 /gnome-base/oaf
parentRemoved old version of gtk-gnutella, new version is 0.16 (diff)
downloadgentoo-2-80b02321e39f180108980eb73535cb5c29f42f67.tar.gz
gentoo-2-80b02321e39f180108980eb73535cb5c29f42f67.tar.bz2
gentoo-2-80b02321e39f180108980eb73535cb5c29f42f67.zip
updated
Diffstat (limited to 'gnome-base/oaf')
-rw-r--r--gnome-base/oaf/files/digest-oaf-0.6.71
-rw-r--r--gnome-base/oaf/oaf-0.6.7.ebuild57
2 files changed, 58 insertions, 0 deletions
diff --git a/gnome-base/oaf/files/digest-oaf-0.6.7 b/gnome-base/oaf/files/digest-oaf-0.6.7
new file mode 100644
index 000000000000..19f03b11c88b
--- /dev/null
+++ b/gnome-base/oaf/files/digest-oaf-0.6.7
@@ -0,0 +1 @@
+MD5 2bd788bb4346eea3681267088163ee8e oaf-0.6.7.tar.gz 548864
diff --git a/gnome-base/oaf/oaf-0.6.7.ebuild b/gnome-base/oaf/oaf-0.6.7.ebuild
new file mode 100644
index 000000000000..6fe83df5c98f
--- /dev/null
+++ b/gnome-base/oaf/oaf-0.6.7.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Achim Gottinger <achim@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/gnome-base/oaf/oaf-0.6.7.ebuild,v 1.1 2001/10/28 14:10:28 azarah Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="Object Activation Framework for GNOME"
+SRC_URI="ftp://ftp.gnome.org/pub/GNOME/stable/sources/${PN}/${P}.tar.gz"
+
+RDEPEND="virtual/glibc
+ >=dev-libs/popt-1.5
+ >=gnome-base/ORBit-0.5.10-r1
+ >=dev-libs/libxml-1.8.15"
+
+DEPEND="${RDEPEND}
+ >=sys-devel/perl-5
+ nls? ( sys-devel/gettext )"
+
+src_unpack() {
+ unpack ${A}
+
+ cd ${S}
+ cp -a configure configure.orig
+ sed -e "s:perl5\.00404:perl5.6.1:" configure.orig > configure
+ rm configure.orig
+}
+
+src_compile() {
+ local myconf
+
+ if [ -z "`use nls`" ]
+ then
+ myconf="--disable-nls"
+ fi
+
+ ./configure --host=${CHOST} \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --localstatedir=/var/lib \
+ ${myconf} || die
+
+ emake || die
+}
+
+src_install() {
+ make prefix=${D}/usr \
+ sysconfdir=${D}/etc \
+ localstatedir=${D}/var/lib \
+ install || die
+
+ dodoc AUTHORS COPYING* ChangeLog README
+ dodoc NEWS TODO
+}
+
+pkg_postinst() {
+ ldconfig -r ${ROOT}
+}