summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeemant Kulleen <seemant@gentoo.org>2005-10-11 13:30:44 +0000
committerSeemant Kulleen <seemant@gentoo.org>2005-10-11 13:30:44 +0000
commitf2f394807dd7ff9d8320ef3b78a685b0425f9e84 (patch)
tree0ae26edf9ea34bf0054dd6dbb81863e6e1435fd4 /gnome-base/nautilus
parent0.4.2 x86 stable. (diff)
downloadgentoo-2-f2f394807dd7ff9d8320ef3b78a685b0425f9e84.tar.gz
gentoo-2-f2f394807dd7ff9d8320ef3b78a685b0425f9e84.tar.bz2
gentoo-2-f2f394807dd7ff9d8320ef3b78a685b0425f9e84.zip
test can only run if userpriv in FEATURES. Also, removed ~ia64 and ~ppc64 keywords from 2.12 since gnome-vfs is a DEP and is missing those KEYWORDS
(Portage version: 2.0.53_rc5)
Diffstat (limited to 'gnome-base/nautilus')
-rw-r--r--gnome-base/nautilus/ChangeLog6
-rw-r--r--gnome-base/nautilus/nautilus-2.12.1.ebuild9
2 files changed, 11 insertions, 4 deletions
diff --git a/gnome-base/nautilus/ChangeLog b/gnome-base/nautilus/ChangeLog
index 15ad9b45685a..2351e46ca248 100644
--- a/gnome-base/nautilus/ChangeLog
+++ b/gnome-base/nautilus/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for gnome-base/nautilus
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-base/nautilus/ChangeLog,v 1.156 2005/10/10 08:21:35 hardave Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnome-base/nautilus/ChangeLog,v 1.157 2005/10/11 13:30:44 seemant Exp $
+
+ 11 Oct 2005; Seemant Kulleen <seemant@gentoo.org> nautilus-2.12.1.ebuild:
+ the test here needs to be run with userpriv, rather than root. Also removed
+ ia64 and ppc64, since gnome-vfs does not have those KEYWORDS, and is a DEPEND.
10 Oct 2005; Hardave Riar <hardave@gentoo.org> nautilus-2.10.1-r1.ebuild:
Stable on mips.
diff --git a/gnome-base/nautilus/nautilus-2.12.1.ebuild b/gnome-base/nautilus/nautilus-2.12.1.ebuild
index 0c9b9dae6af3..587638b3c0b3 100644
--- a/gnome-base/nautilus/nautilus-2.12.1.ebuild
+++ b/gnome-base/nautilus/nautilus-2.12.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-base/nautilus/nautilus-2.12.1.ebuild,v 1.1 2005/10/06 07:21:08 leonardop Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnome-base/nautilus/nautilus-2.12.1.ebuild,v 1.2 2005/10/11 13:30:44 seemant Exp $
inherit virtualx gnome2
@@ -9,7 +9,7 @@ HOMEPAGE="http://www.gnome.org/projects/nautilus/"
LICENSE="GPL-2 LGPL-2 FDL-1.1"
SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~mips ~ppc ~sparc ~x86"
IUSE=""
# cups flac gstreamer mad ogg vorbis
@@ -74,5 +74,8 @@ USE_DESTDIR="1"
#}
src_test() {
- Xmake check || die "Test phase failed"
+ if hasq userpriv $FEATURES ;
+ then
+ Xmake check || die "Test phase failed"
+ fi
}