summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2013-08-03 22:18:54 +0000
committerGilles Dartiguelongue <eva@gentoo.org>2013-08-03 22:18:54 +0000
commit54180ebb960c51eac16198fbbe4c6264e68c92fa (patch)
treed0405332048341957cf7d30f6aff256b62f6468d /gnome-base/librsvg
parentUpdate zsh-completion install after upstream cleanup. (diff)
downloadgentoo-2-54180ebb960c51eac16198fbbe4c6264e68c92fa.tar.gz
gentoo-2-54180ebb960c51eac16198fbbe4c6264e68c92fa.tar.bz2
gentoo-2-54180ebb960c51eac16198fbbe4c6264e68c92fa.zip
Version bump. Switch USE=tools to rsvg-view only, other tools were not installed.
(Portage version: 2.2.0_alpha192/cvs/Linux x86_64, signed Manifest commit with key C6085806)
Diffstat (limited to 'gnome-base/librsvg')
-rw-r--r--gnome-base/librsvg/ChangeLog8
-rw-r--r--gnome-base/librsvg/librsvg-2.37.0.ebuild109
2 files changed, 116 insertions, 1 deletions
diff --git a/gnome-base/librsvg/ChangeLog b/gnome-base/librsvg/ChangeLog
index b597cb3a232b..29894ec2242c 100644
--- a/gnome-base/librsvg/ChangeLog
+++ b/gnome-base/librsvg/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for gnome-base/librsvg
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-base/librsvg/ChangeLog,v 1.304 2013/04/09 16:43:23 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnome-base/librsvg/ChangeLog,v 1.305 2013/08/03 22:18:54 eva Exp $
+
+*librsvg-2.37.0 (03 Aug 2013)
+
+ 03 Aug 2013; Gilles Dartiguelongue <eva@gentoo.org> +librsvg-2.37.0.ebuild:
+ Version bump. Switch USE=tools to rsvg-view only, other tools were not
+ installed.
09 Apr 2013; Agostino Sarubbo <ago@gentoo.org> librsvg-2.36.4.ebuild:
Stable for sh, wrt bug #458984
diff --git a/gnome-base/librsvg/librsvg-2.37.0.ebuild b/gnome-base/librsvg/librsvg-2.37.0.ebuild
new file mode 100644
index 000000000000..1239979e57ab
--- /dev/null
+++ b/gnome-base/librsvg/librsvg-2.37.0.ebuild
@@ -0,0 +1,109 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/gnome-base/librsvg/librsvg-2.37.0.ebuild,v 1.1 2013/08/03 22:18:54 eva Exp $
+
+EAPI="5"
+GCONF_DEBUG="no"
+VALA_MIN_API_VERSION="0.18"
+VALA_USE_DEPEND="vapigen"
+
+inherit autotools eutils gnome2 multilib vala
+
+DESCRIPTION="Scalable Vector Graphics (SVG) rendering library"
+HOMEPAGE="https://live.gnome.org/LibRsvg"
+
+LICENSE="LGPL-2"
+SLOT="2"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~arm-linux ~x86-linux ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
+IUSE="+gtk +introspection tools vala"
+REQUIRED_USE="
+ vala? ( introspection )
+ tools? ( gtk )"
+
+RDEPEND="
+ >=dev-libs/glib-2.24:2
+ >=x11-libs/cairo-1.2
+ >=x11-libs/pango-1.32.6
+ >=dev-libs/libxml2-2.7:2
+ >=dev-libs/libcroco-0.6.1
+ x11-libs/gdk-pixbuf:2[introspection?]
+ gtk? (
+ >=x11-libs/gtk+-2.16:2
+ tools? ( >=x11-libs/gtk+-3:3 ) )
+ introspection? ( >=dev-libs/gobject-introspection-0.10.8 )
+"
+DEPEND="${RDEPEND}
+ dev-libs/gobject-introspection-common
+ dev-libs/vala-common
+ >=dev-util/gtk-doc-am-1.13
+ virtual/pkgconfig
+ vala? ( $(vala_depend) )
+"
+# >=gtk-doc-am-1.13, gobject-introspection-common, vala-common needed by eautoreconf
+
+src_prepare() {
+ # Make rsvg-view non-automagic
+ epatch "${FILESDIR}/${PN}-2.36.0-rsvg-view-automagic.patch"
+
+ use vala && vala_src_prepare
+
+ eautoreconf
+ gnome2_src_prepare
+}
+
+src_configure() {
+ DOCS="AUTHORS ChangeLog README NEWS TODO"
+
+ local myconf=""
+
+ # -Bsymbolic is not supported by the Darwin toolchain
+ if [[ ${CHOST} == *-darwin* ]]; then
+ myconf="${myconf} --disable-Bsymbolic"
+ fi
+
+ gnome2_src_configure \
+ --disable-static \
+ --disable-tools \
+ $(use_enable tools rsvg-view) \
+ $(use_enable gtk gtk-theme) \
+ $(use_enable introspection) \
+ $(use_enable vala) \
+ --enable-pixbuf-loader \
+ ${myconf}
+}
+
+src_compile() {
+ # causes segfault if set, see bug #411765
+ unset __GL_NO_DSO_FINALIZER
+ gnome2_src_compile
+}
+
+pkg_postinst() {
+ # causes segfault if set, see bug 375615
+ unset __GL_NO_DSO_FINALIZER
+
+ tmp_file=$(mktemp -t tmp.XXXXXXXXXXlibrsvg_ebuild)
+ # be atomic!
+ gdk-pixbuf-query-loaders > "${tmp_file}"
+ if [ "${?}" = "0" ]; then
+ cat "${tmp_file}" > "${EROOT}usr/$(get_libdir)/gdk-pixbuf-2.0/2.10.0/loaders.cache"
+ else
+ ewarn "Cannot update loaders.cache, gdk-pixbuf-query-loaders failed to run"
+ fi
+ rm "${tmp_file}"
+}
+
+pkg_postrm() {
+ # causes segfault if set, see bug 375615
+ unset __GL_NO_DSO_FINALIZER
+
+ tmp_file=$(mktemp -t tmp.XXXXXXXXXXlibrsvg_ebuild)
+ # be atomic!
+ gdk-pixbuf-query-loaders > "${tmp_file}"
+ if [ "${?}" = "0" ]; then
+ cat "${tmp_file}" > "${EROOT}usr/$(get_libdir)/gdk-pixbuf-2.0/2.10.0/loaders.cache"
+ else
+ ewarn "Cannot update loaders.cache, gdk-pixbuf-query-loaders failed to run"
+ fi
+ rm "${tmp_file}"
+}