summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2011-01-27 11:57:29 +0000
committerPacho Ramos <pacho@gentoo.org>2011-01-27 11:57:29 +0000
commitbcb1dedf21d30a2f85bf594011115bd33c0bfb3f (patch)
tree071c1a1153ac3691099ab31f2fba6ab053df798e /gnome-base/libgnomeui
parentDon't build tests when unneeded (bug #226227), bump to eapi3, set GCONF_DEBUG... (diff)
downloadgentoo-2-bcb1dedf21d30a2f85bf594011115bd33c0bfb3f.tar.gz
gentoo-2-bcb1dedf21d30a2f85bf594011115bd33c0bfb3f.tar.bz2
gentoo-2-bcb1dedf21d30a2f85bf594011115bd33c0bfb3f.zip
Don't build tests when not needed (bug #226229), bump to eapi3, stop inheritting unneded eclass, update homepage.
(Portage version: 2.1.9.35/cvs/Linux x86_64)
Diffstat (limited to 'gnome-base/libgnomeui')
-rw-r--r--gnome-base/libgnomeui/ChangeLog6
-rw-r--r--gnome-base/libgnomeui/libgnomeui-2.24.4.ebuild17
2 files changed, 18 insertions, 5 deletions
diff --git a/gnome-base/libgnomeui/ChangeLog b/gnome-base/libgnomeui/ChangeLog
index f33ae63faa3a..d28499707722 100644
--- a/gnome-base/libgnomeui/ChangeLog
+++ b/gnome-base/libgnomeui/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for gnome-base/libgnomeui
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-base/libgnomeui/ChangeLog,v 1.199 2011/01/19 21:24:26 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnome-base/libgnomeui/ChangeLog,v 1.200 2011/01/27 11:57:29 pacho Exp $
+
+ 27 Jan 2011; Pacho Ramos <pacho@gentoo.org> libgnomeui-2.24.4.ebuild:
+ Don't build tests when not needed (bug #226229), bump to eapi3, stop
+ inheritting unneded eclass, update homepage.
19 Jan 2011; Markos Chandras <hwoarang@gentoo.org> libgnomeui-2.24.4.ebuild:
Stable on amd64 wrt bug #348987
diff --git a/gnome-base/libgnomeui/libgnomeui-2.24.4.ebuild b/gnome-base/libgnomeui/libgnomeui-2.24.4.ebuild
index 3e30135febf6..c8dee8324671 100644
--- a/gnome-base/libgnomeui/libgnomeui-2.24.4.ebuild
+++ b/gnome-base/libgnomeui/libgnomeui-2.24.4.ebuild
@@ -1,18 +1,19 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-base/libgnomeui/libgnomeui-2.24.4.ebuild,v 1.3 2011/01/19 21:24:26 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnome-base/libgnomeui/libgnomeui-2.24.4.ebuild,v 1.4 2011/01/27 11:57:29 pacho Exp $
+EAPI="3"
GCONF_DEBUG="no"
-inherit eutils gnome2
+inherit gnome2
DESCRIPTION="User Interface routines for Gnome"
-HOMEPAGE="http://www.gnome.org/"
+HOMEPAGE="http://library.gnome.org/devel/libgnomeui/stable/"
LICENSE="LGPL-2"
SLOT="0"
KEYWORDS="~alpha amd64 ~arm ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc x86 ~x86-fbsd ~x86-interix ~amd64-linux ~x86-linux ~sparc-solaris ~x86-solaris"
-IUSE="doc"
+IUSE="doc test"
# gtk+-2.14 dep instead of 2.12 ensures system doesn't loose VFS capabilities in GtkFilechooser
RDEPEND=">=dev-libs/libxml2-2.4.20
@@ -36,3 +37,11 @@ DEPEND="${RDEPEND}
PDEPEND="x11-themes/gnome-icon-theme"
DOCS="AUTHORS ChangeLog NEWS README"
+
+src_prepare() {
+ gnome2_src_prepare
+
+ if ! use test; then
+ sed 's/ test-gnome//' -i Makefile.am Makefile.in || die "sed failed"
+ fi
+}